mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux to 3.2.1-1
This commit is contained in:
parent
893caf1e09
commit
bcd04dcc1e
8 changed files with 1085 additions and 768 deletions
|
@ -8,15 +8,15 @@ pkgbase=linux
|
|||
pkgname=('linux' 'linux-headers')
|
||||
# pkgname=linux-custom # Build kernel with a different name
|
||||
_kernelname=${pkgname#linux}
|
||||
_basekernel=3.1
|
||||
pkgver=${_basekernel}.7
|
||||
pkgrel=2
|
||||
_basekernel=3.2
|
||||
pkgver=${_basekernel}.1
|
||||
pkgrel=1
|
||||
arch=('arm')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'uboot-mkimage')
|
||||
options=('!strip')
|
||||
source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.x/linux-${_basekernel}.tar.bz2"
|
||||
source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.x/linux-${_basekernel}.tar.xz"
|
||||
"ftp://ftp.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.bz2"
|
||||
'archlinuxarm.patch'
|
||||
'support.patch'
|
||||
|
@ -25,19 +25,17 @@ source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.x/linux-${_basekernel}.tar.bz2
|
|||
'aufs3-standalone.patch'
|
||||
'aufs3-git-extras.patch'
|
||||
'config'
|
||||
'change-default-console-loglevel.patch'
|
||||
'usb-add-reset-resume-quirk-for-several-webcams.patch')
|
||||
md5sums=('8d43453f8159b2332ad410b19d86a931'
|
||||
'13ea1e611a0a580138b8203e6f1353ed'
|
||||
'18f59dbd0df3dd7b36e8c4714e2c6725'
|
||||
'change-default-console-loglevel.patch')
|
||||
md5sums=('364066fa18767ec0ae5f4e4abcf9dc51'
|
||||
'31fc34340f11118873463a1d59d47b7f'
|
||||
'642ee27498d0db67bb626acf88f2f786'
|
||||
'f5d3635da03cb45904bedd69b47133de'
|
||||
'3f64ed9d71499fe9293dc671f4e4087e'
|
||||
'29628745258df910abfb8cb24ca3ccd9'
|
||||
'c9e6e8bb0774a89f7f9bd30a13be7532'
|
||||
'55b04499a4578e586cf5a4d0b69fc5aa'
|
||||
'5c5d2cf86500362353bced8f6764addc'
|
||||
'9d3c56a4b999c8bfbd4018089a62f662'
|
||||
'd00814b57448895e65fbbc800e8a58ba')
|
||||
'3b763062a5503534c2e11c6d0f45b185'
|
||||
'44a5461daf301a46adf20c475069aaa7'
|
||||
'9c1d9e47a0991b9d3d1f1ede01171c04'
|
||||
'8da3fed1e26cb1e76dd44e7a84872fd0'
|
||||
'133e7ede6ffc62f77f8d6c8e9f79022d'
|
||||
'9d3c56a4b999c8bfbd4018089a62f662')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/linux-${_basekernel}"
|
||||
|
@ -45,10 +43,6 @@ build() {
|
|||
# add upstream patch
|
||||
patch -p1 -i "${srcdir}/patch-${pkgver}"
|
||||
|
||||
# Add the USB_QUIRK_RESET_RESUME for several webcams
|
||||
# FS#26528
|
||||
patch -Np1 -i "${srcdir}/usb-add-reset-resume-quirk-for-several-webcams.patch"
|
||||
|
||||
# Add Arch Linux ARM patch for ARMv5te plug computers and requested additional support
|
||||
patch -Np1 -i "${srcdir}/archlinuxarm.patch"
|
||||
patch -Np1 -i "${srcdir}/support.patch"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
diff -urN a/arch/arm/mach-kirkwood/dockstar-setup.c b/arch/arm/mach-kirkwood/dockstar-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/dockstar-setup.c 2011-10-24 01:10:05.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/dockstar-setup.c 2012-01-14 03:32:44.000000000 -0700
|
||||
--- a/arch/arm/mach-kirkwood/dockstar-setup.c 2012-01-04 16:55:44.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/dockstar-setup.c 2012-01-21 19:54:46.000000000 -0700
|
||||
@@ -19,7 +19,6 @@
|
||||
#include <asm/mach-types.h>
|
||||
#include <asm/mach/arch.h>
|
||||
|
@ -54,7 +54,7 @@ diff -urN a/arch/arm/mach-kirkwood/dockstar-setup.c b/arch/arm/mach-kirkwood/doc
|
|||
|
||||
diff -urN a/arch/arm/mach-kirkwood/goflexhome-setup.c b/arch/arm/mach-kirkwood/goflexhome-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/goflexhome-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/goflexhome-setup.c 2012-01-14 03:32:44.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/goflexhome-setup.c 2012-01-21 23:29:42.000000000 -0700
|
||||
@@ -0,0 +1,123 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/goflexhome-setup.c
|
||||
|
@ -171,7 +171,7 @@ diff -urN a/arch/arm/mach-kirkwood/goflexhome-setup.c b/arch/arm/mach-kirkwood/g
|
|||
+
|
||||
+MACHINE_START(GOFLEXHOME, "Seagate GoFlex Home")
|
||||
+ /* Maintainer: Peter Carmichael <peterjncarm@ovi.com> */
|
||||
+ .boot_params = 0x00000100,
|
||||
+ .atag_offset = 0x100,
|
||||
+ .init_machine = goflexhome_init,
|
||||
+ .map_io = kirkwood_map_io,
|
||||
+ .init_early = kirkwood_init_early,
|
||||
|
@ -181,7 +181,7 @@ diff -urN a/arch/arm/mach-kirkwood/goflexhome-setup.c b/arch/arm/mach-kirkwood/g
|
|||
+
|
||||
diff -urN a/arch/arm/mach-kirkwood/goflexnet-setup.c b/arch/arm/mach-kirkwood/goflexnet-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/goflexnet-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/goflexnet-setup.c 2012-01-14 03:32:44.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/goflexnet-setup.c 2012-01-21 23:29:47.000000000 -0700
|
||||
@@ -0,0 +1,176 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/goflexnet-setup.c
|
||||
|
@ -351,7 +351,7 @@ diff -urN a/arch/arm/mach-kirkwood/goflexnet-setup.c b/arch/arm/mach-kirkwood/go
|
|||
+
|
||||
+MACHINE_START(GOFLEXNET, "Seagate GoFlex Net")
|
||||
+ /* Maintainer: Peter Carmichael <peterjncarm@ovi.com> */
|
||||
+ .boot_params = 0x00000100,
|
||||
+ .atag_offset = 0x100,
|
||||
+ .init_machine = goflexnet_init,
|
||||
+ .map_io = kirkwood_map_io,
|
||||
+ .init_early = kirkwood_init_early,
|
||||
|
@ -360,8 +360,8 @@ diff -urN a/arch/arm/mach-kirkwood/goflexnet-setup.c b/arch/arm/mach-kirkwood/go
|
|||
+MACHINE_END
|
||||
+
|
||||
diff -urN a/arch/arm/mach-kirkwood/guruplug-setup.c b/arch/arm/mach-kirkwood/guruplug-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/guruplug-setup.c 2011-10-24 01:10:05.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/guruplug-setup.c 2012-01-14 03:32:44.000000000 -0700
|
||||
--- a/arch/arm/mach-kirkwood/guruplug-setup.c 2012-01-04 16:55:44.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/guruplug-setup.c 2012-01-21 19:54:46.000000000 -0700
|
||||
@@ -57,22 +57,24 @@
|
||||
|
||||
static struct gpio_led guruplug_led_pins[] = {
|
||||
|
@ -393,7 +393,7 @@ diff -urN a/arch/arm/mach-kirkwood/guruplug-setup.c b/arch/arm/mach-kirkwood/gur
|
|||
},
|
||||
diff -urN a/arch/arm/mach-kirkwood/iconnect-setup.c b/arch/arm/mach-kirkwood/iconnect-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/iconnect-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/iconnect-setup.c 2012-01-14 03:32:44.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/iconnect-setup.c 2012-01-21 23:29:51.000000000 -0700
|
||||
@@ -0,0 +1,203 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/iconnect-setup.c
|
||||
|
@ -591,7 +591,7 @@ diff -urN a/arch/arm/mach-kirkwood/iconnect-setup.c b/arch/arm/mach-kirkwood/ico
|
|||
+
|
||||
+
|
||||
+MACHINE_START(ICONNECT, "Iomega iConnect Wireless")
|
||||
+ .boot_params = 0x00000100,
|
||||
+ .atag_offset = 0x100,
|
||||
+ .init_machine = iconnect_init,
|
||||
+ .map_io = kirkwood_map_io,
|
||||
+ .init_early = kirkwood_init_early,
|
||||
|
@ -599,9 +599,9 @@ diff -urN a/arch/arm/mach-kirkwood/iconnect-setup.c b/arch/arm/mach-kirkwood/ico
|
|||
+ .timer = &kirkwood_timer,
|
||||
+MACHINE_END
|
||||
diff -urN a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
|
||||
--- a/arch/arm/mach-kirkwood/Kconfig 2011-10-24 01:10:05.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/Kconfig 2012-01-14 04:04:19.000000000 -0700
|
||||
@@ -64,6 +64,31 @@
|
||||
--- a/arch/arm/mach-kirkwood/Kconfig 2012-01-04 16:55:44.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/Kconfig 2012-01-21 20:01:00.000000000 -0700
|
||||
@@ -64,6 +64,36 @@
|
||||
Say 'Y' here if you want your kernel to support the
|
||||
Seagate FreeAgent DockStar.
|
||||
|
||||
|
@ -621,8 +621,13 @@ diff -urN a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
|
|||
+ bool "Iomega iConnect Wireless"
|
||||
+ help
|
||||
+ Say 'Y' here if you want your kernel to support the
|
||||
+ Iomega iConnect Wireless. Overrides Marvell RD-88F6281
|
||||
+ Reference Board.
|
||||
+ Iomega iConnect Wireless.
|
||||
+
|
||||
+config MACH_POGO_E02
|
||||
+ bool "Pogoplug E02"
|
||||
+ help
|
||||
+ Say 'Y' here if you want your kernel to support the
|
||||
+ CloudEngines Pogoplug e02.
|
||||
+
|
||||
+config MACH_POGOPLUGV4
|
||||
+ bool "Pogoplug Series 4"
|
||||
|
@ -634,22 +639,23 @@ diff -urN a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
|
|||
bool
|
||||
|
||||
diff -urN a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
|
||||
--- a/arch/arm/mach-kirkwood/Makefile 2011-10-24 01:10:05.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/Makefile 2012-01-14 03:36:39.000000000 -0700
|
||||
@@ -8,6 +8,10 @@
|
||||
--- a/arch/arm/mach-kirkwood/Makefile 2012-01-04 16:55:44.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/Makefile 2012-01-21 23:11:47.000000000 -0700
|
||||
@@ -8,6 +8,11 @@
|
||||
obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG) += sheevaplug-setup.o
|
||||
obj-$(CONFIG_MACH_GURUPLUG) += guruplug-setup.o
|
||||
obj-$(CONFIG_MACH_DOCKSTAR) += dockstar-setup.o
|
||||
+obj-$(CONFIG_MACH_GOFLEXNET) += goflexnet-setup.o
|
||||
+obj-$(CONFIG_MACH_GOFLEXHOME) += goflexhome-setup.o
|
||||
+obj-$(CONFIG_MACH_ICONNECT) += iconnect-setup.o
|
||||
+obj-$(CONFIG_MACH_POGO_E02) += pogo_e02-setup.o
|
||||
+obj-$(CONFIG_MACH_POGOPLUGV4) += pogoplugv4-setup.o
|
||||
obj-$(CONFIG_MACH_TS219) += ts219-setup.o tsx1x-common.o
|
||||
obj-$(CONFIG_MACH_TS41X) += ts41x-setup.o tsx1x-common.o
|
||||
obj-$(CONFIG_MACH_OPENRD) += openrd-setup.o
|
||||
diff -urN a/arch/arm/mach-kirkwood/mpp.h b/arch/arm/mach-kirkwood/mpp.h
|
||||
--- a/arch/arm/mach-kirkwood/mpp.h 2011-10-24 01:10:05.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/mpp.h 2012-01-14 03:32:44.000000000 -0700
|
||||
--- a/arch/arm/mach-kirkwood/mpp.h 2012-01-04 16:55:44.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/mpp.h 2012-01-21 19:54:46.000000000 -0700
|
||||
@@ -102,6 +102,7 @@
|
||||
#define MPP11_SATA0_ACTn MPP( 11, 0x5, 0, 1, 0, 1, 1, 1, 1 )
|
||||
|
||||
|
@ -658,9 +664,127 @@ diff -urN a/arch/arm/mach-kirkwood/mpp.h b/arch/arm/mach-kirkwood/mpp.h
|
|||
#define MPP12_SD_CLK MPP( 12, 0x1, 0, 1, 1, 1, 1, 1, 1 )
|
||||
#define MPP12_AU_SPDIF0 MPP( 12, 0xa, 0, 1, 0, 0, 0, 0, 1 )
|
||||
#define MPP12_SPI_MOSI MPP( 12, 0xb, 0, 1, 0, 0, 0, 0, 1 )
|
||||
diff -urN a/arch/arm/mach-kirkwood/pogo_e02-setup.c b/arch/arm/mach-kirkwood/pogo_e02-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/pogo_e02-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/pogo_e02-setup.c 2012-01-21 23:29:56.000000000 -0700
|
||||
@@ -0,0 +1,114 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/pogo_e02-setup.c
|
||||
+ *
|
||||
+ * CloudEngines Pogoplug E02 support
|
||||
+ *
|
||||
+ * This file is licensed under the terms of the GNU General Public
|
||||
+ * License version 2. This program is licensed "as is" without any
|
||||
+ * warranty of any kind, whether express or implied.
|
||||
+ */
|
||||
+
|
||||
+#include <linux/kernel.h>
|
||||
+#include <linux/init.h>
|
||||
+#include <linux/platform_device.h>
|
||||
+#include <linux/ata_platform.h>
|
||||
+#include <linux/mtd/partitions.h>
|
||||
+#include <linux/mv643xx_eth.h>
|
||||
+#include <linux/gpio.h>
|
||||
+#include <linux/leds.h>
|
||||
+#include <asm/mach-types.h>
|
||||
+#include <asm/mach/arch.h>
|
||||
+#include <mach/kirkwood.h>
|
||||
+#include "common.h"
|
||||
+#include "mpp.h"
|
||||
+
|
||||
+static struct mtd_partition pogo_e02_nand_parts[] = {
|
||||
+ {
|
||||
+ .name = "u-boot",
|
||||
+ .offset = 0,
|
||||
+ .size = SZ_1M
|
||||
+ }, {
|
||||
+ .name = "uImage",
|
||||
+ .offset = MTDPART_OFS_NXTBLK,
|
||||
+ .size = SZ_4M
|
||||
+ }, {
|
||||
+ .name = "pogoplug",
|
||||
+ .offset = MTDPART_OFS_NXTBLK,
|
||||
+ .size = SZ_32M
|
||||
+ }, {
|
||||
+ .name = "root",
|
||||
+ .offset = MTDPART_OFS_NXTBLK,
|
||||
+ .size = MTDPART_SIZ_FULL
|
||||
+ },
|
||||
+};
|
||||
+
|
||||
+static struct mv643xx_eth_platform_data pogo_e02_ge00_data = {
|
||||
+ .phy_addr = MV643XX_ETH_PHY_ADDR(0),
|
||||
+};
|
||||
+
|
||||
+static struct gpio_led pogo_e02_led_pins[] = {
|
||||
+ {
|
||||
+ .name = "status:green:health",
|
||||
+ .default_trigger = "default-on",
|
||||
+ .gpio = 48,
|
||||
+ .active_low = 1,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:orange:fault",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 49,
|
||||
+ .active_low = 1,
|
||||
+ }
|
||||
+};
|
||||
+
|
||||
+static struct gpio_led_platform_data pogo_e02_led_data = {
|
||||
+ .leds = pogo_e02_led_pins,
|
||||
+ .num_leds = ARRAY_SIZE(pogo_e02_led_pins),
|
||||
+};
|
||||
+
|
||||
+static struct platform_device pogo_e02_leds = {
|
||||
+ .name = "leds-gpio",
|
||||
+ .id = -1,
|
||||
+ .dev = {
|
||||
+ .platform_data = &pogo_e02_led_data,
|
||||
+ }
|
||||
+};
|
||||
+
|
||||
+static unsigned int pogo_e02_mpp_config[] __initdata = {
|
||||
+ MPP29_GPIO, /* USB Power Enable */
|
||||
+ MPP48_GPIO, /* LED Green */
|
||||
+ MPP49_GPIO, /* LED Orange */
|
||||
+ 0
|
||||
+};
|
||||
+
|
||||
+static void __init pogo_e02_init(void)
|
||||
+{
|
||||
+ /*
|
||||
+ * Basic setup. Needs to be called early.
|
||||
+ */
|
||||
+ kirkwood_init();
|
||||
+
|
||||
+ /* setup gpio pin select */
|
||||
+ kirkwood_mpp_conf(pogo_e02_mpp_config);
|
||||
+
|
||||
+ kirkwood_uart0_init();
|
||||
+ kirkwood_nand_init(ARRAY_AND_SIZE(pogo_e02_nand_parts), 25);
|
||||
+
|
||||
+ if (gpio_request(29, "USB Power Enable") != 0 ||
|
||||
+ gpio_direction_output(29, 1) != 0)
|
||||
+ printk(KERN_ERR "can't set up GPIO 29 (USB Power Enable)\n");
|
||||
+ kirkwood_ehci_init();
|
||||
+
|
||||
+ kirkwood_ge00_init(&pogo_e02_ge00_data);
|
||||
+
|
||||
+ platform_device_register(&pogo_e02_leds);
|
||||
+}
|
||||
+
|
||||
+MACHINE_START(POGO_E02, "Pogoplug E02")
|
||||
+ .atag_offset = 0x100,
|
||||
+ .init_machine = pogo_e02_init,
|
||||
+ .map_io = kirkwood_map_io,
|
||||
+ .init_early = kirkwood_init_early,
|
||||
+ .init_irq = kirkwood_init_irq,
|
||||
+ .timer = &kirkwood_timer,
|
||||
+MACHINE_END
|
||||
diff -urN a/arch/arm/mach-kirkwood/pogoplugv4-setup.c b/arch/arm/mach-kirkwood/pogoplugv4-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/pogoplugv4-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/pogoplugv4-setup.c 2012-01-14 04:34:06.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/pogoplugv4-setup.c 2012-01-21 23:30:01.000000000 -0700
|
||||
@@ -0,0 +1,194 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/pogoplugv4-setup.c
|
||||
|
@ -849,7 +973,7 @@ diff -urN a/arch/arm/mach-kirkwood/pogoplugv4-setup.c b/arch/arm/mach-kirkwood/p
|
|||
+
|
||||
+MACHINE_START(POGOPLUGV4, "Pogoplug V4")
|
||||
+ /* Maintainer: Kevin Mihelich <kevin@archlinuxarm.org> */
|
||||
+ .boot_params = 0x00000100,
|
||||
+ .atag_offset = 0x100,
|
||||
+ .init_machine = pogoplugv4_init,
|
||||
+ .map_io = kirkwood_map_io,
|
||||
+ .init_early = kirkwood_init_early,
|
||||
|
@ -857,8 +981,8 @@ diff -urN a/arch/arm/mach-kirkwood/pogoplugv4-setup.c b/arch/arm/mach-kirkwood/p
|
|||
+ .timer = &kirkwood_timer,
|
||||
+MACHINE_END
|
||||
diff -urN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/sheevaplug-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c 2011-10-24 01:10:05.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c 2012-01-14 03:32:44.000000000 -0700
|
||||
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c 2012-01-04 16:55:44.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c 2012-01-21 19:54:46.000000000 -0700
|
||||
@@ -64,7 +64,13 @@
|
||||
.active_low = 1,
|
||||
},
|
||||
|
@ -896,10 +1020,11 @@ diff -urN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/s
|
|||
};
|
||||
|
||||
diff -urN a/arch/arm/tools/mach-types b/arch/arm/tools/mach-types
|
||||
--- a/arch/arm/tools/mach-types 2011-10-24 01:10:05.000000000 -0600
|
||||
+++ b/arch/arm/tools/mach-types 2012-01-14 03:41:57.000000000 -0700
|
||||
@@ -1113,3 +1113,4 @@
|
||||
thales_adc MACH_THALES_ADC THALES_ADC 3492
|
||||
ubisys_p9d_evp MACH_UBISYS_P9D_EVP UBISYS_P9D_EVP 3493
|
||||
atdgp318 MACH_ATDGP318 ATDGP318 3494
|
||||
--- a/arch/arm/tools/mach-types 2012-01-04 16:55:44.000000000 -0700
|
||||
+++ b/arch/arm/tools/mach-types 2012-01-21 19:55:49.000000000 -0700
|
||||
@@ -1126,3 +1126,5 @@
|
||||
m28evk MACH_M28EVK M28EVK 3613
|
||||
smdk4212 MACH_SMDK4212 SMDK4212 3638
|
||||
smdk4412 MACH_SMDK4412 SMDK4412 3765
|
||||
+pogo_e02 MACH_POGO_E02 POGO_E02 3542
|
||||
+pogoplugv4 MACH_POGOPLUGV4 POGOPLUGV4 3960
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
aufs3.1 base patch
|
||||
aufs3.2 base patch
|
||||
|
||||
diff --git a/fs/namei.c b/fs/namei.c
|
||||
index 0b3138d..8edad02 100644
|
||||
index 5008f01..4cc94cf 100644
|
||||
--- a/fs/namei.c
|
||||
+++ b/fs/namei.c
|
||||
@@ -1748,7 +1748,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
|
||||
@@ -1753,7 +1753,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
|
||||
* needs parent already locked. Doesn't follow mounts.
|
||||
* SMP-safe.
|
||||
*/
|
||||
|
@ -42,10 +42,10 @@ index fa2defa..e3569b0 100644
|
|||
ssize_t (*splice_read)(struct file *, loff_t *,
|
||||
struct pipe_inode_info *, size_t, unsigned int);
|
||||
diff --git a/include/linux/namei.h b/include/linux/namei.h
|
||||
index 409328d..40afdc0 100644
|
||||
index ffc0213..ef35a31 100644
|
||||
--- a/include/linux/namei.h
|
||||
+++ b/include/linux/namei.h
|
||||
@@ -84,6 +84,7 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
|
||||
@@ -85,6 +85,7 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
|
||||
extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry *dentry,
|
||||
int (*open)(struct inode *, struct file *));
|
||||
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,7 +1,7 @@
|
|||
aufs3.1 kbuild patch
|
||||
aufs3.2 kbuild patch
|
||||
|
||||
diff --git a/fs/Kconfig b/fs/Kconfig
|
||||
index 9fe0b34..c4311f8 100644
|
||||
index 5f4c45d..357a8a6 100644
|
||||
--- a/fs/Kconfig
|
||||
+++ b/fs/Kconfig
|
||||
@@ -215,6 +215,7 @@ source "fs/pstore/Kconfig"
|
||||
|
@ -13,11 +13,11 @@ index 9fe0b34..c4311f8 100644
|
|||
endif # MISC_FILESYSTEMS
|
||||
|
||||
diff --git a/fs/Makefile b/fs/Makefile
|
||||
index afc1096..5c5ac76 100644
|
||||
index d2c3353..680ad8a 100644
|
||||
--- a/fs/Makefile
|
||||
+++ b/fs/Makefile
|
||||
@@ -123,3 +123,4 @@ obj-$(CONFIG_GFS2_FS) += gfs2/
|
||||
obj-$(CONFIG_EXOFS_FS) += exofs/
|
||||
obj-y += exofs/ # Multiple modules
|
||||
obj-$(CONFIG_CEPH_FS) += ceph/
|
||||
obj-$(CONFIG_PSTORE) += pstore/
|
||||
+obj-$(CONFIG_AUFS_FS) += aufs/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
aufs3.1 standalone patch
|
||||
aufs3.2 standalone patch
|
||||
|
||||
diff --git a/fs/file_table.c b/fs/file_table.c
|
||||
index c322794..2aad244 100644
|
||||
|
@ -14,7 +14,7 @@ index c322794..2aad244 100644
|
|||
|
||||
/*
|
||||
diff --git a/fs/inode.c b/fs/inode.c
|
||||
index ec79246..46ac6f9 100644
|
||||
index ee4e66b..728042b 100644
|
||||
--- a/fs/inode.c
|
||||
+++ b/fs/inode.c
|
||||
@@ -65,6 +65,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
|
||||
|
@ -26,10 +26,10 @@ index ec79246..46ac6f9 100644
|
|||
/*
|
||||
* Empty aops. Can be used for the cases where the user does not
|
||||
diff --git a/fs/namei.c b/fs/namei.c
|
||||
index 8edad02..50e8718 100644
|
||||
index 4cc94cf..af19e30 100644
|
||||
--- a/fs/namei.c
|
||||
+++ b/fs/namei.c
|
||||
@@ -1752,6 +1752,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
|
||||
@@ -1757,6 +1757,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
|
||||
{
|
||||
return __lookup_hash(&nd->last, nd->path.dentry, nd);
|
||||
}
|
||||
|
@ -38,10 +38,10 @@ index 8edad02..50e8718 100644
|
|||
/**
|
||||
* lookup_one_len - filesystem helper to lookup single pathname component
|
||||
diff --git a/fs/namespace.c b/fs/namespace.c
|
||||
index b4febb2..598a308 100644
|
||||
index cfc6d44..173d15a 100644
|
||||
--- a/fs/namespace.c
|
||||
+++ b/fs/namespace.c
|
||||
@@ -1508,6 +1508,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
|
||||
@@ -1506,6 +1506,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
|
||||
}
|
||||
return 0;
|
||||
}
|
||||
|
@ -111,7 +111,7 @@ index e14587d..be6533b 100644
|
|||
static int fsnotify_mark_destroy(void *ignored)
|
||||
{
|
||||
diff --git a/fs/open.c b/fs/open.c
|
||||
index f711921..d742fc0 100644
|
||||
index 22c41b5..33b4033 100644
|
||||
--- a/fs/open.c
|
||||
+++ b/fs/open.c
|
||||
@@ -60,6 +60,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
|
||||
|
@ -143,19 +143,27 @@ index e3569b0..9dc07b7 100644
|
|||
/**
|
||||
* splice_direct_to_actor - splices data directly between two non-pipes
|
||||
diff --git a/security/commoncap.c b/security/commoncap.c
|
||||
index a93b3b7..024282c 100644
|
||||
index ee4f848..611fd70 100644
|
||||
--- a/security/commoncap.c
|
||||
+++ b/security/commoncap.c
|
||||
@@ -971,3 +971,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
|
||||
@@ -975,3 +975,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
|
||||
}
|
||||
return ret;
|
||||
}
|
||||
+EXPORT_SYMBOL(cap_file_mmap);
|
||||
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
|
||||
index 4450fbe..2c437e5 100644
|
||||
index 4450fbe..bc94175 100644
|
||||
--- a/security/device_cgroup.c
|
||||
+++ b/security/device_cgroup.c
|
||||
@@ -500,6 +500,7 @@ found:
|
||||
@@ -7,6 +7,7 @@
|
||||
#include <linux/device_cgroup.h>
|
||||
#include <linux/cgroup.h>
|
||||
#include <linux/ctype.h>
|
||||
+#include <linux/export.h>
|
||||
#include <linux/list.h>
|
||||
#include <linux/uaccess.h>
|
||||
#include <linux/seq_file.h>
|
||||
@@ -500,6 +501,7 @@ found:
|
||||
|
||||
return -EPERM;
|
||||
}
|
||||
|
@ -164,10 +172,10 @@ index 4450fbe..2c437e5 100644
|
|||
int devcgroup_inode_mknod(int mode, dev_t dev)
|
||||
{
|
||||
diff --git a/security/security.c b/security/security.c
|
||||
index d9e1533..466ee5c 100644
|
||||
index e2f684a..892000c 100644
|
||||
--- a/security/security.c
|
||||
+++ b/security/security.c
|
||||
@@ -373,6 +373,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
|
||||
@@ -411,6 +411,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
|
||||
return 0;
|
||||
return security_ops->path_rmdir(dir, dentry);
|
||||
}
|
||||
|
@ -175,7 +183,7 @@ index d9e1533..466ee5c 100644
|
|||
|
||||
int security_path_unlink(struct path *dir, struct dentry *dentry)
|
||||
{
|
||||
@@ -389,6 +390,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
|
||||
@@ -427,6 +428,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
|
||||
return 0;
|
||||
return security_ops->path_symlink(dir, dentry, old_name);
|
||||
}
|
||||
|
@ -183,7 +191,7 @@ index d9e1533..466ee5c 100644
|
|||
|
||||
int security_path_link(struct dentry *old_dentry, struct path *new_dir,
|
||||
struct dentry *new_dentry)
|
||||
@@ -397,6 +399,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
|
||||
@@ -435,6 +437,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
|
||||
return 0;
|
||||
return security_ops->path_link(old_dentry, new_dir, new_dentry);
|
||||
}
|
||||
|
@ -191,7 +199,7 @@ index d9e1533..466ee5c 100644
|
|||
|
||||
int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
|
||||
struct path *new_dir, struct dentry *new_dentry)
|
||||
@@ -415,6 +418,7 @@ int security_path_truncate(struct path *path)
|
||||
@@ -453,6 +456,7 @@ int security_path_truncate(struct path *path)
|
||||
return 0;
|
||||
return security_ops->path_truncate(path);
|
||||
}
|
||||
|
@ -199,7 +207,7 @@ index d9e1533..466ee5c 100644
|
|||
|
||||
int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
|
||||
mode_t mode)
|
||||
@@ -423,6 +427,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
|
||||
@@ -461,6 +465,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
|
||||
return 0;
|
||||
return security_ops->path_chmod(dentry, mnt, mode);
|
||||
}
|
||||
|
@ -207,7 +215,7 @@ index d9e1533..466ee5c 100644
|
|||
|
||||
int security_path_chown(struct path *path, uid_t uid, gid_t gid)
|
||||
{
|
||||
@@ -430,6 +435,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
|
||||
@@ -468,6 +473,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
|
||||
return 0;
|
||||
return security_ops->path_chown(path, uid, gid);
|
||||
}
|
||||
|
@ -215,7 +223,7 @@ index d9e1533..466ee5c 100644
|
|||
|
||||
int security_path_chroot(struct path *path)
|
||||
{
|
||||
@@ -506,6 +512,7 @@ int security_inode_readlink(struct dentry *dentry)
|
||||
@@ -544,6 +550,7 @@ int security_inode_readlink(struct dentry *dentry)
|
||||
return 0;
|
||||
return security_ops->inode_readlink(dentry);
|
||||
}
|
||||
|
@ -223,7 +231,7 @@ index d9e1533..466ee5c 100644
|
|||
|
||||
int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
|
||||
{
|
||||
@@ -520,6 +527,7 @@ int security_inode_permission(struct inode *inode, int mask)
|
||||
@@ -558,6 +565,7 @@ int security_inode_permission(struct inode *inode, int mask)
|
||||
return 0;
|
||||
return security_ops->inode_permission(inode, mask);
|
||||
}
|
||||
|
@ -231,7 +239,7 @@ index d9e1533..466ee5c 100644
|
|||
|
||||
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
|
||||
{
|
||||
@@ -619,6 +627,7 @@ int security_file_permission(struct file *file, int mask)
|
||||
@@ -673,6 +681,7 @@ int security_file_permission(struct file *file, int mask)
|
||||
|
||||
return fsnotify_perm(file, mask);
|
||||
}
|
||||
|
@ -239,7 +247,7 @@ index d9e1533..466ee5c 100644
|
|||
|
||||
int security_file_alloc(struct file *file)
|
||||
{
|
||||
@@ -646,6 +655,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
|
||||
@@ -700,6 +709,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
|
||||
return ret;
|
||||
return ima_file_mmap(file, prot);
|
||||
}
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -2,7 +2,7 @@
|
|||
# arg 2: the old package version
|
||||
|
||||
KERNEL_NAME=
|
||||
KERNEL_VERSION=3.1.7-2-ARCH
|
||||
KERNEL_VERSION=3.2.1-1-ARCH
|
||||
|
||||
post_install () {
|
||||
# updating module dependencies
|
||||
|
@ -14,7 +14,6 @@ post_upgrade() {
|
|||
if grep "^[^#]*[[:space:]]/boot" etc/fstab 2>&1 >/dev/null; then
|
||||
if ! grep "[[:space:]]/boot" etc/mtab 2>&1 >/dev/null; then
|
||||
echo "WARNING: /boot appears to be a seperate partition but is not mounted."
|
||||
echo " You probably just broke your system. Congratulations."
|
||||
fi
|
||||
fi
|
||||
|
||||
|
|
Loading…
Reference in a new issue