extra/chromium to 65.0.3325.181-6

This commit is contained in:
Kevin Mihelich 2018-04-04 17:46:58 +00:00
parent f91beca2d1
commit bd3ac7d7aa
3 changed files with 124 additions and 1 deletions

View file

@ -14,7 +14,7 @@ highmem=1
pkgname=chromium
pkgver=65.0.3325.181
pkgrel=5
pkgrel=6
_launcher_ver=6
pkgdesc="A web browser built for speed, simplicity, and security"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@ -33,6 +33,8 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
chromium-$pkgver.txt::https://chromium.googlesource.com/chromium/src.git/+/$pkgver?format=TEXT
fix-crash-in-is_cfi-true-builds-with-unbundled-ICU.patch
allow-stat-in-Linux-for-GPU-process-for-a-list-of-files.patch
fix-frame-buttons-rendering-too-large-when-using-OSX.patch
send-GSB-before-switching-to-mainthread-scrolling-in.patch
chromium-skia-harmony.patch
chromium-clang-r2.patch
chromium-math.h-r0.patch
@ -54,6 +56,8 @@ sha256sums=('93666448c6b96ec83e6a35a64cff40db4eb92a154fe1db4e7dab4761d0e38687'
'2771c049b66c9aba3b945fe065f2610f164d55506eb5d71751a26aaf8b40d4ee'
'e3fb73b43bb8c69ff517e66b2cac73d6e759fd240003eb35598df9af442422fe'
'4327289866d0b3006de62799ec06b07198a738e50e0a5c2e41ff62dbe00b4a2c'
'bd5e0e61df3f89172590801aea7c8ac75162c10c7fe83e262e96a14388d1633a'
'b20bb43c89dd1fb5fc787e52b7ef6f4f20714f7d74e33372c0979fe398b5b436'
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
'4495e8b29dae242c79ffe4beefc5171eb3c7aacb7e9aebfd2d4d69b9d8c958d3'
'fe0ab86aa5b0072db730eccda3e1582ebed4af25815bfd49fe0da24cf63ca902'
@ -150,6 +154,12 @@ prepare() {
# https://crbug.com/817400
patch -Np1 -i ../allow-stat-in-Linux-for-GPU-process-for-a-list-of-files.patch
# https://crbug.com/821881
patch -Np1 -i ../fix-frame-buttons-rendering-too-large-when-using-OSX.patch
# https://crbug.com/797708
patch -Np1 -i ../send-GSB-before-switching-to-mainthread-scrolling-in.patch
# https://crbug.com/skia/6663#c10
patch -Np4 -i ../chromium-skia-harmony.patch

View file

@ -0,0 +1,60 @@
From 7ef426c221d11b53b6de507b398e35e8d7b3cc94 Mon Sep 17 00:00:00 2001
From: Tom Anderson <thomasanderson@chromium.org>
Date: Wed, 4 Apr 2018 01:23:26 +0000
Subject: [PATCH] Fix frame buttons rendering too large when using
OSX-Arc-White GTK theme
The check for GTK 3.20 was incorrect as the issue it was trying to fix
was still occurring on GTK 3.20+ systems. This CL adds the correct,
but more complex, check.
Verified on these configurations:
{GTK 3.18, GTK 3.22} X
{Breeze, Adwaita, OSX-Arc-White, Greybird} X
{scale=1, scale=2} X
{fullscreen, restored}
BUG=821881
R=thestig
Change-Id: I05afa35c1452a46a1abf4c39191a13657bfd8e2c
Reviewed-on: https://chromium-review.googlesource.com/990717
Reviewed-by: Lei Zhang <thestig@chromium.org>
Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
Cr-Commit-Position: refs/heads/master@{#547921}
---
chrome/browser/ui/libgtkui/nav_button_provider_gtk3.cc | 18 +++++++++++++++++-
1 file changed, 17 insertions(+), 1 deletion(-)
diff --git a/chrome/browser/ui/libgtkui/nav_button_provider_gtk3.cc b/chrome/browser/ui/libgtkui/nav_button_provider_gtk3.cc
index 31a8087bca11..6a09faec5dd2 100644
--- a/chrome/browser/ui/libgtkui/nav_button_provider_gtk3.cc
+++ b/chrome/browser/ui/libgtkui/nav_button_provider_gtk3.cc
@@ -213,7 +213,23 @@ class NavButtonImageSource : public gfx::ImageSkiaSource {
// is not scaled for the (unexpected) smaller button size, and the button's
// edges appear cut off. To fix this, manually set the background to scale
// to the button size when it would have clipped.
- if (GtkVersionCheck(3, 20)) {
+ //
+ // GTK's "contain" is unlike CSS's "contain". In CSS, the image would only
+ // be downsized when it would have clipped. In GTK, the image is always
+ // scaled to fit the drawing region (preserving aspect ratio). Only add
+ // "contain" if clipping would occur.
+ cairo_pattern_t* cr_pattern = nullptr;
+ cairo_surface_t* cr_surface = nullptr;
+ gtk_style_context_get(button_context, button_state,
+ GTK_STYLE_PROPERTY_BACKGROUND_IMAGE, &cr_pattern,
+ nullptr);
+ if (cr_pattern &&
+ cairo_pattern_get_surface(cr_pattern, &cr_surface) ==
+ CAIRO_STATUS_SUCCESS &&
+ cr_surface &&
+ cairo_surface_get_type(cr_surface) == CAIRO_SURFACE_TYPE_IMAGE &&
+ (cairo_image_surface_get_width(cr_surface) > button_size_.width() ||
+ cairo_image_surface_get_height(cr_surface) > button_size_.height())) {
ApplyCssToContext(button_context,
".titlebutton { background-size: contain; }");
}
--
2.16.2

View file

@ -0,0 +1,53 @@
From 5d5a062fac6f567cd8f8b2ef7e894e7623f8013e Mon Sep 17 00:00:00 2001
From: Sahel Sharify <sahel@chromium.org>
Date: Thu, 15 Mar 2018 17:30:49 +0000
Subject: [PATCH] Send GSB before switching to mainthread scrolling in smooth
scroll path.
This cl is the equivalent of https://codereview.chromium.org/2854683002 fix for smooth scrolling
path,if the compositor handles the GSB and during the scrolling we have to switch to main thread
since the compositor cannot handle a GSU a GSB must be sent to the main thread since the original
GSB was handled on the compositor rather than being sent to the main thread.
touchpad-scroll-impl-to-main.html is the test that forces switch from compositor thread to main
thread in the middle of scrolling. It used to get executed with --disable-smooth-scrolling
in this cl I've moved the test to a new virtual test suite that has default scroll animation
value.
I have removed the test expectations since I have changed the test and this might fix the flake.
subpixel-accumulation.html needs scroll animation to be disabled and that's why I had to move it to
a new test suite.
Bug: 820979, 708499, 757165, 800840
Cq-Include-Trybots: master.tryserver.blink:linux_trusty_blink_rel;master.tryserver.chromium.linux:linux_layout_tests_slimming_paint_v2
Change-Id: I21b1f4285897d74559f6827e6a232f007dc897b0
Reviewed-on: https://chromium-review.googlesource.com/961264
Commit-Queue: Sahel Sharifymoghaddam <sahel@chromium.org>
Reviewed-by: Timothy Dresser <tdresser@chromium.org>
Cr-Commit-Position: refs/heads/master@{#543425}
---
ui/events/blink/input_handler_proxy.cc | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/ui/events/blink/input_handler_proxy.cc b/ui/events/blink/input_handler_proxy.cc
index e9dd50253458..6d77910839f4 100644
--- a/ui/events/blink/input_handler_proxy.cc
+++ b/ui/events/blink/input_handler_proxy.cc
@@ -765,7 +765,12 @@ InputHandlerProxy::HandleGestureScrollUpdate(
return DID_HANDLE;
case cc::InputHandler::SCROLL_IGNORED:
return DROP_EVENT;
- default:
+ case cc::InputHandler::SCROLL_ON_MAIN_THREAD:
+ case cc::InputHandler::SCROLL_UNKNOWN:
+ if (input_handler_->ScrollingShouldSwitchtoMainThread()) {
+ gesture_scroll_on_impl_thread_ = false;
+ client_->GenerateScrollBeginAndSendToMainThread(gesture_event);
+ }
return DID_NOT_HANDLE;
}
}
--
2.16.2