removed alarm/motion-noffmpeg

This commit is contained in:
Kevin Mihelich 2018-01-07 15:15:14 +00:00
parent 75df3bdd84
commit bd94d0dda4
4 changed files with 0 additions and 162 deletions

View file

@ -1,46 +0,0 @@
# $Id$
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
plugrel=3
_pkgbase='motion'
pkgname=motion-noffmpeg
pkgver=3.2.12
provides=('motion')
replaces=('motion')
conflicts=('motion')
pkgrel=3
pkgdesc="A software motion detector which grabs images from video4linux devices and/or from webcams, built without FFMPEG, and requires fewer dependencies (~47MB -> ~3MB) "
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
depends=('libjpeg' 'v4l-utils')
backup=('etc/motion/motion.conf')
options=('!makeflags')
source=(http://downloads.sourceforge.net/${_pkgbase}/${_pkgbase}-${pkgver}.tar.gz
rc.motion
linux-headers.patch
noffmpeg.patch)
md5sums=('1ba0065ed50509aaffb171594c689f46'
'77be944e4466ab66836d50ea216af3b6'
'ea917c4ac459cd26a6d161d4e759f0dc'
'106a149dba24db497e89af7fca886348')
build() {
cd "${srcdir}/${_pkgbase}-${pkgver}"
patch -p1 motion-dist.conf.in < $srcdir/noffmpeg.patch
patch -Np1 -i $srcdir/linux-headers.patch
./configure --prefix=/usr \
--without-pgsql \
--without-ffmpeg \
--without-mysql \
--sysconfdir=/etc/motion
make
}
package(){
cd "${srcdir}/${_pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
mv "${pkgdir}/etc/motion/motion-dist.conf" "${pkgdir}/etc/motion/motion.conf"
install -Dm755 "${srcdir}/rc.motion" "${pkgdir}/etc/rc.d/motion"
}

View file

@ -1,35 +0,0 @@
diff -urN motion-3.2.12-OLD/motion.h motion-3.2.12-NEW/motion.h
--- motion-3.2.12-OLD/motion.h 2010-05-31 23:48:23.000000000 -0700
+++ motion-3.2.12-NEW/motion.h 2011-08-30 02:11:08.000000000 -0700
@@ -40,7 +40,7 @@
#define _LINUX_TIME_H 1
#if !defined(WITHOUT_V4L) && !defined(BSD)
-#include <linux/videodev.h>
+#include <libv4l1-videodev.h>
#endif
#include <pthread.h>
diff -urN motion-3.2.12-OLD/track.c motion-3.2.12-NEW/track.c
--- motion-3.2.12-OLD/track.c 2010-05-31 23:48:23.000000000 -0700
+++ motion-3.2.12-NEW/track.c 2011-08-30 23:05:09.000000000 -0700
@@ -11,6 +11,7 @@
#include "motion.h"
#ifndef WITHOUT_V4L
+#include <linux/videodev2.h>
#include "pwc-ioctl.h"
#endif
diff -urN motion-3.2.12-OLD/video.h motion-3.2.12-NEW/video.h
--- motion-3.2.12-OLD/video.h 2010-05-31 23:48:23.000000000 -0700
+++ motion-3.2.12-NEW/video.h 2011-08-30 02:11:12.000000000 -0700
@@ -12,7 +12,7 @@
#define _LINUX_TIME_H 1
#ifndef WITHOUT_V4L
-#include <linux/videodev.h>
+#include <libv4l1-videodev.h>
#include <sys/mman.h>
#include "pwc-ioctl.h"
#endif

View file

@ -1,44 +0,0 @@
211c211
< max_mpeg_time 0
---
> #max_mpeg_time 0
247c247
< ffmpeg_cap_new on
---
> #ffmpeg_cap_new on
251c251
< ffmpeg_cap_motion off
---
> #ffmpeg_cap_motion off
255c255
< ffmpeg_timelapse 0
---
> #ffmpeg_timelapse 0
259c259
< ffmpeg_timelapse_mode daily
---
> #ffmpeg_timelapse_mode daily
263c263
< ffmpeg_bps 500000
---
> #ffmpeg_bps 500000
269c269
< ffmpeg_variable_bitrate 0
---
> #ffmpeg_variable_bitrate 0
282c282
< ffmpeg_video_codec mpeg4
---
> #ffmpeg_video_codec mpeg4
287c287
< ffmpeg_deinterlace off
---
> #ffmpeg_deinterlace off
385c385
< movie_filename %v-%Y%m%d%H%M%S
---
> #movie_filename %v-%Y%m%d%H%M%S
392c392
< timelapse_filename %Y%m%d-timelapse
---
> #timelapse_filename %Y%m%d-timelapse

View file

@ -1,37 +0,0 @@
#!/bin/bash
. /etc/rc.conf
. /etc/rc.d/functions
PID=`pidof -o %PPID /usr/bin/motion`
case "$1" in
start)
stat_busy "Starting Motion"
mkdir -p /var/run/motion
[ -z "$PID" ] && /usr/bin/motion
if [ $? -gt 0 ]; then
stat_fail
else
add_daemon motion
stat_done
fi
;;
stop)
stat_busy "Stopping Motion"
[ ! -z "$PID" ] && kill $PID &> /dev/null
if [ $? -gt 0 ]; then
stat_fail
else
rm_daemon motion
stat_done
fi
;;
restart)
$0 stop
sleep 3
$0 start
;;
*)
echo "usage: $0 {start|stop|restart}"
esac
exit 0