extra/hid-tools to 0.7-3

This commit is contained in:
Kevin Mihelich 2024-12-22 18:28:36 +00:00
parent aaf13a4cb9
commit bdf78f0eda
4 changed files with 30 additions and 4 deletions

View file

@ -1,7 +1,7 @@
pkgbase = hid-tools
pkgdesc = Python scripts to manipulate HID data
pkgver = 0.7
pkgrel = 2
pkgrel = 3
url = https://gitlab.freedesktop.org/libevdev/hid-tools
arch = any
license = GPL2
@ -18,6 +18,8 @@ pkgbase = hid-tools
depends = python-click
depends = python-yaml
source = https://gitlab.freedesktop.org/libevdev/hid-tools/-/archive/0.7/hid-tools-0.7.tar.gz
source = fix-sphinx.patch
sha512sums = 9a9bd42ac0a78455e7c5c472b954ac6761c656d51dc9667def50fd61311280d435b227c5b9519d05287063bbdfad3930598a9f0a8e4ffe4cc7cc1cda37c4462c
sha512sums = de6821177ddda48ebd9183f7d9f159797f36c1e7b0f0a08066994322999a58560975208ac6b3702f6022e18ee1f6f1572cdfad72c27aadc649e0c5eb8e5d8ef5
pkgname = hid-tools

View file

@ -0,0 +1,3 @@
[hid-tools]
source = "git"
git = "https://gitlab.freedesktop.org/libevdev/hid-tools.git"

View file

@ -5,15 +5,24 @@
pkgname=hid-tools
pkgver=0.7
pkgrel=2
pkgrel=3
arch=('any')
url='https://gitlab.freedesktop.org/libevdev/hid-tools'
license=('GPL2')
pkgdesc='Python scripts to manipulate HID data'
depends=('python-parse' 'python-pyudev' 'python-libevdev' 'python-click' 'python-yaml')
makedepends=('python-build' 'python-installer' 'python-hatchling' 'python-sphinx' 'python-sphinx_rtd_theme' 'python-sphinxcontrib-apidoc')
source=("$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
sha512sums=('9a9bd42ac0a78455e7c5c472b954ac6761c656d51dc9667def50fd61311280d435b227c5b9519d05287063bbdfad3930598a9f0a8e4ffe4cc7cc1cda37c4462c')
source=("$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
"fix-sphinx.patch")
sha512sums=('9a9bd42ac0a78455e7c5c472b954ac6761c656d51dc9667def50fd61311280d435b227c5b9519d05287063bbdfad3930598a9f0a8e4ffe4cc7cc1cda37c4462c'
'de6821177ddda48ebd9183f7d9f159797f36c1e7b0f0a08066994322999a58560975208ac6b3702f6022e18ee1f6f1572cdfad72c27aadc649e0c5eb8e5d8ef5')
prepare() {
cd $pkgname-$pkgver
patch -Np1 -i ${srcdir}/fix-sphinx.patch
}
build() {
cd $pkgname-$pkgver

View file

@ -0,0 +1,12 @@
diff -aur hid-tools-0.7.old/doc/source/conf.py hid-tools-0.7/doc/source/conf.py
--- hid-tools-0.7.old/doc/source/conf.py 2024-11-23 11:33:40.921977008 +0100
+++ hid-tools-0.7/doc/source/conf.py 2024-11-23 11:34:04.335873711 +0100
@@ -173,7 +173,7 @@
]
# Example configuration for intersphinx: refer to the Python standard library.
-intersphinx_mapping = {"http://docs.python.org/": None}
+intersphinx_mapping = {'python': ('https://docs.python.org/3', None)}
apidoc_module_dir = "../../"
apidoc_output_dir = "./"