mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
alarm/uboot-wandboard to 2014.04-1
This commit is contained in:
parent
3dd8a051e8
commit
be3386490c
2 changed files with 15 additions and 17 deletions
|
@ -5,7 +5,7 @@ buildarch=4
|
||||||
|
|
||||||
pkgbase=uboot-wandboard
|
pkgbase=uboot-wandboard
|
||||||
pkgname=('uboot-wandboard-solo' 'uboot-wandboard-dual' 'uboot-wandboard-quad')
|
pkgname=('uboot-wandboard-solo' 'uboot-wandboard-dual' 'uboot-wandboard-quad')
|
||||||
pkgver=2014.01
|
pkgver=2014.04
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="http://git.denx.de/u-boot.git/"
|
url="http://git.denx.de/u-boot.git/"
|
||||||
|
@ -14,9 +14,9 @@ makedepends=('git')
|
||||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
||||||
"https://raw.github.com/eewiki/u-boot-patches/master/v${pkgver}/0001-wandboard-uEnv.txt-bootz-n-fixes.patch"
|
"https://raw.github.com/eewiki/u-boot-patches/master/v${pkgver}/0001-wandboard-uEnv.txt-bootz-n-fixes.patch"
|
||||||
'alarm.patch')
|
'alarm.patch')
|
||||||
md5sums=('e531307578f6d32a7ccb1d04f1e08cbc'
|
md5sums=('6d2116d1385a66e9a59742caa9d62a54'
|
||||||
'07b1aba3db09dc86c2c3960baa4d77ad'
|
'07b1aba3db09dc86c2c3960baa4d77ad'
|
||||||
'8f749cdb50b4deddbfa92655610ad5f4')
|
'c6dbc33cd1be40aa23623ef5aa9aa9f0')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd u-boot-${pkgver}
|
cd u-boot-${pkgver}
|
||||||
|
@ -29,11 +29,12 @@ build() {
|
||||||
|
|
||||||
unset CFLAGS CXXFLAGS LDFLAGS
|
unset CFLAGS CXXFLAGS LDFLAGS
|
||||||
|
|
||||||
|
mkdir bins
|
||||||
for i in solo dl quad; do
|
for i in solo dl quad; do
|
||||||
make distclean
|
make distclean
|
||||||
make wandboard_${i}_config
|
make wandboard_${i}_config
|
||||||
make
|
make
|
||||||
mv u-boot.imx u-boot-${i}.imx
|
mv u-boot.imx bins/u-boot-${i}.imx
|
||||||
done
|
done
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -43,7 +44,7 @@ package_uboot-wandboard-solo() {
|
||||||
install=${pkgbase}.install
|
install=${pkgbase}.install
|
||||||
|
|
||||||
mkdir -p "${pkgdir}"/boot
|
mkdir -p "${pkgdir}"/boot
|
||||||
cp u-boot-${pkgver}/u-boot-solo.imx "${pkgdir}"/boot/u-boot.imx
|
cp u-boot-${pkgver}/bins/u-boot-solo.imx "${pkgdir}"/boot/u-boot.imx
|
||||||
}
|
}
|
||||||
|
|
||||||
package_uboot-wandboard-dual() {
|
package_uboot-wandboard-dual() {
|
||||||
|
@ -52,7 +53,7 @@ package_uboot-wandboard-dual() {
|
||||||
install=${pkgbase}.install
|
install=${pkgbase}.install
|
||||||
|
|
||||||
mkdir -p "${pkgdir}"/boot
|
mkdir -p "${pkgdir}"/boot
|
||||||
cp u-boot-${pkgver}/u-boot-dl.imx "${pkgdir}"/boot/u-boot.imx
|
cp u-boot-${pkgver}/bins/u-boot-dl.imx "${pkgdir}"/boot/u-boot.imx
|
||||||
}
|
}
|
||||||
|
|
||||||
package_uboot-wandboard-quad() {
|
package_uboot-wandboard-quad() {
|
||||||
|
@ -61,5 +62,5 @@ package_uboot-wandboard-quad() {
|
||||||
install=${pkgbase}.install
|
install=${pkgbase}.install
|
||||||
|
|
||||||
mkdir -p "${pkgdir}"/boot
|
mkdir -p "${pkgdir}"/boot
|
||||||
cp u-boot-${pkgver}/u-boot-quad.imx "${pkgdir}"/boot/u-boot.imx
|
cp u-boot-${pkgver}/bins/u-boot-quad.imx "${pkgdir}"/boot/u-boot.imx
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
diff -urN a/include/configs/wandboard.h b/include/configs/wandboard.h
|
diff -urN a/include/configs/wandboard.h b/include/configs/wandboard.h
|
||||||
--- a/include/configs/wandboard.h 2014-03-19 15:09:36.119921706 -0600
|
--- a/include/configs/wandboard.h 2014-05-17 13:09:55.544901200 -0600
|
||||||
+++ b/include/configs/wandboard.h 2014-03-19 15:25:36.641399875 -0600
|
+++ b/include/configs/wandboard.h 2014-05-17 13:10:26.309787812 -0600
|
||||||
@@ -108,6 +108,8 @@
|
@@ -108,6 +108,8 @@
|
||||||
#define CONFIG_DEFAULT_FDT_FILE "imx6q-wandboard.dtb"
|
#define CONFIG_DEFAULT_FDT_FILE "imx6q-wandboard.dtb"
|
||||||
#endif
|
#endif
|
||||||
|
@ -64,19 +64,16 @@ diff -urN a/include/configs/wandboard.h b/include/configs/wandboard.h
|
||||||
"netargs=setenv bootargs console=${console},${baudrate} " \
|
"netargs=setenv bootargs console=${console},${baudrate} " \
|
||||||
"root=/dev/nfs " \
|
"root=/dev/nfs " \
|
||||||
"ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
|
"ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
|
||||||
@@ -208,10 +197,14 @@
|
@@ -211,7 +200,11 @@
|
||||||
"echo Running uenvcmd ...;" \
|
|
||||||
"run uenvcmd;" \
|
|
||||||
"fi;" \
|
|
||||||
+ "echo Running default loaduimage ...;" \
|
|
||||||
+ "if run loaduimage; then " \
|
|
||||||
+ "run mmcbootm;" \
|
|
||||||
+ "fi;" \
|
|
||||||
"echo Running default loadzimage ...;" \
|
"echo Running default loadzimage ...;" \
|
||||||
"if run loadzimage; then " \
|
"if run loadzimage; then " \
|
||||||
"run loadfdt;" \
|
"run loadfdt;" \
|
||||||
- "run mmcboot;" \
|
- "run mmcboot;" \
|
||||||
+ "run mmcbootz;" \
|
+ "run mmcbootz;" \
|
||||||
|
+ "fi;" \
|
||||||
|
+ "echo Running default loaduimage ...;" \
|
||||||
|
+ "if run loaduimage; then " \
|
||||||
|
+ "run mmcbootm;" \
|
||||||
"fi;" \
|
"fi;" \
|
||||||
"fi;"
|
"fi;"
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue