diff --git a/core/linux-rpi/PKGBUILD b/core/linux-rpi/PKGBUILD
index 7f4254596..8fc7cb049 100644
--- a/core/linux-rpi/PKGBUILD
+++ b/core/linux-rpi/PKGBUILD
@@ -34,7 +34,7 @@ md5sums=('3b4b19b6ad336b2280d81eaa2cb5fdf7'
          '0a5f16bfec6ad982a2f6782724cca8ba'
          '441ec084c47cddc53e592fb0cbce4edf')
 md5sums_armv7h=('c4d26a4ab3cdf730a191ff95e1f32d79'
-                'aedda0148db2692971671e6aa90ad9ff')
+                '177bbdbe1baa46a04dcba86352cfa3fe')
 md5sums_aarch64=('c7b65343bd66c580e76539ad0c6da80e'
                  '7e4403dea857e40005bf76beda9927ff')
 
diff --git a/core/linux-rpi/config.txt b/core/linux-rpi/config.txt
index ad288073f..5a38716af 100644
--- a/core/linux-rpi/config.txt
+++ b/core/linux-rpi/config.txt
@@ -3,9 +3,24 @@
 dtoverlay=vc4-kms-v3d
 initramfs initramfs-linux.img followkernel
 
-# Disable compensation for displays with overscan
+# Automatically load overlays for detected DSI displays
 display_auto_detect=1
 
+# uncomment if hdmi display is not detected and composite is being output
+#hdmi_force_hotplug=1
+
+# Uncomment some or all of these to enable the optional hardware interfaces
+#dtparam=i2c_arm=on
+#dtparam=i2s=on
+#dtparam=spi=on
+
+# Uncomment this to enable infrared communication.
+#dtoverlay=gpio-ir,gpio_pin=17
+#dtoverlay=gpio-ir-tx,gpio_pin=18
+
+# Automatically load overlays for detected cameras
+camera_auto_detect=1
+
 # Uncomment to enable bluetooth
 #dtparam=krnbt=on