removed community/gdal

This commit is contained in:
Kevin Mihelich 2018-04-17 18:34:58 +00:00
parent 6713fbf273
commit bed240fafc
4 changed files with 0 additions and 341 deletions

View file

@ -1,88 +0,0 @@
# $Id$
# Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
# Contributor: William Rea <sillywilly@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - drop poppler, currently breaks build
pkgname=gdal
pkgver=2.2.3
pkgrel=4
pkgdesc="A translator library for raster geospatial data formats"
arch=('x86_64')
url="http://www.gdal.org/"
license=('custom')
depends=('curl' 'geos' 'giflib' 'hdf5' 'libgeotiff' 'libjpeg-turbo' 'libpng' 'libspatialite' 'libtiff' 'netcdf'
'openjpeg2' 'python2' 'python2-numpy' 'cfitsio' 'sqlite' 'libmariadbclient' 'postgresql-libs')
makedepends=('perl' 'swig' 'chrpath' 'doxygen')
optdepends=('postgresql: postgresql database support'
'mariadb: mariadb database support'
'perl: perl binding support')
options=('!emptydirs')
changelog=$pkgname.changelog
source=(http://download.osgeo.org/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz
gdal-perl-vendor.patch
gdal-2.2.3_json-c_013.patch)
sha256sums=('a328d63d476b3653f5a25b5f7971e87a15cdf8860ab0729d4b1157ba988b8d0b'
'20989e5fa499206b42c92280ce084fdf7b2f661a4233fc349611cc57102fe114'
'722f6b3394542635815b07702f88a312a0d32fcf7672abf780360b888fbab4af')
prepare() {
cd "${srcdir}"/$pkgname-$pkgver
# python2 fixes
sed -i 's_python python1.5_python2 python python1.5_' configure
for file in swig/python/{,osgeo/,samples/,scripts/}*.py; do
sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' $file
done
# Fix mandir
sed -i "s|^mandir=.*|mandir='\${prefix}/share/man'|" configure
# Fix Perl bindings installation path
patch -Np1 -i ../gdal-perl-vendor.patch
# build fix
patch -Np1 -i ../gdal-2.2.3_json-c_013.patch
}
build() {
cd "${srcdir}"/$pkgname-$pkgver
export CFLAGS="$CFLAGS -fno-strict-aliasing"
# bug #23654
export LDFLAGS="$LDFLAGS -Wl,--as-needed"
./configure --prefix=/usr --with-netcdf --with-libtiff --with-sqlite3 --with-geotiff \
--with-mysql --with-python --with-curl --with-hdf5 --with-perl --with-geos \
--with-png --with-poppler --with-spatialite --with-openjpeg
# workaround for bug #13646
sed -i 's/PY_HAVE_SETUPTOOLS=1/PY_HAVE_SETUPTOOLS=/g' ./GDALmake.opt
sed -i 's/EXE_DEP_LIBS/KILL_EXE_DEP_LIBS/' apps/GNUmakefile
make
make man
}
package () {
cd "${srcdir}"/$pkgname-$pkgver
make DESTDIR="${pkgdir}" install
make DESTDIR="${pkgdir}" install-man
# install license
install -Dm644 LICENSE.TXT "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
#FS15477 clean up junks - still present in 2.2.1
rm -f "${pkgdir}"/usr/share/man/man1/_build_gdal_src_gdal-${pkgver}_apps_.1
# Remove RPATH
eval local $(perl -V:vendorarch)
chrpath --delete "${pkgdir}"${vendorarch}/auto/Geo/OSR/OSR.so
chrpath --delete "${pkgdir}"${vendorarch}/auto/Geo/OGR/OGR.so
chrpath --delete "${pkgdir}"${vendorarch}/auto/Geo/GDAL/GDAL.so
chrpath --delete "${pkgdir}"${vendorarch}/auto/Geo/GDAL/Const/Const.so
chrpath --delete "${pkgdir}"${vendorarch}/auto/Geo/GNM/GNM.so
}

View file

@ -1,132 +0,0 @@
commit 7cab3c2049907fb0be76784c796143fb22dcafea
Author: Bjรถrn Esser <besser82@fedoraproject.org>
Date: Mon Dec 11 17:01:20 2017 +0100
geojson: Adaptions for json-c v0.13
Index: gdal-2.2.3-fedora/ogr/ogrsf_frmts/geojson/ogrgeojsonwriter.cpp
===================================================================
--- gdal-2.2.3-fedora.orig/ogr/ogrsf_frmts/geojson/ogrgeojsonwriter.cpp
+++ gdal-2.2.3-fedora/ogr/ogrsf_frmts/geojson/ogrgeojsonwriter.cpp
@@ -27,12 +27,18 @@
* DEALINGS IN THE SOFTWARE.
****************************************************************************/
+#define JSON_C_VER_013 (13 << 8)
+
#include "ogrgeojsonwriter.h"
#include "ogrgeojsonutils.h"
#include "ogr_geojson.h"
#include "ogrgeojsonreader.h"
#include <json.h> // JSON-C
+
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
#include <json_object_private.h>
+#endif
+
#include <printbuf.h>
#include <ogr_api.h>
#include <ogr_p.h>
@@ -1381,13 +1387,26 @@ static int OGR_json_double_with_precisio
{
// TODO(schwehr): Explain this casting.
const int nPrecision =
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
static_cast<int>(reinterpret_cast<GUIntptr_t>(jso->_userdata));
+#else
+ static_cast<int>(reinterpret_cast<GUIntptr_t>(json_object_get_userdata(jso)));
+#endif
char szBuffer[75] = {};
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
OGRFormatDouble( szBuffer, sizeof(szBuffer), jso->o.c_double, '.',
(nPrecision < 0) ? 15 : nPrecision );
+#else
+ OGRFormatDouble( szBuffer, sizeof(szBuffer), json_object_get_double(jso), '.',
+ (nPrecision < 0) ? 15 : nPrecision );
+#endif
if( szBuffer[0] == 't' /*oobig */ )
{
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
CPLsnprintf(szBuffer, sizeof(szBuffer), "%.18g", jso->o.c_double);
+#else
+ CPLsnprintf(szBuffer, sizeof(szBuffer), "%.18g", json_object_get_double(jso));
+#endif
}
return printbuf_memappend(pb, szBuffer, static_cast<int>(strlen(szBuffer)));
}
@@ -1417,11 +1436,23 @@ OGR_json_double_with_significant_figures
{
char szBuffer[75] = {};
int nSize = 0;
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
if( CPLIsNan(jso->o.c_double))
+#else
+ if( CPLIsNan(json_object_get_double(jso)))
+#endif
nSize = CPLsnprintf(szBuffer, sizeof(szBuffer), "NaN");
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
else if( CPLIsInf(jso->o.c_double) )
+#else
+ else if( CPLIsInf(json_object_get_double(jso)) )
+#endif
{
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
if( jso->o.c_double > 0 )
+#else
+ if( json_object_get_double(jso) > 0 )
+#endif
nSize = CPLsnprintf(szBuffer, sizeof(szBuffer), "Infinity");
else
nSize = CPLsnprintf(szBuffer, sizeof(szBuffer), "-Infinity");
@@ -1429,13 +1460,22 @@ OGR_json_double_with_significant_figures
else
{
char szFormatting[32] = {};
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
const int nSignificantFigures = (int) (GUIntptr_t) jso->_userdata;
+#else
+ const int nSignificantFigures = (int) (GUIntptr_t) json_object_get_userdata(jso);
+#endif
const int nInitialSignificantFigures =
nSignificantFigures >= 0 ? nSignificantFigures : 17;
CPLsnprintf(szFormatting, sizeof(szFormatting),
"%%.%dg", nInitialSignificantFigures);
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
nSize = CPLsnprintf(szBuffer, sizeof(szBuffer),
szFormatting, jso->o.c_double);
+#else
+ nSize = CPLsnprintf(szBuffer, sizeof(szBuffer),
+ szFormatting, json_object_get_double(jso));
+#endif
const char* pszDot = NULL;
if( nSize+2 < static_cast<int>(sizeof(szBuffer)) &&
(pszDot = strchr(szBuffer, '.')) == NULL )
@@ -1456,8 +1496,13 @@ OGR_json_double_with_significant_figures
{
CPLsnprintf(szFormatting, sizeof(szFormatting),
"%%.%dg", nInitialSignificantFigures- i);
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
nSize = CPLsnprintf(szBuffer, sizeof(szBuffer),
szFormatting, jso->o.c_double);
+#else
+ nSize = CPLsnprintf(szBuffer, sizeof(szBuffer),
+ szFormatting, json_object_get_double(jso));
+#endif
pszDot = strchr(szBuffer, '.');
if( pszDot != NULL &&
strstr(pszDot, "999999") == NULL &&
@@ -1471,8 +1516,13 @@ OGR_json_double_with_significant_figures
{
CPLsnprintf(szFormatting, sizeof(szFormatting),
"%%.%dg", nInitialSignificantFigures);
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
nSize = CPLsnprintf(szBuffer, sizeof(szBuffer),
szFormatting, jso->o.c_double);
+#else
+ nSize = CPLsnprintf(szBuffer, sizeof(szBuffer),
+ szFormatting, json_object_get_double(jso));
+#endif
if( nSize+2 < static_cast<int>(sizeof(szBuffer)) &&
strchr(szBuffer, '.') == NULL )
{

View file

@ -1,28 +0,0 @@
Description: pass INSTALLDIRS=vendor to Makefile.PL to get stuff into the right place
Origin: vendor
Forwarded: not-needed
Author: gregor herrmann <gregoa@debian.org>
Last-Update: 2014-07-08
--- a/swig/perl/Makefile
+++ b/swig/perl/Makefile
@@ -7,7 +7,7 @@ build: Makefile_Geo__GDAL
$(MAKE) -f Makefile_Geo__OSR
Makefile_Geo__GDAL:
- perl Makefile.PL INSTALL_BASE=$(INST_PREFIX)
+ perl Makefile.PL INSTALLDIRS=vendor
test: build
$(MAKE) -f Makefile_Geo__GDAL test
--- a/swig/perl/GNUmakefile
+++ b/swig/perl/GNUmakefile
@@ -30,7 +30,7 @@ build: gdal_wrap.cc Makefile_Geo__GDAL
gdal_wrap.cc: generate
Makefile_Geo__GDAL:
- perl Makefile.PL INSTALL_BASE=$(INST_PREFIX)
+ perl Makefile.PL INSTALLDIRS=vendor
test: build
$(MAKE) -f Makefile_Geo__GDAL test

View file

@ -1,93 +0,0 @@
2017-11-26 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.2.3-1
2017-10-21 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.2.2-1
2017-08-06 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.2.1-1
2017-07-10 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.2.0-1
* hdf5 1.10.1 rebuild
2017-01-22 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.1.2-1
2016-08-02 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.1.1-1 glew 2.0.0 / poppler 0.46.0 rebuilds rebuild
2016-06-05 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.1.0-2 cfitsio 3.390 rebuild
2016-05-22 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.1.0-1
2016-04-12 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.0.2-5
* hdf5 1.10.0 rebuild
2016-02-08 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.0.2-1
2016-01-23 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.0.0-7
* postgresql-libs 9.5 rebuild
* openjpeg2 added as dependency
2015-10-06 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.0.1-2 FS#46581 fix
2015-06-27 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 2.0.0-1
2015-03-01 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.11.2-2 poppler 0.31.0 rebuild
2015-02-23 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.11.2-1
2015-01-29 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.11.1-6 poppler 0.30.0 rebuild
2014-12-22 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.11.1-5 FS#43193 fix
2014-12-20 Evangelos Foutras <evangelos@foutrelis.com>
* gdal 1.11.1-4 poppler 0.29.0 rebuild
2014-11-25 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.11.1-3 hdf5 1.8.14 rebuild
2014-10-03 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.11.1-1
2014-07-28 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.11.0-4 libspatialite soname rebuild
2014-05-27 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.11.0-2 giflib soname rebuild
2014-04-27 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.11.0-1
2013-11-11 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.10.1-1
2013-09-29 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.10.0-4 FS#36328 fix
2013-05-18 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.10.0-1
2011-02-19 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* gdal 1.8.0-1
2010-11-20 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* Update to major release 1.7.3
2010-06-26 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* FS#19946 fixed in 1.7.2-2
2010-05-05 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* Update to major release 1.7.2