mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
aur/shonenjump to 0.8.0-2
This commit is contained in:
parent
39505a7328
commit
bf016a80a9
2 changed files with 31 additions and 1 deletions
25
aur/shonenjump/0001-store.go-do-not-call-Age.patch
Normal file
25
aur/shonenjump/0001-store.go-do-not-call-Age.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From a6b29a74b492f8792c74304081e454ef9f314324 Mon Sep 17 00:00:00 2001
|
||||
From: graysky <therealgraysky@proton.me>
|
||||
Date: Tue, 1 Nov 2022 07:44:06 -0400
|
||||
Subject: [PATCH] store.go: do not call Age()
|
||||
|
||||
---
|
||||
jump/store.go | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/jump/store.go b/jump/store.go
|
||||
index 855e003..8b4f5d0 100644
|
||||
--- a/jump/store.go
|
||||
+++ b/jump/store.go
|
||||
@@ -30,7 +30,7 @@ func (s Store) AddPath(pathToAdd string) error {
|
||||
if err != nil {
|
||||
return err
|
||||
}
|
||||
- oldEntries.Age()
|
||||
+ // oldEntries.Age()
|
||||
newEntries := oldEntries.Update(path, defaultWeight)
|
||||
return s.saveEntries(newEntries)
|
||||
}
|
||||
--
|
||||
2.38.1
|
||||
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
pkgname=shonenjump
|
||||
pkgver=0.8.0
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="A faster way to change directory and improve command line productivity"
|
||||
arch=(x86_64)
|
||||
url="https://github.com/suzaku/shonenjump"
|
||||
|
@ -14,6 +14,11 @@ install=readme.install
|
|||
source=("$pkgname-$pkgver.tar.gz::https://github.com/suzaku/shonenjump/archive/refs/tags/v$pkgver.tar.gz")
|
||||
b2sums=('9b46e3a27d29b2b1d3be3a703b90e33f5b4c5e5d3377df12bdcd5eee1efca9c35858b32462b9d100541fa76b59bac3b07f07d37825c83c510edca59504fffaf0')
|
||||
|
||||
prepare() {
|
||||
cd "$pkgname-$pkgver"
|
||||
patch -p1 -i ../0001-store.go-do-not-call-Age.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$pkgname-$pkgver"
|
||||
CGO_CPPFLAGS="${CPPFLAGS}" CGO_CFLAGS="${CFLAGS}" CGO_CXXFLAGS="${CXXFLAGS}" CGO_LDFLAGS="${LDFLAGS}" \
|
||||
|
|
Loading…
Reference in a new issue