mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/x265 to 2.2-1
This commit is contained in:
parent
fd8f881f43
commit
bf190beb7b
2 changed files with 10 additions and 10 deletions
|
@ -7,8 +7,8 @@
|
|||
# - patch to attempt fixing ARM hackery by bandwagoning developers
|
||||
|
||||
pkgname=x265
|
||||
pkgver=2.1
|
||||
pkgrel=2
|
||||
pkgver=2.2
|
||||
pkgrel=1
|
||||
pkgdesc='Open Source H265/HEVC video encoder'
|
||||
arch=('i686' 'x86_64')
|
||||
url='https://bitbucket.org/multicoreware/x265'
|
||||
|
@ -18,8 +18,8 @@ makedepends=('yasm' 'cmake')
|
|||
provides=('libx265.so')
|
||||
source=("https://bitbucket.org/multicoreware/x265/downloads/x265_${pkgver}.tar.gz"
|
||||
arm.patch)
|
||||
sha256sums=('88fcb9af4ba52c0757ac9c0d8cd5ec79951a22905ae886897e06954353d6a643'
|
||||
'394cbf7e6f9f51e9f525698d73739fb0c94e6e7c810321ea14c964440f74877d')
|
||||
sha256sums=('b872552535e41fbffa03ba7cbcd3479c42c4053868309292e78e147b7773ac4b'
|
||||
'c3e80d7261d5fef72bfea5c5dd4613c1e997315dc7d0d9465f99356287a8d46b')
|
||||
|
||||
prepare() {
|
||||
cd x265_${pkgver}
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
|
||||
--- a/source/CMakeLists.txt 2016-09-27 03:05:59.000000000 -0600
|
||||
+++ b/source/CMakeLists.txt 2016-10-02 08:43:12.796597758 -0600
|
||||
--- a/source/CMakeLists.txt 2016-12-22 22:57:39.000000000 -0700
|
||||
+++ b/source/CMakeLists.txt 2016-12-28 06:36:06.297232756 -0700
|
||||
@@ -41,7 +41,7 @@
|
||||
# System architecture detection
|
||||
string(TOLOWER "${CMAKE_SYSTEM_PROCESSOR}" SYSPROC)
|
||||
|
@ -10,7 +10,7 @@ diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
|
|||
list(FIND X86_ALIASES "${SYSPROC}" X86MATCH)
|
||||
list(FIND ARM_ALIASES "${SYSPROC}" ARMMATCH)
|
||||
set(POWER_ALIASES ppc64 ppc64le)
|
||||
@@ -66,9 +66,17 @@
|
||||
@@ -71,9 +71,17 @@
|
||||
else()
|
||||
set(CROSS_COMPILE_ARM 0)
|
||||
endif()
|
||||
|
@ -30,7 +30,7 @@ diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
|
|||
else()
|
||||
message(STATUS "CMAKE_SYSTEM_PROCESSOR value `${CMAKE_SYSTEM_PROCESSOR}` is unknown")
|
||||
message(STATUS "Please add this value near ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE}")
|
||||
@@ -190,18 +198,6 @@
|
||||
@@ -208,18 +216,6 @@
|
||||
endif()
|
||||
endif()
|
||||
endif()
|
||||
|
@ -50,8 +50,8 @@ diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
|
|||
if(INTEL_CXX)
|
||||
add_definitions(-prof-gen -prof-dir="${CMAKE_CURRENT_BINARY_DIR}")
|
||||
diff -urN a/source/common/cpu.cpp b/source/common/cpu.cpp
|
||||
--- a/source/common/cpu.cpp 2016-09-27 03:05:59.000000000 -0600
|
||||
+++ b/source/common/cpu.cpp 2016-10-02 08:43:12.796597758 -0600
|
||||
--- a/source/common/cpu.cpp 2016-12-22 22:57:39.000000000 -0700
|
||||
+++ b/source/common/cpu.cpp 2016-12-28 06:36:06.297232756 -0700
|
||||
@@ -37,7 +37,7 @@
|
||||
#include <machine/cpu.h>
|
||||
#endif
|
||||
|
|
Loading…
Reference in a new issue