extra/calligra to 3.2.1-58

This commit is contained in:
David Beauchamp 2024-05-03 08:22:02 -04:00
parent 1ff887d026
commit bf346fe4eb
3 changed files with 20 additions and 2 deletions

View file

@ -1,7 +1,7 @@
pkgbase = calligra
pkgdesc = A set of applications for productivity and creative usage
pkgver = 3.2.1
pkgrel = 57
pkgrel = 58
url = https://www.calligra-suite.org/
arch = x86_64
license = FDL1.2
@ -58,6 +58,7 @@ pkgbase = calligra
source = 068cd9ae.patch
source = 2ac46db5.patch
source = 62f51070.patch
source = libgit2-1.8.patch
source = https://invent.kde.org/office/calligra/-/commit/236bacbe.patch
source = https://invent.kde.org/office/calligra/-/commit/6b75bec7.patch
validpgpkeys = 05D00A8B73A686789E0A156858B9596C722EA3BD
@ -68,6 +69,7 @@ pkgbase = calligra
sha256sums = 4516d15421209e5d8c8b5008140dbcb1eefa96b0e96e0da49b343e1799a8cefd
sha256sums = c88e6d7a1f67c1b5413b624aa67fca2841205fdf4201f6682f69bae737582922
sha256sums = 8a94e076c09887ff0741da3276ce4652063351b884c66d4c9ba0cde431dbb867
sha256sums = e79f1068a7c0bf9f4af63c379d3dc1e10bfa7f8c9953dfc172460cf14c9e7b55
sha256sums = 94ce2242774d18df21dd594f2d9dce752ffda0349b2c2c872dfe39cb73353aab
sha256sums = 0eb880b19f32fe4045831415fe5849e43db09be3f7550c4abfe21e4511dfb1a5

View file

@ -9,7 +9,7 @@
pkgname=calligra
pkgdesc='A set of applications for productivity and creative usage'
pkgver=3.2.1
pkgrel=57
pkgrel=58
arch=(x86_64)
url='https://www.calligra-suite.org/'
license=(FDL1.2 GPL2 LGPL)
@ -62,6 +62,7 @@ source=(https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz
068cd9ae.patch
2ac46db5.patch
62f51070.patch
libgit2-1.8.patch
https://invent.kde.org/office/calligra/-/commit/236bacbe.patch
https://invent.kde.org/office/calligra/-/commit/6b75bec7.patch)
sha256sums=('b1f8a6eb8208543a2f908caa83d089075fcd1e530d00e19f5362b2f9cc371147'
@ -70,6 +71,7 @@ sha256sums=('b1f8a6eb8208543a2f908caa83d089075fcd1e530d00e19f5362b2f9cc371147'
'4516d15421209e5d8c8b5008140dbcb1eefa96b0e96e0da49b343e1799a8cefd'
'c88e6d7a1f67c1b5413b624aa67fca2841205fdf4201f6682f69bae737582922'
'8a94e076c09887ff0741da3276ce4652063351b884c66d4c9ba0cde431dbb867'
'e79f1068a7c0bf9f4af63c379d3dc1e10bfa7f8c9953dfc172460cf14c9e7b55'
'94ce2242774d18df21dd594f2d9dce752ffda0349b2c2c872dfe39cb73353aab'
'0eb880b19f32fe4045831415fe5849e43db09be3f7550c4abfe21e4511dfb1a5')
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
@ -82,6 +84,7 @@ prepare() {
patch -d $pkgname-$pkgver -p1 < 62f51070.patch # Fix fontconfig linking
patch -d $pkgname-$pkgver -p1 < 236bacbe.patch # Fix build with poppler 22.03.0
patch -d $pkgname-$pkgver -p1 < 6b75bec7.patch # Fix build with poppler 22.04.0
patch -d $pkgname-$pkgver -p1 < libgit2-1.8.patch # Fix build with libgit2 1.8
}
build() {

View file

@ -0,0 +1,13 @@
diff --git a/gemini/cloud/git/gitcontroller.cpp b/gemini/cloud/git/gitcontroller.cpp
index 9f65fd183a4..86473c0ea6a 100644
--- a/gemini/cloud/git/gitcontroller.cpp
+++ b/gemini/cloud/git/gitcontroller.cpp
@@ -404,7 +404,7 @@ void GitOpsThread::performPull()
git_commit_create(&commit_id, repository, "HEAD", d->signature, d->signature,
NULL, message.ptr,
- tree, 2, (const git_commit **) parents);
+ tree, 2, (git_commit * const *) parents);
git_tree_free(tree);
}
git_index_free(index);