extra/x264: remove aarch64 patch

This commit is contained in:
Kevin Mihelich 2015-07-29 00:03:20 +00:00
parent 8d71ef7376
commit bf719303f6
2 changed files with 2 additions and 19 deletions

View file

@ -18,10 +18,8 @@ license=('GPL')
depends=('glibc')
makedepends=('yasm' 'git' 'ffmpeg' 'l-smash')
_commit=73ae2d11d472d0eb3b7c218dc1659db32f649b14
source=("git://git.videolan.org/x264.git#commit=${_commit}"
'aarch64.patch')
md5sums=('SKIP'
'cfea784ff527edab0972a540660f4000')
source=(git://git.videolan.org/x264.git#commit=${_commit})
md5sums=('SKIP')
pkgver() {
cd $pkgname
@ -32,9 +30,6 @@ pkgver() {
}
prepare() {
cd $pkgname
patch -p1 -i ../aarch64.patch
cd ..
cp -r $pkgname $pkgname-10bit
}

View file

@ -1,12 +0,0 @@
diff -urN a/configure b/configure
--- a/configure 2015-07-15 23:13:53.689889673 -0600
+++ b/configure 2015-07-15 23:15:02.609508868 -0600
@@ -789,7 +789,7 @@
if [ $asm = auto -a $ARCH = AARCH64 ] ; then
# set flags so neon is built by default
- echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu|-arch)' || CFLAGS="$CFLAGS -arch arm64 -mfpu=neon"
+ echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu|-arch)' || CFLAGS="$CFLAGS"
if cc_check '' '' '__asm__("cmeq v0.8h, v0.8h, #0");' ; then define HAVE_NEON
ASFLAGS="$ASFLAGS -c"