added community/rebar

This commit is contained in:
Kevin Mihelich 2015-09-08 01:19:38 +00:00
parent 0fb5c8b475
commit bf8257d61a
2 changed files with 53 additions and 0 deletions

38
community/rebar/PKGBUILD Normal file
View file

@ -0,0 +1,38 @@
# $Id$
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: AeroNotix <aaron.l.france@gmail.com>
# Contributor: AeroNotix <aaron.l.france@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch for AArch64 (https://github.com/rebar/rebar/pull/538)
pkgname=rebar
epoch=1
pkgver=2.6.0
pkgrel=1.1
pkgdesc="A sophisticated build-tool for Erlang projects that follows OTP principles."
arch=('any')
url="https://github.com/rebar/rebar"
license=('APACHE')
depends=('erlang-nox')
makedepends=('git')
source=("$pkgname-$pkgver.tar.gz::https://github.com/rebar/rebar/archive/$pkgver.tar.gz"
'aarch64.patch')
md5sums=('20aea5eafe90f68accfe9487974ed0bf'
'72bcc92fe06030bba13295bfc5578947')
prepare() {
cd "$srcdir/rebar-$pkgver"
patch -p1 -i ../aarch64.patch
}
build() {
cd "$srcdir/rebar-$pkgver"
make
}
package() {
cd "$srcdir/rebar-$pkgver"
install -Dm0755 "rebar" "$pkgdir/usr/bin/rebar"
install -Dm0644 "priv/shell-completion/bash/rebar" "$pkgdir/usr/share/bash-completion/completions/rebar"
}

View file

@ -0,0 +1,15 @@
diff -urN a/src/rebar_port_compiler.erl b/src/rebar_port_compiler.erl
--- a/src/rebar_port_compiler.erl 2015-06-19 10:14:28.000000000 -0600
+++ b/src/rebar_port_compiler.erl 2015-09-07 19:16:25.828631245 -0600
@@ -604,11 +604,6 @@
{"solaris.*-64$", "CXXFLAGS", "-D_REENTRANT -m64 $CXXFLAGS"},
{"solaris.*-64$", "LDFLAGS", "-m64 $LDFLAGS"},
- %% Linux specific flags for multiarch
- {"linux.*-64$", "CFLAGS", "-m64 $CFLAGS"},
- {"linux.*-64$", "CXXFLAGS", "-m64 $CXXFLAGS"},
- {"linux.*-64$", "LDFLAGS", "$LDFLAGS"},
-
%% OS X Leopard flags for 64-bit
{"darwin9.*-64$", "CFLAGS", "-m64 $CFLAGS"},
{"darwin9.*-64$", "CXXFLAGS", "-m64 $CXXFLAGS"},