mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added extra/calligra
This commit is contained in:
parent
7915aa18c5
commit
bf86d52ebc
14 changed files with 383 additions and 0 deletions
226
extra/calligra/PKGBUILD
Normal file
226
extra/calligra/PKGBUILD
Normal file
|
@ -0,0 +1,226 @@
|
|||
# $Id: PKGBUILD 171683 2012-11-21 11:19:58Z andrea $
|
||||
# Maintainer: Ronald van Haren <ronald.archlinux.org>
|
||||
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - added patch to fix building on ARM
|
||||
|
||||
pkgbase=calligra
|
||||
pkgname=('calligra-filters'
|
||||
'calligra-libs'
|
||||
'calligra-plugins'
|
||||
'calligra-tools'
|
||||
'calligra-karbon'
|
||||
'calligra-kexi'
|
||||
'calligra-plan'
|
||||
'calligra-stage'
|
||||
'calligra-krita'
|
||||
'calligra-sheets'
|
||||
'calligra-words'
|
||||
'calligra-handbook'
|
||||
'calligra-braindump'
|
||||
'calligra-flow')
|
||||
pkgver=2.5.4
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://www.calligra-suite.org/'
|
||||
license=('FDL1.2' 'GPL2' 'LGPL')
|
||||
makedepends=('cmake' 'automoc4' 'boost ' 'kdepimlibs' 'eigen2' 'kdeedu-marble'
|
||||
'lcms2' 'libmysqlclient' 'freetds' 'xbase' 'libwpg'
|
||||
'libwps' 'gsl' 'glew' 'fftw' 'opengtl' 'poppler-qt' 'libkdcraw'
|
||||
'openjpeg' 'kdegraphics-okular' 'pstoedit' 'mesa')
|
||||
groups=('calligra')
|
||||
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.bz2"
|
||||
'arm.patch')
|
||||
md5sums=('54f4677a9b00eec5951fa2386ba271a1'
|
||||
'd61b5bc8abbf5959ca6625f8a4fb5a4e')
|
||||
|
||||
build() {
|
||||
cd "${pkgbase}-${pkgver}"
|
||||
patch -p1 -i ../arm.patch
|
||||
cd ..
|
||||
mkdir build
|
||||
cd build
|
||||
cmake ../${pkgbase}-${pkgver} \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DBUILD_active=OFF
|
||||
make
|
||||
}
|
||||
|
||||
package_calligra-filters() {
|
||||
pkgdesc="Filters for the Calligra office suite"
|
||||
optdepends=('libwpg: Corel WordPerfect Graphics image importer'
|
||||
'libwps: Microsoft Works file word processor format import')
|
||||
conflicts=('koffice-filters')
|
||||
replaces=('koffice-filters')
|
||||
install=calligra-filters.install
|
||||
|
||||
cd "${srcdir}"/build/filters
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_calligra-libs() {
|
||||
pkgdesc="Libraries for the Calligra office suite"
|
||||
depends=('kdepimlibs' 'lcms2')
|
||||
conflicts=('koffice-interfaces' 'koffice-libs' 'koffice-pics'
|
||||
'koffice-servicetypes' 'koffice-templates' 'calligra-interfaces'
|
||||
'calligra-pics' 'calligra-servicetypes' 'calligra-templates')
|
||||
replaces=('koffice-interfaces' 'koffice-libs' 'koffice-pics'
|
||||
'koffice-servicetypes' 'koffice-templates' 'calligra-interfaces'
|
||||
'calligra-pics' 'calligra-servicetypes' 'calligra-templates')
|
||||
|
||||
for d in interfaces libs pics servicetypes templates; do
|
||||
cd "${srcdir}"/build/${d}
|
||||
make DESTDIR="${pkgdir}" install
|
||||
done
|
||||
}
|
||||
|
||||
package_calligra-plugins() {
|
||||
pkgdesc="Plugins for the Calligra office suite"
|
||||
depends=('calligra-libs' 'calligra-filters')
|
||||
optdepends=('kdeedu-marble: map shape for Calligra')
|
||||
conflicts=('koffice-plugins' 'koffice-kchart')
|
||||
replaces=('koffice-plugins' 'koffice-kchart' 'koffice-kformula')
|
||||
|
||||
cd "${srcdir}"/build/plugins
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_calligra-tools() {
|
||||
pkgdesc="Tools for the Calligra office suite"
|
||||
depends=('calligra-libs')
|
||||
conflicts=('koffice-tools')
|
||||
replaces=('koffice-tools')
|
||||
install=calligra-tools.install
|
||||
|
||||
cd "${srcdir}"/build/tools
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_calligra-karbon() {
|
||||
pkgdesc="Create scalable vector drawings"
|
||||
depends=('calligra-libs' 'kdebase-runtime' 'pstoedit')
|
||||
optdepends=('calligra-filters: import/export filters'
|
||||
'calligra-tools: extra calligra tools')
|
||||
conflicts=('koffice-karbon' 'koffice-karbon-doc' 'calligra-karbon-doc')
|
||||
replaces=('koffice-karbon' 'koffice-karbon-doc' 'calligra-karbon-doc')
|
||||
install=calligra-karbon.install
|
||||
|
||||
cd "${srcdir}"/build/karbon
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_calligra-kexi() {
|
||||
pkgdesc="Develop desktop database applications"
|
||||
depends=('calligra-libs' 'glew' 'fftw')
|
||||
optdepends=('libmysqlclient: MySQL driver'
|
||||
'freetds: Sybase & MS SQL driver'
|
||||
'xbase: XBase driver'
|
||||
'calligra-sheets: Spreadsheet-to-Kexi-table import plugin'
|
||||
'kdeedu-marble: map form widget'
|
||||
'calligra-plugins: extra calligra plugins')
|
||||
conflicts=('koffice-kexi' 'koffice-kexi-doc' 'calligra-kexi-doc')
|
||||
replaces=('koffice-kexi' 'koffice-kexi-doc' 'calligra-kexi-doc')
|
||||
install=calligra-kexi.install
|
||||
|
||||
cd "${srcdir}"/build/kexi
|
||||
make DESTDIR="${pkgdir}" install
|
||||
cd "${srcdir}"/build/doc/kexi
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_calligra-plan() {
|
||||
pkgdesc="Calligra Project Management Component"
|
||||
depends=('calligra-words')
|
||||
conflicts=('koffice-kplato' 'calligra-kplato')
|
||||
replaces=('koffice-kplato' 'calligra-kplato')
|
||||
install=calligra-plan.install
|
||||
|
||||
cd "${srcdir}"/build/plan
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_calligra-stage() {
|
||||
pkgdesc="Write presentation documents"
|
||||
depends=('calligra-libs' 'kdebase-runtime')
|
||||
optdepends=('calligra-plugins: extra calligra plugins')
|
||||
conflicts=('koffice-kpresenter' 'koffice-kpresenter-doc' 'calligra-stage-doc')
|
||||
replaces=('koffice-kpresenter' 'koffice-kpresenter-doc' 'calligra-stage-doc')
|
||||
install=calligra-stage.install
|
||||
|
||||
cd "${srcdir}"/build/stage
|
||||
make DESTDIR="${pkgdir}" install
|
||||
cd "${srcdir}"/build/doc/stage
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_calligra-krita() {
|
||||
pkgdesc="Edit and paint images"
|
||||
depends=('calligra-plugins' 'kdebase-runtime' 'eigen2'
|
||||
'poppler-qt' 'libkdcraw' 'fftw' 'glew' 'opengtl')
|
||||
conflicts=('koffice-krita' 'calligra-krita-doc')
|
||||
replaces=('koffice-krita' 'calligra-krita-doc')
|
||||
install=calligra-krita.install
|
||||
|
||||
cd "${srcdir}"/build/krita
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_calligra-sheets() {
|
||||
pkgdesc="Write spreadsheet documents"
|
||||
depends=('calligra-libs' 'gsl' 'kdebase-runtime')
|
||||
optdepends=('calligra-filters: import/export filters'
|
||||
'calligra-plugins: extra calligra plugins'
|
||||
'calligra-tools: extra calligra tools')
|
||||
conflicts=('koffice-kspread' 'koffice-kspread-doc' 'calligra-tables-doc' 'calligra-tables')
|
||||
replaces=('koffice-kspread' 'koffice-kspread-doc' 'calligra-tables-doc' 'calligra-tables')
|
||||
install=calligra-sheets.install
|
||||
|
||||
cd "${srcdir}"/build/sheets
|
||||
make DESTDIR="${pkgdir}" install
|
||||
cd "${srcdir}"/build/doc/sheets
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_calligra-words() {
|
||||
pkgdesc="Word Processor"
|
||||
depends=('calligra-libs' 'kdegraphics-okular')
|
||||
optdepends=('calligra-tools: extra calligra tools')
|
||||
conflicts=('koffice-kword')
|
||||
replaces=('koffice-kword')
|
||||
install=calligra-words.install
|
||||
|
||||
cd "${srcdir}"/build/words
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_calligra-handbook() {
|
||||
pkgdesc="Documentation for Calligra"
|
||||
conflicts=('koffice-handbook')
|
||||
replaces=('koffice-handbook')
|
||||
options=('docs')
|
||||
|
||||
cd "${srcdir}"/build/doc/calligra
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_calligra-braindump() {
|
||||
pkgdesc="Notes and idea gathering"
|
||||
depends=('calligra-libs' 'kdebase-runtime')
|
||||
install=calligra-braindump.install
|
||||
|
||||
cd "${srcdir}"/build/braindump
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_calligra-flow() {
|
||||
pkgdesc="Flowchart & Diagram Editing"
|
||||
depends=('calligra-words')
|
||||
conflicts=('calligra-flow-doc')
|
||||
replaces=('calligra-flow-doc')
|
||||
install=calligra-flow.install
|
||||
|
||||
cd "${srcdir}"/build/flow
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
15
extra/calligra/arm.patch
Normal file
15
extra/calligra/arm.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
Index: calligra-2.5.3/krita/ui/canvas/kis_coordinates_converter.cpp
|
||||
===================================================================
|
||||
--- calligra-2.5.3.orig/krita/ui/canvas/kis_coordinates_converter.cpp 2012-10-09 10:25:56.706529477 +0100
|
||||
+++ calligra-2.5.3/krita/ui/canvas/kis_coordinates_converter.cpp 2012-10-09 10:27:14.963095078 +0100
|
||||
@@ -73,8 +73,8 @@
|
||||
|
||||
QPointF range = maxOffset - minOffset;
|
||||
|
||||
- range.rx() = qMin(range.x(), 0.0);
|
||||
- range.ry() = qMin(range.y(), 0.0);
|
||||
+ range.rx() = qMin(range.x(), (qreal)0.0);
|
||||
+ range.ry() = qMin(range.y(), (qreal)0.0);
|
||||
|
||||
range /= 2;
|
||||
|
12
extra/calligra/calligra-braindump.install
Normal file
12
extra/calligra/calligra-braindump.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
11
extra/calligra/calligra-filters.install
Normal file
11
extra/calligra/calligra-filters.install
Normal file
|
@ -0,0 +1,11 @@
|
|||
post_install() {
|
||||
update-mime-database usr/share/mime &> /dev/null
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
12
extra/calligra/calligra-flow.install
Normal file
12
extra/calligra/calligra-flow.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
12
extra/calligra/calligra-karbon.install
Normal file
12
extra/calligra/calligra-karbon.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
11
extra/calligra/calligra-kexi.install
Normal file
11
extra/calligra/calligra-kexi.install
Normal file
|
@ -0,0 +1,11 @@
|
|||
post_install() {
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
13
extra/calligra/calligra-krita.install
Normal file
13
extra/calligra/calligra-krita.install
Normal file
|
@ -0,0 +1,13 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
update-mime-database usr/share/mime &> /dev/null
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
12
extra/calligra/calligra-plan.install
Normal file
12
extra/calligra/calligra-plan.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
12
extra/calligra/calligra-sheets.install
Normal file
12
extra/calligra/calligra-sheets.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
12
extra/calligra/calligra-stage.install
Normal file
12
extra/calligra/calligra-stage.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
12
extra/calligra/calligra-tools.install
Normal file
12
extra/calligra/calligra-tools.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
12
extra/calligra/calligra-words.install
Normal file
12
extra/calligra/calligra-words.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
11
extra/calligra/calligra.install
Normal file
11
extra/calligra/calligra.install
Normal file
|
@ -0,0 +1,11 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
Loading…
Reference in a new issue