community/gitea to 1.13.0-1

This commit is contained in:
Kevin Mihelich 2020-12-06 16:48:42 +00:00
parent fde48f5628
commit bf951ef606
2 changed files with 14 additions and 15 deletions

View file

@ -7,7 +7,7 @@
# - don't check repo signature until author puts his keys on keyservers
pkgname=gitea
pkgver=1.12.6
pkgver=1.13.0
pkgrel=1
pkgdesc="Painless self-hosted Git service. Community managed fork of Gogs."
arch=(x86_64)
@ -25,7 +25,7 @@ optdepends=(
'sqlite: SQLite support'
)
backup=('etc/gitea/app.ini')
_tag=08209589da0f669a4595841ff3b7d99c3673182c # git rev-parse v${pkgver}
_tag=f55e479eaaef1b1150ac2ee36b1f4f30cd154dce # git rev-parse v${pkgver}
source=("git+https://github.com/go-gitea/gitea.git#tag=${_tag}"
gitea.tmpfiles
gitea.service
@ -35,7 +35,7 @@ sha256sums=('SKIP'
'1521fd7edc3830c695698ffe9835709f1408040b5ec989f07410972c894fa8ba'
'3ad603263c6e79c5ab35ed37a3c45115b0af97c8beb027d2fbe7fa5cfa34b2eb'
'7e7b798b8ce035c1fb55993ece41c5efb6cad5922708866804fa50ada0cf9fa5'
'33ef77053a6bc8e2f5d9b62c92681909858d78356dfc7970616c42ad1dc60c57')
'9209c385a59cef83fd4c526b445de998c7b30c345c0b6101570142b4ce29ee1f')
validpgpkeys=(
8C4033A23895237CB27D52D9D9B5613BEB813F99 # Matti Ranta <matti@mdranta.net> old RSA2048, retrieved from https://github.com/techknowlogick.gpg
B56E3C7437A49E136862F5DE9D8A57ADAA232E95 # Matti Ranta <matti@mdranta.net> new RSA4096, retrieved from https://github.com/techknowlogick.gpg
@ -77,5 +77,5 @@ package() {
install -Dm644 ${pkgname}.service -t "${pkgdir}"/usr/lib/systemd/system/
install -Dm644 ${pkgname}.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/${pkgname}.conf
install -Dm644 ${pkgname}.sysusers "${pkgdir}"/usr/lib/sysusers.d/${pkgname}.conf
install -D ${pkgname}/custom/conf/app.ini.sample "${pkgdir}"/etc/gitea/app.ini
install -D ${pkgname}/custom/conf/app.example.ini "${pkgdir}"/etc/gitea/app.ini
}

View file

@ -1,22 +1,21 @@
--- a/custom/conf/app.ini.sample
+++ b/custom/conf/app.ini.sample
@@ -7,12 +7,12 @@
--- a/custom/conf/app.example.ini
+++ b/custom/conf/app.example.ini
@@ -7,6 +7,6 @@
; App name that shows in every page title
APP_NAME = Gitea: Git with a cup of tea
; Change it if you run locally
-RUN_USER = git
+RUN_USER = gitea
; Either "dev", "prod" or "test", default is "dev"
-RUN_MODE = dev
+RUN_MODE = prod
; Application run mode, affects performance and debugging. Either "dev", "prod" or "test", default is "prod"
RUN_MODE = prod
@@ -18,5 +18,5 @@
[repository]
-ROOT =
+ROOT = /var/lib/gitea/repos
SCRIPT_TYPE = bash
; Default ANSI charset
ANSI_CHARSET =
@@ -378,7 +378,7 @@ SQLITE_TIMEOUT = 500
; DETECTED_CHARSETS_ORDER tie-break order for detected charsets.
@@ -424,7 +424,7 @@ SQLITE_TIMEOUT = 500
; For iterate buffer, default is 50
ITERATE_BUFFER_SIZE = 50
; Show the database generated SQL
@ -25,7 +24,7 @@
; Maximum number of DB Connect retries
DB_RETRIES = 10
; Backoff time per DB retry (time.Duration)
@@ -751,10 +751,10 @@ FORMAT =
@@ -838,10 +838,10 @@ FORMAT =
DEFAULT_UI_LOCATION =
[log]
@ -38,7 +37,7 @@
; Buffer length of the channel, keep it as it is if you don't know what it is.
BUFFER_LEN = 10000
REDIRECT_MACARON_LOG = false
@@ -779,7 +779,7 @@ COLORIZE = false
@@ -866,7 +866,7 @@ COLORIZE = false
; For "console" mode only
[log.console]