mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/gnuradio to 3.7.13.5-1
This commit is contained in:
parent
c851287e76
commit
bfb9f3c40d
4 changed files with 9 additions and 169 deletions
|
@ -7,8 +7,8 @@
|
|||
|
||||
pkgbase=gnuradio
|
||||
pkgname=(gnuradio gnuradio-companion)
|
||||
pkgver=3.7.13.4
|
||||
pkgrel=5
|
||||
pkgver=3.7.13.5
|
||||
pkgrel=1
|
||||
pkgdesc="General purpose DSP and SDR toolkit. With drivers for usrp and fcd."
|
||||
arch=('x86_64')
|
||||
url="http://gnuradio.org"
|
||||
|
@ -31,18 +31,16 @@ makedepends=('boost' 'cmake' 'python2-lxml' 'python2-cheetah' 'glu' 'swig'
|
|||
|
||||
# secret release directory
|
||||
#source=("http://s3-dist.gnuradio.org/gnuradio-$pkgver.tar.gz"
|
||||
source=("https://gnuradio.org/releases/$pkgbase/$pkgbase-$pkgver.tar.gz"
|
||||
"https://gnuradio.org/releases/$pkgbase/$pkgbase-$pkgver.tar.gz.asc"
|
||||
"21-fcd.rules" "gnuradio-gcc7.patch"
|
||||
"boost-1.67.patch" "boost-1.67-pthread.patch")
|
||||
# neglected official release directory
|
||||
#source=("https://gnuradio.org/releases/$pkgbase/$pkgbase-$pkgver.tar.gz"
|
||||
source=("https://github.com/gnuradio/gnuradio/releases/download/v$pkgver/gnuradio-$pkgver.tar.gz"
|
||||
"https://github.com/gnuradio/gnuradio/releases/download/v$pkgver/gnuradio-$pkgver.tar.gz.asc"
|
||||
"21-fcd.rules")
|
||||
validpgpkeys=('B90DDFAC56989BF62262EB812987C77CBB8ED9B2' # GNU Radio Project
|
||||
'D74F9F146E7F755783583158B343B2BA293E5174') # Marcus Müller
|
||||
md5sums=('b38d9cfa7cb4dcb97f5d19ebcabe8dcb'
|
||||
md5sums=('489e5469b516afe6b0638752fb77bc7f'
|
||||
'SKIP'
|
||||
'465e12c454c6a22ebec9849181af7bdc'
|
||||
'c510104fa2ad9852a683c265c42ae1da'
|
||||
'204b87f1663411c17e5b40e9073e9d48'
|
||||
'7f177cb699393cb4141d8eaa927c0c4a')
|
||||
'465e12c454c6a22ebec9849181af7bdc')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgbase-$pkgver"
|
||||
|
@ -52,11 +50,6 @@ prepare() {
|
|||
$(find ./ -name 'gnuradio-companion' -o -name 'flow_graph.tmpl')
|
||||
sed -i -e "s|#![ ]*/usr/bin/env /usr/bin/python$|#!/usr/bin/env python2|" \
|
||||
$(find ./ -name '*.py')
|
||||
# fix build with GCC 7 (Fedora)
|
||||
#patch -p1 -N -i ../gnuradio-gcc7.patch
|
||||
# https://github.com/gnuradio/gnuradio/pull/1733
|
||||
#patch -p1 -N -i ../boost-1.67.patch
|
||||
#patch -p1 -N -i ../boost-1.67-pthread.patch
|
||||
# GCC 7?
|
||||
#sed -i 's|SET(CMAKE_CXX_STANDARD 98)|#&|' CMakeLists.txt
|
||||
#sed -i 's|SET(CMAKE_C_FLAGS .* -std=gnu99"|#&|' CMakeLists.txt
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
diff -upr gnuradio-3.7.11.orig/gr-blocks/lib/CMakeLists.txt gnuradio-3.7.11/gr-blocks/lib/CMakeLists.txt
|
||||
--- gnuradio-3.7.11.orig/gr-blocks/lib/CMakeLists.txt 2017-02-28 01:19:00.000000000 +0200
|
||||
+++ gnuradio-3.7.11/gr-blocks/lib/CMakeLists.txt 2018-06-03 07:12:46.110899996 +0300
|
||||
@@ -328,6 +328,7 @@ if(ENABLE_TESTING)
|
||||
gnuradio-runtime
|
||||
gnuradio-blocks
|
||||
${Boost_LIBRARIES}
|
||||
+ ${CMAKE_THREAD_LIBS_INIT}
|
||||
${CPPUNIT_LIBRARIES}
|
||||
${LOG4CPP_LIBRARIES}
|
||||
)
|
||||
diff -upr gnuradio-3.7.11.orig/gr-uhd/examples/c++/CMakeLists.txt gnuradio-3.7.11/gr-uhd/examples/c++/CMakeLists.txt
|
||||
--- gnuradio-3.7.11.orig/gr-uhd/examples/c++/CMakeLists.txt 2017-02-28 01:19:00.000000000 +0200
|
||||
+++ gnuradio-3.7.11/gr-uhd/examples/c++/CMakeLists.txt 2018-06-03 07:12:53.401117802 +0300
|
||||
@@ -35,7 +35,7 @@ link_directories(${Boost_LIBRARY_DIRS})
|
||||
# Build executable
|
||||
########################################################################
|
||||
add_executable(tags_demo tags_demo.cc)
|
||||
-target_link_libraries(tags_demo gnuradio-uhd)
|
||||
+target_link_libraries(tags_demo gnuradio-uhd ${CMAKE_THREAD_LIBS_INIT})
|
||||
|
||||
INSTALL(TARGETS
|
||||
tags_demo
|
|
@ -1,59 +0,0 @@
|
|||
From b320213c6611cd0ab02034ec1ff1380e83dab8e1 Mon Sep 17 00:00:00 2001
|
||||
From: ilovezfs <ilovezfs@icloud.com>
|
||||
Date: Tue, 17 Apr 2018 03:25:30 -0700
|
||||
Subject: [PATCH] Boost 1.67 compatibility
|
||||
|
||||
---
|
||||
gr-blocks/lib/message_strobe_impl.cc | 2 +-
|
||||
gr-blocks/lib/message_strobe_random_impl.cc | 2 +-
|
||||
gr-uhd/lib/usrp_block_impl.cc | 4 ++--
|
||||
3 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/gr-blocks/lib/message_strobe_impl.cc b/gr-blocks/lib/message_strobe_impl.cc
|
||||
index 059584e636..cee7bfccf3 100644
|
||||
--- a/gr-blocks/lib/message_strobe_impl.cc
|
||||
+++ b/gr-blocks/lib/message_strobe_impl.cc
|
||||
@@ -91,7 +91,7 @@ namespace gr {
|
||||
void message_strobe_impl::run()
|
||||
{
|
||||
while(!d_finished) {
|
||||
- boost::this_thread::sleep(boost::posix_time::milliseconds(d_period_ms));
|
||||
+ boost::this_thread::sleep(boost::posix_time::milliseconds(static_cast<long>(d_period_ms)));
|
||||
if(d_finished) {
|
||||
return;
|
||||
}
|
||||
diff --git a/gr-blocks/lib/message_strobe_random_impl.cc b/gr-blocks/lib/message_strobe_random_impl.cc
|
||||
index ab9422717c..08bfd1ff1f 100644
|
||||
--- a/gr-blocks/lib/message_strobe_random_impl.cc
|
||||
+++ b/gr-blocks/lib/message_strobe_random_impl.cc
|
||||
@@ -110,7 +110,7 @@ namespace gr {
|
||||
void message_strobe_random_impl::run()
|
||||
{
|
||||
while(!d_finished) {
|
||||
- boost::this_thread::sleep(boost::posix_time::milliseconds(std::max(0.0f,next_delay())));
|
||||
+ boost::this_thread::sleep(boost::posix_time::milliseconds(static_cast<long>(std::max(0.0f,next_delay()))));
|
||||
if(d_finished) {
|
||||
return;
|
||||
}
|
||||
diff --git a/gr-uhd/lib/usrp_block_impl.cc b/gr-uhd/lib/usrp_block_impl.cc
|
||||
index 70256d3071..84a6791cf7 100644
|
||||
--- a/gr-uhd/lib/usrp_block_impl.cc
|
||||
+++ b/gr-uhd/lib/usrp_block_impl.cc
|
||||
@@ -196,7 +196,7 @@ bool usrp_block_impl::_wait_for_locked_sensor(
|
||||
|
||||
while (true) {
|
||||
if ((not first_lock_time.is_not_a_date_time()) and
|
||||
- (boost::get_system_time() > (first_lock_time + boost::posix_time::seconds(LOCK_TIMEOUT)))) {
|
||||
+ (boost::get_system_time() > (first_lock_time + boost::posix_time::seconds(static_cast<long>(LOCK_TIMEOUT))))) {
|
||||
break;
|
||||
}
|
||||
|
||||
@@ -207,7 +207,7 @@ bool usrp_block_impl::_wait_for_locked_sensor(
|
||||
else {
|
||||
first_lock_time = boost::system_time(); //reset to 'not a date time'
|
||||
|
||||
- if (boost::get_system_time() > (start + boost::posix_time::seconds(LOCK_TIMEOUT))){
|
||||
+ if (boost::get_system_time() > (start + boost::posix_time::seconds(static_cast<long>(LOCK_TIMEOUT)))){
|
||||
return false;
|
||||
}
|
||||
}
|
|
@ -1,71 +0,0 @@
|
|||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 0ac65fe..71378aa 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -62,7 +62,7 @@ ENDIF()
|
||||
# set(CMAKE_CXX_STANDARD 98)
|
||||
|
||||
IF(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
|
||||
- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98")
|
||||
+# SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98")
|
||||
ELSEIF(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
|
||||
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98")
|
||||
ELSEIF(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
|
||||
@@ -72,7 +72,7 @@ ELSE()
|
||||
ENDIF()
|
||||
|
||||
IF(CMAKE_C_COMPILER_ID STREQUAL "GNU")
|
||||
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
|
||||
+# SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
|
||||
ELSEIF(CMAKE_C_COMPILER_ID STREQUAL "Clang")
|
||||
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
|
||||
ELSEIF(CMAKE_C_COMPILER_ID STREQUAL "MSVC")
|
||||
diff --git a/gnuradio-runtime/lib/math/qa_fxpt.h b/gnuradio-runtime/lib/math/qa_fxpt.h
|
||||
index 58a6f02..6020e47 100644
|
||||
--- a/gnuradio-runtime/lib/math/qa_fxpt.h
|
||||
+++ b/gnuradio-runtime/lib/math/qa_fxpt.h
|
||||
@@ -25,6 +25,7 @@
|
||||
|
||||
#include <cppunit/extensions/HelperMacros.h>
|
||||
#include <cppunit/TestCase.h>
|
||||
+#include <memory>
|
||||
|
||||
class qa_fxpt : public CppUnit::TestCase
|
||||
{
|
||||
diff --git a/gnuradio-runtime/lib/math/qa_fxpt_nco.h b/gnuradio-runtime/lib/math/qa_fxpt_nco.h
|
||||
index 1b2cdae..1755904 100644
|
||||
--- a/gnuradio-runtime/lib/math/qa_fxpt_nco.h
|
||||
+++ b/gnuradio-runtime/lib/math/qa_fxpt_nco.h
|
||||
@@ -25,6 +25,7 @@
|
||||
|
||||
#include <cppunit/extensions/HelperMacros.h>
|
||||
#include <cppunit/TestCase.h>
|
||||
+#include <memory>
|
||||
|
||||
class qa_fxpt_nco : public CppUnit::TestCase
|
||||
{
|
||||
diff --git a/gnuradio-runtime/lib/math/qa_fxpt_vco.h b/gnuradio-runtime/lib/math/qa_fxpt_vco.h
|
||||
index 72693f3..76e0b6d 100644
|
||||
--- a/gnuradio-runtime/lib/math/qa_fxpt_vco.h
|
||||
+++ b/gnuradio-runtime/lib/math/qa_fxpt_vco.h
|
||||
@@ -25,6 +25,7 @@
|
||||
|
||||
#include <cppunit/extensions/HelperMacros.h>
|
||||
#include <cppunit/TestCase.h>
|
||||
+#include <memory>
|
||||
|
||||
class qa_fxpt_vco : public CppUnit::TestCase
|
||||
{
|
||||
diff --git a/gr-fec/include/gnuradio/fec/polar_decoder_common.h b/gr-fec/include/gnuradio/fec/polar_decoder_common.h
|
||||
index 13b25ea..8a3d65d 100644
|
||||
--- a/gr-fec/include/gnuradio/fec/polar_decoder_common.h
|
||||
+++ b/gr-fec/include/gnuradio/fec/polar_decoder_common.h
|
||||
@@ -68,7 +68,7 @@ namespace gr {
|
||||
bool set_frame_size(unsigned int frame_size){return false;};
|
||||
|
||||
private:
|
||||
- static BOOST_CONSTEXPR_OR_CONST float D_LLR_FACTOR;
|
||||
+ static const float D_LLR_FACTOR;
|
||||
unsigned int d_frozen_bit_counter;
|
||||
|
||||
protected:
|
Loading…
Reference in a new issue