core/systemd to 248-1

This commit is contained in:
Kevin Mihelich 2021-04-01 20:23:39 +00:00
parent d2cbef3e2a
commit bfcc9d1904
4 changed files with 62 additions and 20 deletions

View file

@ -1,17 +1,21 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Tue, 6 Mar 2018 23:39:47 +0100
Subject: [PATCH] Use Arch Linux' device access groups
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
cdrom → optical
dialout → uucp
tape → storage
---
rules.d/50-udev-default.rules.in | 14 +++++++-------
sysusers.d/basic.conf.in | 6 +++---
sysusers.d/basic.conf.in | 6 +++---
2 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/rules.d/50-udev-default.rules.in b/rules.d/50-udev-default.rules.in
index 191f56f42..f81c4d0fc 100644
index edfa8bb107..35b8d4ba41 100644
--- a/rules.d/50-udev-default.rules.in
+++ b/rules.d/50-udev-default.rules.in
@@ -22,7 +22,7 @@ SUBSYSTEM=="tty", KERNEL=="sclp_line[0-9]*", GROUP="tty", MODE="0620"
@ -23,7 +27,7 @@ index 191f56f42..f81c4d0fc 100644
SUBSYSTEM=="mem", KERNEL=="mem|kmem|port", GROUP="kmem", MODE="0640"
@@ -57,13 +57,13 @@ KERNEL=="irlpt[0-9]*", GROUP="lp"
@@ -62,13 +62,13 @@ KERNEL=="irlpt[0-9]*", GROUP="lp"
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ENV{ID_USB_INTERFACES}=="*:0701??:*", GROUP="lp"
SUBSYSTEM=="block", GROUP="disk"
@ -44,10 +48,10 @@ index 191f56f42..f81c4d0fc 100644
KERNEL=="qft[0-9]*|nqft[0-9]*|zqft[0-9]*|nzqft[0-9]*|rawqft[0-9]*|nrawqft[0-9]*", GROUP="disk"
KERNEL=="loop-control", GROUP="disk", OPTIONS+="static_node=loop-control"
diff --git a/sysusers.d/basic.conf.in b/sysusers.d/basic.conf.in
index 8e358c02d..33e513a36 100644
index 4be0bd869e..cc3721b58a 100644
--- a/sysusers.d/basic.conf.in
+++ b/sysusers.d/basic.conf.in
@@ -24,14 +24,14 @@ g utmp - - -
@@ -24,15 +24,15 @@ g utmp - - -
# Hardware access groups
g audio - - -
@ -59,6 +63,7 @@ index 8e358c02d..33e513a36 100644
g lp - - -
+g optical - - -
g render - - -
g sgx - - -
-g tape - - -
+g storage - - -
+g uucp - - -

View file

@ -0,0 +1,23 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Mon, 29 Mar 2021 00:12:34 +0000
Subject: [PATCH] Disable SYSTEMD_URLIFY by default
Until https://github.com/gwsw/less/issues/140 is fixed.
---
src/shared/pretty-print.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/shared/pretty-print.c b/src/shared/pretty-print.c
index 0f02f32760..1d0f9901dd 100644
--- a/src/shared/pretty-print.c
+++ b/src/shared/pretty-print.c
@@ -28,7 +28,7 @@ bool urlify_enabled(void) {
if (val >= 0)
cached_urlify_enabled = val;
else
- cached_urlify_enabled = colors_enabled();
+ cached_urlify_enabled = 0;
}
return cached_urlify_enabled;

View file

@ -6,13 +6,13 @@
# - disable gold/LTO
# - removed makedepend on gnu-efi-libs, set -Dgnuefi=false for !aarch64
# - add 242-1 changes in systemd.install to fix systemd-timesyncd
# - upstream patch to fix building with newer gnu-efi-libs
pkgbase=systemd
pkgname=('systemd' 'systemd-libs' 'systemd-resolvconf' 'systemd-sysvcompat')
_tag='f948f652768a5279087e13961ebb87f345626e2e' # git rev-parse v${pkgver}
pkgver=247.4
pkgrel=2
_tag='e13126bd95857eb9344e030edbb4c603aab63884' # git rev-parse v${_tag_name}
_tag_name=248
pkgver="${_tag_name/-/}"
pkgrel=1
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
@ -20,15 +20,15 @@ makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
'libmicrohttpd' 'libxcrypt' 'libxslt' 'util-linux' 'linux-api-headers'
'python-lxml' 'quota-tools' 'shadow' 'git'
'meson' 'libseccomp' 'pcre2' 'audit' 'kexec-tools' 'libxkbcommon'
'bash-completion' 'p11-kit' 'systemd')
'bash-completion' 'p11-kit' 'systemd' 'libfido2')
makedepends_aarch64=('gnu-efi-libs')
options=('strip')
validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering <lennart@poettering.net>
'5C251B5FC54EB2F80F407AAAC54CA336CFEB557E') # Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>
source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
"git+https://github.com/systemd/systemd#tag=v${pkgver%.*}?signed"
"git+https://github.com/systemd/systemd#tag=v${_tag_name%.*}?signed"
'0001-Use-Arch-Linux-device-access-groups.patch'
'https://patch-diff.githubusercontent.com/raw/systemd/systemd-stable/pull/97.patch'
'0002-Disable-SYSTEMD_URLIFY-by-default.patch'
'initcpio-hook-udev'
'initcpio-install-systemd'
'initcpio-install-udev'
@ -48,10 +48,11 @@ source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
'30-systemd-update.hook')
sha512sums=('SKIP'
'SKIP'
'e38c7c422c82953f9c2476a5ab8009d614cbec839e4088bff5db7698ddc84e3d8ed64f32ed323f57b1913c5c9703546f794996cb415ed7cdda930b627962a3c4'
'882e486b6d88c8bafc50088845e41a49686e98981967f72ca1fb4ef07a01767400632f4b648fd31857d2a2a24a8fd65bcc2a8983284dd4fff2380732741d4c41'
'313f3d6cc3d88f718509007e029213a82d84b196afdadc6ef560580acf70ab480aaecd7622f51726cc1af7d7841c6ec5390f72890b055a54fc74722341395651'
'6c8d8b016d1ad56e0bb050782cb3974288ced78d954e540df9bd7de23e895a9967713261f874a859975b56a950615c4ce51ce9feef3b27b4fa3f9c271ce011c2'
'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
'8e76f8334b95ce7fee9190f4a1016b16109f3a75b68635fc227b2b4791cf8179ef09b532b66b4ed885ddf98ed76befed3106f3c3088f1819ed8cdf4c13e0805a'
'4ad9db3e7335ab8577eb3189b25478d407f569cc4ffaeae34ca3fc5a075ac5dd9cd4ca39194d0e8e56e1a4ead13fb960b850a79373d0df8b3d3e5db0c914a68b'
'a25b28af2e8c516c3a2eec4e64b8c7f70c21f974af4a955a4a9d45fd3e3ff0d2a98b4419fe425d47152d5acae77d64e69d8d014a7209524b75a81b0edb10bf3a'
'61032d29241b74a0f28446f8cf1be0e8ec46d0847a61dadb2a4f096e8686d5f57fe5c72bcf386003f6520bc4b5856c32d63bf3efe7eb0bc0deefc9f68159e648'
'c416e2121df83067376bcaacb58c05b01990f4614ad9de657d74b6da3efa441af251d13bf21e3f0f71ddcb4c9ea658b81da3d915667dc5c309c87ec32a1cb5a5'
@ -72,8 +73,6 @@ _backports=(
)
_reverts=(
# resolved: gracefully handle with packets with too large RR count
'fdfffdaf20a18a50c9a6d858359cf4af6d2f4c8b'
)
prepare() {
@ -95,7 +94,8 @@ prepare() {
# Replace cdrom/dialout/tape groups with optical/uucp/storage
patch -Np1 -i ../0001-Use-Arch-Linux-device-access-groups.patch
patch -Np1 -i ../97.patch
# https://github.com/gwsw/less/issues/140
patch -Np1 -i ../0002-Disable-SYSTEMD_URLIFY-by-default.patch
}
build() {
@ -135,9 +135,10 @@ build() {
-Ddbuspolicydir=/usr/share/dbus-1/system.d
-Ddefault-dnssec=no
-Ddefault-hierarchy=hybrid
-Ddefault-hierarchy=unified
-Ddefault-kill-user-processes=false
-Ddefault-locale=C
-Dlocalegen-path=/usr/bin/locale-gen
-Ddns-over-tls=openssl
-Dfallback-hostname='archlinux'
-Dnologin-path=/usr/bin/nologin
@ -173,7 +174,8 @@ package_systemd() {
'quota-tools: kernel-level quota management'
'systemd-sysvcompat: symlink package to provide sysvinit binaries'
'polkit: allow administration as unprivileged user'
'curl: machinectl pull-tar and pull-raw')
'curl: machinectl pull-tar and pull-raw'
'libfido2: unlocking LUKS2 volumes')
backup=(etc/pam.d/systemd-user
etc/systemd/coredump.conf
etc/systemd/homed.conf
@ -182,6 +184,7 @@ package_systemd() {
etc/systemd/journal-upload.conf
etc/systemd/logind.conf
etc/systemd/networkd.conf
etc/systemd/oomd.conf
etc/systemd/pstore.conf
etc/systemd/resolved.conf
etc/systemd/sleep.conf
@ -248,7 +251,7 @@ package_systemd() {
package_systemd-libs() {
pkgdesc='systemd client libraries'
depends=('glibc' 'libcap' 'libgcrypt' 'lz4' 'xz' 'zstd')
depends=('glibc' 'libcap' 'libgcrypt' 'libp11-kit' 'lz4' 'xz' 'zstd')
license=('LGPL2.1')
provides=('libsystemd' 'libsystemd.so' 'libudev.so')
conflicts=('libsystemd')

View file

@ -163,6 +163,17 @@ build() {
rescue.target \
emergency.target
# add libraries dlopen()ed by systemd and its tools
for LIB in fido2; do
for FILE in $(find /usr/lib/ -name "lib${LIB}.so*"); do
if [[ -L "${FILE}" ]]; then
add_symlink "${FILE}"
else
add_binary "${FILE}"
fi
done
done
add_symlink "/usr/lib/systemd/system/default.target" "initrd.target"
add_symlink "/usr/lib/systemd/system/ctrl-alt-del.target" "reboot.target"