diff --git a/extra/ghc/PKGBUILD b/extra/ghc/PKGBUILD
deleted file mode 100644
index 86427f026..000000000
--- a/extra/ghc/PKGBUILD
+++ /dev/null
@@ -1,161 +0,0 @@
-# $Id$
-# Maintainer: Thomas Dziedzic <gostrc@gmail.com>
-# Maintainer: Vesa Kaihlavirta <vesa@archlinux.org>
-# Special note for devs looking to upgrade this package:
-#   ghc places a unique hash for each library when it is built.
-#   Libraries depend on versions specified by those hashes.
-#   This implies that all libraries need to be rebuilt when ghc is rebuilt.
-
-# use the following command to print out packages that need to get rebuilt
-# grep -r ghc /var/abs/ | awk -F '/' '{ print $5; }' | sort -u
-
-# ALARM: Kevin Mihelich <kevin@archlinuxarm.org
-#        David Flemström <david.flemstrom@gmail.com>
-#  - Patch for vfp flags (add-vfp-flags.patch)
-#  - Patch to fix dynamic linking on ARM
-#  - build.mk: BuildFlavor change from perf to perf-llvm
-#  - Add LLVM as a dependency
-#  - Correct gcc path after bulding with distcc
-#  - Use -j2 for building (RAM constraints)
-
-noautobuild=1
-
-pkgname=ghc
-pkgver=7.10.1
-pkgrel=2
-pkgdesc='The Glasgow Haskell Compiler'
-arch=('i686' 'x86_64')
-url='http://www.haskell.org/ghc/'
-license=('custom')
-depends=('perl' 'gmp' 'gcc' 'libffi' 'llvm')
-makedepends=('ghc' 'perl' 'libxslt' 'docbook-xsl')
-# will hopefully be able to depend on python 3 in a future version
-# https://ghc.haskell.org/trac/ghc/ticket/9184
-# title: Allow the use of Python 3 when building GHC
-checkdepends=('python2')
-install='ghc.install'
-options=('staticlibs')
-provides=('haskell-array=0.5.1.0'
-          'haskell-base=4.8.0.0'
-          'haskell-binary=0.7.3.0'
-          'haskell-bin-package-db=0.0.0.0'
-          'haskell-bytestring=0.10.6.0'
-          'haskell-containers=0.5.6.2'
-          'haskell-deepseq=1.4.1.1'
-          'haskell-directory=1.2.2.0'
-          'haskell-filepath=1.4.0.0'
-          'haskell-ghc-prim=0.4.0.0'
-          'haskell-haskeline=0.7.2.1'
-          'haskell-hoopl=3.10.0.2'
-          'haskell-hpc=0.6.0.2'
-          'haskell-integer-gmp=1.0.0.0'
-          'haskell-pretty=1.1.2.0'
-          'haskell-process=1.2.3.0'
-          'haskell-template-haskell=2.10.0.0'
-          'haskell-terminfo=0.4.0.1'
-          'haskell-time=1.5.0.1'
-          'haskell-transformers=0.4.2.0'
-          'haskell-unix=2.7.1.0'
-          'haskell-xhtml=3000.2.1'
-          'haskell-cabal=1.22.2.0'
-          )
-replaces=('haskell-array'
-          'haskell-base'
-          'haskell-binary'
-          'haskell-bin-package-db'
-          'haskell-bytestring'
-          'haskell-containers'
-          'haskell-deepseq'
-          'haskell-directory'
-          'haskell-filepath'
-          'haskell-ghc-prim'
-          'haskell-haskeline'
-          'haskell-hoopl'
-          'haskell-hpc'
-          'haskell-integer-gmp'
-          'haskell-pretty'
-          'haskell-process'
-          'haskell-template-haskell'
-          'haskell-terminfo'
-          'haskell-time'
-          'haskell-transformers'
-          'haskell-unix'
-          'haskell-xhtml'
-          'haskell-cabal'
-         )
-source=("http://www.haskell.org/ghc/dist/${pkgver}/ghc-${pkgver}-src.tar.xz"
-        "http://www.haskell.org/ghc/dist/${pkgver}/ghc-${pkgver}-testsuite.tar.xz"
-        'build.mk'
-        'ghc'
-        'add-vfp-flags.patch'
-        'ghc-7.8.1-mk-config.mk.in-ARM-dynlinking.patch')
-md5sums=('f93ad0cdc9df4b0f2d4421debdecb54f'
-         '41db579e247655236c2e35e66e645e71'
-         'd9c7c61db2b7c0c7eef547092716addb'
-         'c1d46d86752c50dd85e7143b029fa07f'
-         '1eb0ed10fa9676c2e23a587c40166e0e'
-         '041b801ef32c45c7c9fd8d7730e79cc8')
-
-build() {
-  cd ghc-${pkgver}
-
-  cp ${srcdir}/build.mk mk/build.mk
-
-  patch -p1 -i ../add-vfp-flags.patch
-  patch -p1 -Ri ../ghc-7.8.1-mk-config.mk.in-ARM-dynlinking.patch
-  MAKEFLAGS="-j2"
-
-  # have to 're-boot' because the patch changes configure stuff
-  ./boot
-
-  ./configure \
-    --prefix=/usr \
-    --with-system-libffi \
-    --with-ffi-includes=/usr/lib/libffi-3.2.1/include
-
-  make
-}
-
-check() {
-  # keep this otherwise a lot of tests will show as unexpected failures... need to investigate why using -jn for n > 1 does this...
-  unset MAKEFLAGS
-
-  cd ghc-${pkgver}
-
-  # python2 rename
-  sed -e 's_#!/usr/bin/env python_&2_' -i testsuite/timeout/calibrate testsuite/timeout/timeout.py
-
-  # tests check out for 7.10.1 on x86_64 but are broken on i686
-  #make test
-
-  # enabling threads to speed up
-  # causes more failures than make test, need to investigate
-  # upstream known failures on both i686 and x86_64:
-  #    perf/compiler             parsing001 [stat not good enough] (normal)
-  #    simplCore/should_compile  spec-inline [stderr mismatch] (optasm)
-  # upstream known failures on i686 only:
-  #    numrun012 test fails on i686 works on x86_64 - http://hackage.haskell.org/trac/ghc/ticket/5856
-  #make THREADS=9 test
-
-  # will most likely cause lots of failures
-  # enable this when upstream has 0 test failures from a simple 'make test'
-  # zero unexpected failures on all tier 1 platforms - http://hackage.haskell.org/trac/ghc/ticket/5757
-  #make fulltest
-}
-
-package() {
-  cd ghc-${pkgver}
-
-  make DESTDIR=${pkgdir} install
-
-  install -d ${pkgdir}/usr/share/licenses/ghc
-  install -m644 LICENSE \
-    ${pkgdir}/usr/share/licenses/ghc
-
-  sed -r 's|("C compiler command", ")[^"]+|\1/usr/bin/gcc|' \
-    -i "${pkgdir}/usr/lib/ghc-${pkgver}/settings"
-
-  install -d ${pkgdir}/usr/share/bash-completion/completions
-  install -m644 ./utils/completion/ghc.bash \
-    ${pkgdir}/usr/share/bash-completion/completions/ghc
-}
diff --git a/extra/ghc/add-vfp-flags.patch b/extra/ghc/add-vfp-flags.patch
deleted file mode 100644
index 795549de3..000000000
--- a/extra/ghc/add-vfp-flags.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN a/aclocal.m4 b/aclocal.m4
---- a/aclocal.m4	2014-04-07 12:26:08.000000000 -0600
-+++ b/aclocal.m4	2014-05-04 08:43:23.399271800 -0600
-@@ -408,7 +408,7 @@
-                 )],
-                 [changequote(, )dnl
-                  ARM_ISA=ARMv7
--                 ARM_ISA_EXT="[VFPv3,NEON]"
-+                 ARM_ISA_EXT="[VFPv3D16]"
-                  changequote([, ])dnl
-                 ])
-         ])
diff --git a/extra/ghc/build.mk b/extra/ghc/build.mk
deleted file mode 100644
index d935386f5..000000000
--- a/extra/ghc/build.mk
+++ /dev/null
@@ -1,291 +0,0 @@
-# -----------------------------------------------------------------------------
-# A Sample build.mk
-#
-# Uncomment one of the following BuildFlavour settings to get the desired
-# overall build type, and then tweak the options in the relevant section
-# below.
-
-# -------- Build profiles -----------------------------------------------------
-# Uncomment one of these to select a build profile below:
-
-# Full build with max optimisation and everything enabled (very slow build)
-#BuildFlavour = perf
-
-# As above but build GHC using the LLVM backend
-BuildFlavour = perf-llvm
-
-# Perf build configured for a cross-compiler
-#BuildFlavour = perf-cross
-
-# Fast build with optimised libraries, no profiling (RECOMMENDED):
-#BuildFlavour = quick
-
-# Fast build with optimised libraries, no profiling, with LLVM:
-#BuildFlavour = quick-llvm
-
-# Fast build configured for a cross compiler
-#BuildFlavour  = quick-cross
-
-# Even faster build.  NOT RECOMMENDED: the libraries will be
-# completely unoptimised, so any code built with this compiler
-# (including stage2) will run very slowly:
-#BuildFlavour = quickest
-
-# Profile the stage2 compiler:
-#BuildFlavour = prof
-
-# A development build, working on the stage 1 compiler:
-#BuildFlavour = devel1
-
-# A development build, working on the stage 2 compiler:
-#BuildFlavour = devel2
-
-# A build with max optimisation that still builds the stage2 compiler
-# quickly. Compiled code will be the same as with "perf". Programs
-# will compile more slowly.
-#BuildFlavour = bench
-
-# As above but build GHC using the LLVM backend
-#BuildFlavour = bench-llvm
-
-# Bench build configured for a cross-compiler
-#BuildFlavour = bench-cross
-
-# -------- Miscellaneous variables --------------------------------------------
-
-# Set to V = 0 to get prettier build output.
-# Please use V = 1 when reporting GHC bugs.
-V = 1
-
-# After stage 1 and the libraries have been built, you can uncomment this line:
-
-#stage=2
-
-# Then stage 1 will not be touched by the build system, until
-# you comment the line again.  This is a useful trick for when you're
-# working on stage 2 and want to freeze stage 1 and the libraries for
-# a while.
-
-# Uncomment the following line to enable building DPH
-#BUILD_DPH=YES
-
-GhcLibWays = $(if $(filter $(DYNAMIC_GHC_PROGRAMS),YES),v dyn,v)
-
-# Only use -fasm by default on platforms that support it.
-GhcFAsm = $(if $(filter $(GhcWithNativeCodeGen),YES),-fasm,)
-
-# ----------- A Performance/Distribution build --------------------------------
-
-ifeq "$(BuildFlavour)" "perf"
-
-# perf matches the default settings, repeated here for comparison:
-
-SRC_HC_OPTS     = -O -H64m
-GhcStage1HcOpts = -O $(GhcFAsm)
-GhcStage2HcOpts = -O2 $(GhcFAsm)
-GhcHcOpts       = -Rghc-timing
-GhcLibHcOpts    = -O2
-GhcLibWays     += p
-
-ifeq "$(PlatformSupportsSharedLibs)" "YES"
-GhcLibWays += dyn
-endif
-
-endif
-
-# ---------------- Perf build using LLVM --------------------------------------
-
-ifeq "$(BuildFlavour)" "perf-llvm"
-
-SRC_HC_OPTS     = -O -H64m -fllvm -optc-mlong-calls
-GhcStage1HcOpts = -O -fllvm
-GhcStage2HcOpts = -O2 -fllvm
-GhcHcOpts       = -Rghc-timing
-GhcLibHcOpts    = -O2
-GhcLibWays     += p
-
-endif
-
-# -------- A Fast build -------------------------------------------------------
-
-ifeq "$(BuildFlavour)" "quickest"
-
-SRC_HC_OPTS        = -H64m -O0 $(GhcFAsm)
-GhcStage1HcOpts    = -O $(GhcFAsm)
-GhcStage2HcOpts    = -O0 $(GhcFAsm)
-GhcLibHcOpts       = -O0 $(GhcFAsm)
-SplitObjs          = NO
-HADDOCK_DOCS       = NO
-BUILD_DOCBOOK_HTML = NO
-BUILD_DOCBOOK_PS   = NO
-BUILD_DOCBOOK_PDF  = NO
-
-endif
-
-# -------- A Fast build with optimised libs -----------------------------------
-
-ifeq "$(BuildFlavour)" "quick"
-
-SRC_HC_OPTS        = -H64m -O0 $(GhcFAsm)
-GhcStage1HcOpts    = -O $(GhcFAsm)
-GhcStage2HcOpts    = -O0 $(GhcFAsm)
-GhcLibHcOpts       = -O $(GhcFAsm)
-SplitObjs          = NO
-HADDOCK_DOCS       = NO
-BUILD_DOCBOOK_HTML = NO
-BUILD_DOCBOOK_PS   = NO
-BUILD_DOCBOOK_PDF  = NO
-
-endif
-
-# -------- A Fast build with optimised libs using LLVM ------------------------
-
-ifeq "$(BuildFlavour)" "quick-llvm"
-
-SRC_HC_OPTS        = -H64m -O0 -fllvm
-GhcStage1HcOpts    = -O -fllvm
-GhcStage2HcOpts    = -O0 -fllvm
-GhcLibHcOpts       = -O -fllvm
-SplitObjs          = NO
-HADDOCK_DOCS       = NO
-BUILD_DOCBOOK_HTML = NO
-BUILD_DOCBOOK_PS   = NO
-BUILD_DOCBOOK_PDF  = NO
-
-endif
-
-# -------- A Fast build configured for cross-compilation ----------------------
-
-ifeq "$(BuildFlavour)" "quick-cross"
-
-SRC_HC_OPTS        = -H64m -O0
-GhcStage1HcOpts    = -O
-GhcStage2HcOpts    = -O0 -fllvm
-GhcLibHcOpts       = -O -fllvm
-SplitObjs          = NO
-HADDOCK_DOCS       = NO
-BUILD_DOCBOOK_HTML = NO
-BUILD_DOCBOOK_PS   = NO
-BUILD_DOCBOOK_PDF  = NO
-INTEGER_LIBRARY    = integer-simple
-Stage1Only         = YES
-
-DYNAMIC_BY_DEFAULT   = NO
-DYNAMIC_GHC_PROGRAMS = NO
-
-endif
-
-# -------- Profile the stage2 compiler ----------------------------------------
-
-ifeq "$(BuildFlavour)" "prof"
-
-SRC_HC_OPTS        = -H64m -O0 $(GhcFAsm)
-GhcStage1HcOpts    = -O $(GhcFAsm)
-GhcStage2HcOpts    = -O $(GhcFAsm)
-GhcLibHcOpts       = -O $(GhcFAsm)
-
-GhcLibWays         += p
-GhcProfiled        = YES
-
-SplitObjs          = NO
-HADDOCK_DOCS       = NO
-BUILD_DOCBOOK_HTML = NO
-BUILD_DOCBOOK_PS   = NO
-BUILD_DOCBOOK_PDF  = NO
-
-endif
-
-# -------- A Development build (stage 1) --------------------------------------
-
-ifeq "$(BuildFlavour)" "devel1"
-
-SRC_HC_OPTS        = -H64m -O $(GhcFAsm)
-GhcLibHcOpts       = -O -dcore-lint
-GhcStage1HcOpts    = -Rghc-timing -O0 -DDEBUG
-GhcStage2HcOpts    = -Rghc-timing -O $(GhcFAsm)
-SplitObjs          = NO
-HADDOCK_DOCS       = NO
-BUILD_DOCBOOK_HTML = NO
-BUILD_DOCBOOK_PS   = NO
-BUILD_DOCBOOK_PDF  = NO
-LAX_DEPENDENCIES   = YES
-
-endif
-
-# -------- A Development build (stage 2) --------------------------------------
-
-ifeq "$(BuildFlavour)" "devel2"
-
-SRC_HC_OPTS        = -H64m -O $(GhcFAsm)
-GhcLibHcOpts       = -O -dcore-lint
-GhcStage1HcOpts    = -Rghc-timing -O $(GhcFAsm)
-GhcStage2HcOpts    = -Rghc-timing -O0 -DDEBUG
-SplitObjs          = NO
-HADDOCK_DOCS       = NO
-BUILD_DOCBOOK_HTML = NO
-BUILD_DOCBOOK_PS   = NO
-BUILD_DOCBOOK_PDF  = NO
-LAX_DEPENDENCIES   = YES
-
-endif
-
-# -------- A bench build with optimised libs -----------------------------------
-
-ifeq "$(BuildFlavour)" "bench"
-
-SRC_HC_OPTS        = -O -H64m
-GhcStage1HcOpts    = -O $(GhcFAsm)
-GhcStage2HcOpts    = -O0 $(GhcFAsm)
-GhcLibHcOpts       = -O2 $(GhcFAsm)
-SplitObjs          = NO
-HADDOCK_DOCS       = NO
-BUILD_DOCBOOK_HTML = NO
-BUILD_DOCBOOK_PS   = NO
-BUILD_DOCBOOK_PDF  = NO
-
-endif
-
-# ---------------- Bench build using LLVM --------------------------------------
-
-ifeq "$(BuildFlavour)" "bench-llvm"
-
-SRC_HC_OPTS        = -O -H64m
-GhcStage1HcOpts    = -O -fllvm
-GhcStage2HcOpts    = -O0 -fllvm
-GhcLibHcOpts       = -O2 -fllvm
-SplitObjs          = NO
-HADDOCK_DOCS       = NO
-BUILD_DOCBOOK_HTML = NO
-BUILD_DOCBOOK_PS   = NO
-BUILD_DOCBOOK_PDF  = NO
-
-endif
-
-# ------- A Bench build configured for cross-compilation ----------------------
-
-ifeq "$(BuildFlavour)" "bench-cross"
-
-SRC_HC_OPTS        = -O -H64m
-GhcStage1HcOpts    = -O $(GhcFAsm)
-GhcStage2HcOpts    = -O0 $(GhcFAsm)
-GhcLibHcOpts       = -O2 $(GhcFAsm)
-SplitObjs          = NO
-INTEGER_LIBRARY    = integer-simple
-Stage1Only         = YES
-HADDOCK_DOCS       = NO
-BUILD_DOCBOOK_HTML = NO
-BUILD_DOCBOOK_PS   = NO
-BUILD_DOCBOOK_PDF  = NO
-
-DYNAMIC_BY_DEFAULT   = NO
-DYNAMIC_GHC_PROGRAMS = NO
-
-endif
-
-# -----------------------------------------------------------------------------
-# Other settings that might be useful
-
-# NoFib settings
-NoFibWays =
-STRIP_CMD = :
-
diff --git a/extra/ghc/ghc b/extra/ghc/ghc
deleted file mode 100644
index 5e1e189c5..000000000
--- a/extra/ghc/ghc
+++ /dev/null
@@ -1,10 +0,0 @@
-_ghc()
-{
-    local envs=`ghc --show-options`
-    # get the word currently being completed
-   local cur=${COMP_WORDS[$COMP_CWORD]}
-
-    # the resulting completions should be put into this array
-    COMPREPLY=( $( compgen -W "$envs" -- $cur ) )
-}
-complete -F _ghc -o default ghc
diff --git a/extra/ghc/ghc-7.8.1-mk-config.mk.in-ARM-dynlinking.patch b/extra/ghc/ghc-7.8.1-mk-config.mk.in-ARM-dynlinking.patch
deleted file mode 100644
index f9b786ed7..000000000
--- a/extra/ghc/ghc-7.8.1-mk-config.mk.in-ARM-dynlinking.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-commit abb86adf7f749b3d44887d28bc96b43c5a1e0631
-Author: Ben Gamari <bgamari.foss@gmail.com>
-Date:   Thu Mar 6 21:22:28 2014 +0100
-
-    config.mk.in: ARM now supports dynamic linking with the LLVM backend
-    
-    Signed-off-by: Austin Seipp <austin@well-typed.com>
-    (cherry picked from commit d574fcbba09fd6c9d10a79e19daf5f15bb0a6cde)
-
-	Modified   mk/config.mk.in
-diff --git a/mk/config.mk.in b/mk/config.mk.in
-index 2c997de..fef1fb8 100644
---- a/mk/config.mk.in
-+++ b/mk/config.mk.in
-@@ -95,8 +95,7 @@ TargetElf = YES
- endif
- 
- # Some platforms don't support shared libraries
--NoSharedLibsPlatformList = arm-unknown-linux \
--	powerpc-unknown-linux \
-+NoSharedLibsPlatformList = powerpc-unknown-linux \
- 	x86_64-unknown-mingw32 \
- 	i386-unknown-mingw32 \
- 	sparc-sun-solaris2 \
diff --git a/extra/ghc/ghc.install b/extra/ghc/ghc.install
deleted file mode 100644
index 2ccdbdef3..000000000
--- a/extra/ghc/ghc.install
+++ /dev/null
@@ -1,10 +0,0 @@
-pre_upgrade() {
-  echo '==> Unregistering cabalized packages...'
-  [[ -d /usr/share/haskell ]] && find /usr/share/haskell -maxdepth 2 -name 'unregister.sh' -exec {} \;
-  echo '==> Done.'
-}
-
-post_upgrade() {
-  echo '==> All cabalized packages need to be reinstalled now.'
-  echo '==> See /usr/share/haskell/ for a tentative list of affected packages.'
-}
diff --git a/extra/ghc/print-provides-replaces.sh b/extra/ghc/print-provides-replaces.sh
deleted file mode 100755
index 00fe4b35b..000000000
--- a/extra/ghc/print-provides-replaces.sh
+++ /dev/null
@@ -1,47 +0,0 @@
-#!/bin/bash
-
-. PKGBUILD
-
-if [[ ! -d src/ghc-${pkgver}/libraries ]]; then
-  echo "error: no directory src/ghc-${pkgver}/libraries: You must extract the source tarball under src/"
-  exit 1
-fi
-
-declare -A exclude
-# no Win32 cause we're not building on windows
-exclude['Win32']=1
-# no integer-simple because we use integer-gmp
-exclude['integer-simple']=1
-# integer-gmp was replaced with integer-gmp2
-exclude['integer-gmp']=1
-# extract excluded libraries from ghc.mk
-for exclude_pkg in $(sed 's/PKGS_THAT_ARE_INTREE_ONLY := //p' -n src/ghc-${pkgver}/ghc.mk); do
-  exclude[${exclude_pkg}]=1
-done
-
-cd src/ghc-${pkgver}/libraries
-
-# $1 is the name of the variable
-# $2 is the string for the test, either '=' or '<'
-print_var() {
-  printf "$1=("
-  for path in $(ls ./*/*.cabal); do
-    dirname=$(echo $path | awk -F '/' '{ print $2 }')
-    cabalfile=$(echo $path | awk -F '/' '{ print $3 }')
-    cabalname=$(basename $cabalfile .cabal)
-    [[ ${exclude[${dirname}]} ]] && continue
-    version=$(awk 'tolower($0) ~ /^version:/ {print $2 }' $path)
-    printf "'haskell-$cabalname"
-    [[ -n "$2" ]] && printf "$2$version"
-    printf "'\n          "
-  done
-  # also add cabal
-  version=$(awk 'tolower($0) ~ /^version:/ { print $2 }' Cabal/Cabal/Cabal.cabal)
-  printf "'haskell-cabal"
-  [[ -n "$2" ]] && printf "$2$version"
-  printf "'\n          "
-  echo -e '\b)'
-}
-
-print_var 'provides' '='
-print_var 'replaces'