diff --git a/community/rust/PKGBUILD b/community/rust/PKGBUILD
index 8885b2ba7..fa1e71789 100644
--- a/community/rust/PKGBUILD
+++ b/community/rust/PKGBUILD
@@ -14,31 +14,28 @@ highmem=1
 pkgname=('rust' 'rust-docs')
 epoch=1
 pkgver=1.21.0
-pkgrel=1
+pkgrel=2
 
 pkgdesc='Systems programming language focused on safety, speed and concurrency'
 url='https://www.rust-lang.org/'
 arch=('x86_64' 'i686')
 license=('MIT' 'Apache')
 
-makedepends=('rust' 'libffi' 'perl' 'python2' 'curl' 'llvm' 'cmake')
+makedepends=('rust' 'libffi' 'perl' 'python2' 'curl' 'cmake')
 
 options=('!emptydirs')
 
 source=("https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz"{,.asc}
-        0001-librustc_llvm-build-Force-link-against-libffi.patch
         bootstrap-config.toml)
 
 sha256sums=('1707c142244b5bd909993559c6116c81987c1de21d6207c05d3ecbe5bba548fa'
             'SKIP'
-            '563529da8e02f575ddde7247d5fc5350d74031daa54743b86d075f3c45ae2713'
-            '4252d4873a840216115ee306e4d689819bc791ee05bedd1faa0b00c49ff91c62')
+            '6c25c451d6286efd19e96a552406c8b299345749577cf924699cf4c3831d9ad0')
 validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
 
 prepare() {
   cd "rustc-$pkgver-src"
 
-  patch -p1 <"$srcdir"/0001-librustc_llvm-build-Force-link-against-libffi.patch
   cp "$srcdir"/bootstrap-config.toml config.toml
 
   if [[ $CARCH == armv7h ]]; then
diff --git a/community/rust/bootstrap-config.toml b/community/rust/bootstrap-config.toml
index c721bd81a..897bb3486 100644
--- a/community/rust/bootstrap-config.toml
+++ b/community/rust/bootstrap-config.toml
@@ -19,9 +19,3 @@ debuginfo = true
 #debuginfo-lines = false
 
 channel = "stable"
-
-[target.x86_64-unknown-linux-gnu]
-llvm-config = "/usr/bin/llvm-config"
-
-[target.i686-unknown-linux-gnu]
-llvm-config = "/usr/bin/llvm-config"