Added libwebkit, which still does not build

This commit is contained in:
Mike Staszel 2011-01-30 21:59:57 -06:00
parent aa52afc134
commit c0402777a7
2 changed files with 66 additions and 0 deletions

44
extra/libwebkit/PKGBUILD Normal file
View file

@ -0,0 +1,44 @@
# $Id: PKGBUILD 104228 2010-12-30 22:22:42Z ibiru $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# Plugbox changes: None, but this package has to be built by running:
# CPPFLAGS="-I/usr/include/cairo -I/usr/include/freetype2 \
# -I/usr/include/gtk-2.0 -I/usr/include/pango-1.0 -I/usr/lib/gtk-2.0/include \
# -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/atk-1.0 \
# -I/usr/include/gail-1.0" makepkg --asroot -Acs
pkgname=libwebkit
pkgver=1.2.6
pkgrel=1
pkgdesc="an opensource web content engine, derived from KHTML and KJS from KDE"
arch=('i686' 'x86_64')
url="http://webkitgtk.org/"
license=('custom')
depends=('libxt' 'libxslt' 'sqlite3' 'gtk2' 'icu>=4.6' 'gstreamer0.10-base' 'libsoup' 'enchant')
makedepends=('gperf' 'gtk-doc' 'gobject-introspection')
provides=('webkitgtk-svn')
conflicts=('webkitgtk-svn')
replaces=('webkitgtk-svn')
options=('!libtool')
source=(http://webkitgtk.org/webkit-${pkgver}.tar.gz
introspection.patch)
md5sums=('7afb510040b2a49c65514a06bb8200fc'
'e7e83312618cb30cc9a1567a21cd0e06')
build() {
cd "${srcdir}/webkit-${pkgver}"
patch -Np0 -i "${srcdir}/introspection.patch"
./configure --prefix=/usr \
--enable-video --enable-introspection \
--with-font-backend=freetype --enable-gtk-doc \
--enable-jit --with-unicode-backend=icu
#disable makeflags if parallel building fails
make ${MAKEFLAGS}
}
package() {
cd "${srcdir}/webkit-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm644 WebKit/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}

View file

@ -0,0 +1,22 @@
--- WebKit/gtk/JSCore-1.0.gir 2010-09-29 14:54:07.000000000 +0200
+++ WebKit/gtk/JSCore-1.0.gir 2010-09-29 15:57:06.000000000 +0200
@@ -1,12 +1,14 @@
<?xml version="1.0"?>
-<repository version="1.0"
+<repository version="1.2"
xmlns="http://www.gtk.org/introspection/core/1.0"
xmlns:c="http://www.gtk.org/introspection/c/1.0">
<namespace name="JSCore" version="1.0" shared-library="webkit-1.0">
- <alias name="GlobalContextRef"
- target="none"
- c:type="JSGlobalContextRef"/>
- <alias name="ObjectRef" target="none" c:type="JSObjectRef"/>
+ <alias name="GlobalContextRef" target="none">
+ <type name="JSGlobalContextRef" c:type="JSGlobalContextRef"/>
+ </alias>
+ <alias name="ObjectRef" target="none">
+ <type name="JSObjectRef" c:type="JSObjectRef"/>
+ </alias>
<function name="EvaluateScript" c:identifier="JSEvaluateScript">
<return-value transfer-ownership="none">
<type name="none" c:type="void"/>