mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
added extra/mplayer
This commit is contained in:
parent
4f692cd3d2
commit
c0410a626e
5 changed files with 127 additions and 0 deletions
82
extra/mplayer/PKGBUILD
Normal file
82
extra/mplayer/PKGBUILD
Normal file
|
@ -0,0 +1,82 @@
|
|||
# $Id: PKGBUILD 152229 2012-03-05 09:55:27Z ibiru $
|
||||
# Maintainer : Ionut Biru <ibiru@archlinux.org>
|
||||
# Contributor: Hugo Doria <hugo@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org
|
||||
# - remove --enable-runtime-cpudetection from configure
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgbase=mplayer
|
||||
pkgname=('mplayer' 'mencoder')
|
||||
pkgver=34799
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
makedepends=('libxxf86dga' 'libxxf86vm' 'libmad' 'cdparanoia' 'libxinerama' 'sdl' 'lame' 'libtheora' 'xvidcore' 'libmng' 'libxss' 'libgl' 'smbclient'
|
||||
'aalib' 'jack' 'libcaca' 'x264' 'faac' 'faad2' 'lirc-utils' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr' 'libdca' 'a52dec' 'schroedinger' 'libvpx'
|
||||
'libpulse' 'fribidi' 'unzip' 'mesa' 'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass' 'libbluray' 'libcdio')
|
||||
license=('GPL')
|
||||
url="http://www.mplayerhq.hu/"
|
||||
options=(!buildflags !emptydirs)
|
||||
source=(ftp://ftp.archlinux.org/other/$pkgbase/$pkgbase-$pkgver.tar.xz mplayer.desktop
|
||||
live-media.patch)
|
||||
md5sums=('e8bd960bcdb48fdc5a1f45390dc13c53'
|
||||
'c0d6ef795cf6de48e3b87ff7c23f0319'
|
||||
'b6c057633ff7001ee0c102b5f81ec1e3')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgbase"
|
||||
|
||||
patch -Np0 -i "$srcdir/live-media.patch"
|
||||
|
||||
./configure --prefix=/usr \
|
||||
--disable-gui \
|
||||
--disable-arts \
|
||||
--disable-liblzo \
|
||||
--disable-speex \
|
||||
--disable-openal \
|
||||
--disable-libdv \
|
||||
--disable-musepack \
|
||||
--disable-esd \
|
||||
--disable-mga \
|
||||
--disable-ass-internal \
|
||||
--disable-cdparanoia \
|
||||
--enable-xvmc \
|
||||
--enable-radio \
|
||||
--enable-radio-capture \
|
||||
--language=all \
|
||||
--confdir=/etc/mplayer
|
||||
[ "$CARCH" = "i686" ] && sed 's|-march=i486|-march=i686|g' -i config.mak
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package_mplayer() {
|
||||
pkgdesc="A movie player for linux"
|
||||
install=mplayer.install
|
||||
backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
|
||||
depends=('desktop-file-utils' 'ttf-dejavu' 'enca' 'libxss' 'a52dec' 'libvpx' 'lirc-utils' 'x264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig' 'libgl'
|
||||
'libxinerama' 'libvdpau' 'libpulse' 'smbclient' 'xvidcore' 'opencore-amr' 'jack' 'cdparanoia' 'libmad' 'sdl' 'libtheora' 'libcaca' 'libxxf86dga' 'fribidi'
|
||||
'libjpeg' 'faac' 'faad2' 'libxvmc' 'schroedinger' 'mpg123' 'libass' 'libxxf86vm' 'libbluray' 'libcdio')
|
||||
|
||||
cd "$srcdir/$pkgbase"
|
||||
|
||||
make DESTDIR="$pkgdir" install-mplayer install-mplayer-man
|
||||
install -Dm644 etc/{codecs.conf,input.conf,example.conf} "$pkgdir/etc/mplayer/"
|
||||
install -dm755 "$pkgdir/usr/share/mplayer/"
|
||||
ln -s /usr/share/fonts/TTF/DejaVuSans.ttf "$pkgdir/usr/share/mplayer/subfont.ttf"
|
||||
rm -rf "$pkgdir/usr/share/mplayer/font"
|
||||
#desktop file FS#14770
|
||||
install -Dm644 "$srcdir/mplayer.desktop" "$pkgdir/usr/share/applications/mplayer.desktop"
|
||||
install -Dm644 etc/mplayer256x256.png "$pkgdir/usr/share/pixmaps/mplayer.png"
|
||||
}
|
||||
|
||||
package_mencoder() {
|
||||
pkgdesc="Free command line video decoding, encoding and filtering tool"
|
||||
depends=('enca' 'a52dec' 'libvpx' 'x264' 'libmng' 'libdca' 'bzip2' 'lame' 'alsa-lib' 'fontconfig' 'giflib' 'libpng' 'smbclient' 'xvidcore' 'opencore-amr' 'cdparanoia'
|
||||
'libmad' 'libtheora' 'fribidi' 'libjpeg' 'faac' 'faad2' 'schroedinger' 'mpg123' 'libass' 'libbluray' 'libcdio')
|
||||
|
||||
cd "$srcdir/$pkgbase"
|
||||
make DESTDIR="$pkgdir" install-mencoder install-mencoder-man
|
||||
find "$pkgdir/usr/share/man" -name 'mplayer.1' -exec bash -c 'mv "$1" "${1/mplayer/mencoder}"' _ {} \;
|
||||
}
|
13
extra/mplayer/live-media.patch
Normal file
13
extra/mplayer/live-media.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
Index: libmpdemux/demux_rtp.cpp
|
||||
===================================================================
|
||||
--- libmpdemux/demux_rtp.cpp (revision 34798)
|
||||
+++ libmpdemux/demux_rtp.cpp (working copy)
|
||||
@@ -19,6 +19,8 @@
|
||||
* 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
|
||||
*/
|
||||
|
||||
+#define RTSPCLIENT_SYNCHRONOUS_INTERFACE 1
|
||||
+
|
||||
extern "C" {
|
||||
// on MinGW, we must include windows.h before the things it conflicts
|
||||
#ifdef __MINGW32__ // with. they are each protected from
|
21
extra/mplayer/mplayer.desktop
Normal file
21
extra/mplayer/mplayer.desktop
Normal file
|
@ -0,0 +1,21 @@
|
|||
[Desktop Entry]
|
||||
Type=Application
|
||||
Name=MPlayer Media Player
|
||||
Name[ca]=Reproductor multimèdia MPlayer
|
||||
Name[pl]=MPlayer odtwarzacz multimedialny
|
||||
GenericName=Multimedia player
|
||||
Comment=Play movies and songs
|
||||
Comment[ca]=Reproduïu vídeos i cançons
|
||||
Comment[de]=Filme und Musik abspielen
|
||||
Comment[es]=Reproduzca vídeos y canciones
|
||||
Comment[fr]=Lecteur multimédia
|
||||
Comment[it]=Lettore multimediale
|
||||
Comment[zh]=多媒体播放器
|
||||
Comment[pl]=Odtwarzaj filmy i muzykę
|
||||
Icon=mplayer
|
||||
TryExec=mplayer
|
||||
Exec=mplayer %F
|
||||
Terminal=false
|
||||
NoDisplay=true
|
||||
Categories=GTK;AudioVideo;Audio;Video;Player;TV;
|
||||
MimeType=application/ogg;application/x-ogg;application/sdp;application/smil;application/x-smil;application/streamingmedia;application/x-streamingmedia;application/vnd.rn-realmedia;application/vnd.rn-realmedia-vbr;audio/aac;audio/x-aac;audio/m4a;audio/x-m4a;audio/mp1;audio/x-mp1;audio/mp2;audio/x-mp2;audio/mp3;audio/x-mp3;audio/mpeg;audio/x-mpeg;audio/mpegurl;audio/x-mpegurl;audio/mpg;audio/x-mpg;audio/rn-mpeg;audio/scpls;audio/x-scpls;audio/vnd.rn-realaudio;audio/wav;audio/x-pn-windows-pcm;audio/x-realaudio;audio/x-pn-realaudio;audio/x-ms-wma;audio/x-pls;audio/x-wav;video/mpeg;video/x-mpeg;video/x-mpeg2;video/mp4;video/msvideo;video/x-msvideo;video/quicktime;video/vnd.rn-realvideo;video/x-ms-afs;video/x-ms-asf;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvxvideo;video/x-avi;video/x-fli;video/x-flv;video/x-theora;video/x-matroska;
|
11
extra/mplayer/mplayer.install
Normal file
11
extra/mplayer/mplayer.install
Normal file
|
@ -0,0 +1,11 @@
|
|||
post_install() {
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
BIN
extra/mplayer/mplayer.png
Normal file
BIN
extra/mplayer/mplayer.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 1.9 KiB |
Loading…
Reference in a new issue