mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
alarm/uboot-pandaboard to 2015.10-1
This commit is contained in:
parent
2b5b9416d7
commit
c0b00a50a4
2 changed files with 19 additions and 31 deletions
|
@ -1,15 +1,15 @@
|
|||
From 80bcddf384ff200c677d47926f9159f7a555bd44 Mon Sep 17 00:00:00 2001
|
||||
From 2d409f8b850b526091cc35889de9509dba32e362 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 22 Nov 2014 22:55:40 -0700
|
||||
Subject: [PATCH] arch linux arm modifications
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
include/configs/ti_omap4_common.h | 95 +++++++++++++++++++++------------------
|
||||
1 file changed, 52 insertions(+), 43 deletions(-)
|
||||
include/configs/ti_omap4_common.h | 87 ++++++++++++++++++++++-----------------
|
||||
1 file changed, 49 insertions(+), 38 deletions(-)
|
||||
|
||||
diff --git a/include/configs/ti_omap4_common.h b/include/configs/ti_omap4_common.h
|
||||
index 1c93aab..e8b6c90 100644
|
||||
index 1cd7dae..12c5f69 100644
|
||||
--- a/include/configs/ti_omap4_common.h
|
||||
+++ b/include/configs/ti_omap4_common.h
|
||||
@@ -46,7 +46,6 @@
|
||||
|
@ -20,40 +20,25 @@ index 1c93aab..e8b6c90 100644
|
|||
#ifndef CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS
|
||||
#define CONFIG_SYS_AUTOMATIC_SDRAM_DETECTION
|
||||
#define CONFIG_SYS_DEFAULT_LPDDR2_TIMINGS
|
||||
@@ -82,6 +81,12 @@
|
||||
#undef CONFIG_CMD_NET
|
||||
#undef CONFIG_CMD_NFS
|
||||
@@ -78,6 +77,9 @@
|
||||
#define CONFIG_USB_TTY 1
|
||||
#define CONFIG_SYS_CONSOLE_IS_IN_ENV 1
|
||||
|
||||
+/* Arch Linux ARM extras */
|
||||
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
|
||||
+#define CONFIG_SUPPORT_RAW_INITRD
|
||||
+#define CONFIG_CMD_PART
|
||||
+#define CONFIG_PARTITION_UUIDS
|
||||
+
|
||||
/*
|
||||
* Environment setup
|
||||
*/
|
||||
@@ -89,32 +94,57 @@
|
||||
DEFAULT_LINUX_BOOT_ENV \
|
||||
"console=ttyO2,115200n8\0" \
|
||||
@@ -88,23 +90,53 @@
|
||||
"fdtfile=undefined\0" \
|
||||
- "bootpart=0:2\0" \
|
||||
+ "bootpart=0:1\0" \
|
||||
"bootpart=0:2\0" \
|
||||
"bootdir=/boot\0" \
|
||||
+ "fdtdir=/boot/dtbs\0" \
|
||||
"bootfile=zImage\0" \
|
||||
+ "rdfile=initramfs-linux.img\0" \
|
||||
"usbtty=cdc_acm\0" \
|
||||
"vram=16M\0" \
|
||||
"mmcdev=0\0" \
|
||||
- "mmcroot=/dev/mmcblk0p2 rw\0" \
|
||||
- "mmcrootfstype=ext3 rootwait\0" \
|
||||
+ "optargs=\0" \
|
||||
+ "mmcroot=/dev/mmcblk0p1 rw rootwait\0" \
|
||||
"mmcargs=setenv bootargs console=${console} " \
|
||||
"vram=${vram} " \
|
||||
- "root=${mmcroot} " \
|
||||
- "rootfstype=${mmcrootfstype}\0" \
|
||||
- "loadbootscript=load mmc ${mmcdev} ${loadaddr} boot.scr\0" \
|
||||
- "bootscript=echo Running bootscript from mmc${mmcdev} ...; " \
|
||||
- "source ${loadaddr}\0" \
|
||||
|
@ -63,11 +48,14 @@ index 1c93aab..e8b6c90 100644
|
|||
- "loadimage=load mmc ${bootpart} ${loadaddr} ${bootdir}/${bootfile}\0" \
|
||||
- "loaduimage=load mmc ${mmcdev} ${loadaddr} uImage\0" \
|
||||
- "mmcboot=echo Booting from mmc${mmcdev} ...; " \
|
||||
- "run mmcargs; " \
|
||||
- "run args_mmc; " \
|
||||
- "bootz ${loadaddr} - ${fdtaddr}\0" \
|
||||
- "uimageboot=echo Booting from mmc${mmcdev} ...; " \
|
||||
- "run mmcargs; " \
|
||||
- "run args_mmc; " \
|
||||
- "bootm ${loadaddr}\0" \
|
||||
+ "optargs=\0" \
|
||||
+ "mmcargs=setenv bootargs console=${console} " \
|
||||
+ "vram=${vram} " \
|
||||
+ "root=${root} " \
|
||||
+ "${optargs}\0" \
|
||||
+ "loadimage=load ${devtype} ${bootpart} ${loadaddr} ${bootdir}/${bootfile}\0" \
|
||||
|
@ -110,7 +98,7 @@ index 1c93aab..e8b6c90 100644
|
|||
"findfdt="\
|
||||
"if test $board_name = sdp4430; then " \
|
||||
"setenv fdtfile omap4-sdp.dtb; fi; " \
|
||||
@@ -127,32 +157,11 @@
|
||||
@@ -117,32 +149,11 @@
|
||||
"if test $board_name = duovero; then " \
|
||||
"setenv fdtfile omap4-duovero-parlor.dtb; fi;" \
|
||||
"if test $fdtfile = undefined; then " \
|
||||
|
@ -146,5 +134,5 @@ index 1c93aab..e8b6c90 100644
|
|||
/*
|
||||
* Defines for SPL
|
||||
--
|
||||
2.4.2
|
||||
2.6.1
|
||||
|
||||
|
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=uboot-pandaboard
|
||||
pkgver=2015.04
|
||||
pkgver=2015.10
|
||||
pkgrel=1
|
||||
pkgdesc="U-Boot for Pandaboard and Pandaboard ES"
|
||||
arch=('armv7h')
|
||||
|
@ -15,8 +15,8 @@ install=${pkgname}.install
|
|||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
||||
'0001-arch-linux-arm-modifications.patch'
|
||||
'uEnv.txt')
|
||||
md5sums=('570bdc2c47270c2a98ca60ff6c5c74cd'
|
||||
'6a4060a6cef75dd47b841c7a46a866e8'
|
||||
md5sums=('7c203b0fc3390a122d8e8b75f147eac5'
|
||||
'49f3466b86722425598ee3ef42146115'
|
||||
'86004660f2912861a040e335c9c0e85b')
|
||||
|
||||
prepare() {
|
||||
|
|
Loading…
Reference in a new issue