extra/bind to 9.11.1-1

This commit is contained in:
Kevin Mihelich 2017-04-24 23:42:10 +00:00
parent a0d1118577
commit c0f60dc675
2 changed files with 6 additions and 46 deletions

View file

@ -1,39 +0,0 @@
# https://github.com/voidlinux/void-packages/blob/master/srcpkgs/bind/patches/seccomp.patch
--- a/bin/named/include/named/seccomp.h.orig
+++ b/bin/named/include/named/seccomp.h
@@ -57,6 +57,8 @@
SCMP_SYS(rt_sigsuspend),
SCMP_SYS(fstat),
SCMP_SYS(epoll_ctl),
SCMP_SYS(gettimeofday),
+ SCMP_SYS(getpid),
+ SCMP_SYS(getrandom),
SCMP_SYS(unlink),
SCMP_SYS(socket),
@@ -121,6 +123,8 @@
"fstat",
"epoll_ctl",
"gettimeofday",
+ "getpid",
+ "getrandom",
"unlink",
"socket",
"sendto",
@@ -190,6 +194,8 @@
SCMP_SYS(fstat64),
SCMP_SYS(epoll_ctl),
SCMP_SYS(gettimeofday),
+ SCMP_SYS(getpid),
+ SCMP_SYS(getrandom),
SCMP_SYS(unlink),
#ifndef ISC_PLATFORM_USETHREADS
SCMP_SYS(fcntl64),
@@ -226,6 +232,8 @@
"fstat64",
"epoll_ctl",
"gettimeofday",
+ "getpid",
+ "getrandom",
"unlink",
#ifndef ISC_PLATFORM_USETHREADS
"fcntl64",

View file

@ -10,9 +10,9 @@
pkgbase=bind
pkgname=(bind bind-tools)
_pkgver=9.11.0-P3
_pkgver=9.11.1
pkgver=${_pkgver//-/.}
pkgrel=3
pkgrel=1
url='https://www.isc.org/software/bind/'
license=('custom:ISC')
arch=('i686' 'x86_64')
@ -31,9 +31,8 @@ source=("https://ftp.isc.org/isc/bind9/${_pkgver}/bind-${_pkgver}.tar.gz"{,.asc}
'localhost.zone'
'localhost.ip6.zone'
'127.0.0.zone'
'empty.zone'
'01-seccomp.patch')
sha1sums=('87d604061b23757dd746902ee66cd95545d5872f'
'empty.zone')
sha1sums=('9ed24ef251c724fef7fb0dd5484947ddb351195e'
'SKIP'
'c5a2bcd9b0f009ae71f3a03fbdbe012196962a11'
'9537f4835a1f736788d0733c7996a10db2d4eee4'
@ -42,8 +41,7 @@ sha1sums=('87d604061b23757dd746902ee66cd95545d5872f'
'6704303a6ed431a29b1d8fe7b12decd4d1f2f50f'
'52da8f1c0247a11b16daa4e03d920e8f09315cbe'
'9c33726088342207ad06d33b2c13408290a0c8ad'
'4f4457b310cbbeadca2272eced062a9c2b2b42fe'
'b1130c6d3ecab96291108194ec9490df3322aabe')
'4f4457b310cbbeadca2272eced062a9c2b2b42fe')
prepare() {
msg2 'Getting a fresh version of root DNS'
@ -82,6 +80,7 @@ build() {
--with-libjson \
--with-libxml2 \
--with-libtool
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}