mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/chromium to 67.0.3396.87-2
This commit is contained in:
parent
a1f8a9ce8b
commit
c11ce8fe60
2 changed files with 39 additions and 2 deletions
|
@ -16,7 +16,7 @@ highmem=1
|
|||
|
||||
pkgname=chromium
|
||||
pkgver=67.0.3396.87
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
_launcher_ver=6
|
||||
pkgdesc="A web browser built for speed, simplicity, and security"
|
||||
arch=('x86_64')
|
||||
|
@ -37,6 +37,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
x11-fix-mixup-between-DIP-pixel-coordinates.patch
|
||||
chromium-ffmpeg-r1.patch
|
||||
chromium-widevine-r2.patch
|
||||
chromium-disable_xml_catalogs.patch
|
||||
chromium-skia-harmony.patch
|
||||
0001-Ensure-all-targets-build-when-target_arch-arm-and-ta.patch)
|
||||
sha256sums=('5d27a72f0cb8247343034f63fdd9747ff388c05b9fceb541668dd04fb372db1d'
|
||||
|
@ -45,6 +46,7 @@ sha256sums=('5d27a72f0cb8247343034f63fdd9747ff388c05b9fceb541668dd04fb372db1d'
|
|||
'e2c2754536243a60fa70541bbd4121715eccd83caa8f1fb1873bd994cd81f871'
|
||||
'aa885330bc4180b78d915f9dfdfc3210038a0acab7b16735ea9828ab6a633bde'
|
||||
'02c69bb3954087db599def7f5b6d65cf8f7cf2ed81dfbdaa4bb7b51863b4df15'
|
||||
'f9d191e89ed9b2b2641bbbb370ea0a11868409a13cad181f7b63f6007de002a1'
|
||||
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
|
||||
'9e4d63c582b316edaa550aae6fe6623f0df1a94c53f97bae4b0d7826e0779a32')
|
||||
|
||||
|
@ -62,7 +64,7 @@ declare -gA _system_libs=(
|
|||
#[libpng]=libpng # https://crbug.com/752403#c10
|
||||
#[libvpx]=libvpx # needs unreleased libvpx
|
||||
[libwebp]=libwebp
|
||||
#[libxml]=libxml2 # https://crbug.com/736026
|
||||
[libxml]=libxml2
|
||||
[libxslt]=libxslt
|
||||
[opus]=opus
|
||||
[re2]=re2
|
||||
|
@ -112,6 +114,7 @@ prepare() {
|
|||
# Fixes from Gentoo
|
||||
patch -Np1 -i ../chromium-ffmpeg-r1.patch
|
||||
patch -Np1 -i ../chromium-widevine-r2.patch
|
||||
patch -Np1 -i ../chromium-disable_xml_catalogs.patch
|
||||
|
||||
# Remove compiler flags not supported by our system clang
|
||||
sed -i \
|
||||
|
|
34
extra/chromium/chromium-disable_xml_catalogs.patch
Normal file
34
extra/chromium/chromium-disable_xml_catalogs.patch
Normal file
|
@ -0,0 +1,34 @@
|
|||
--- a/third_party/blink/renderer/core/xml/parser/xml_document_parser.cc
|
||||
+++ b/third_party/blink/renderer/core/xml/parser/xml_document_parser.cc
|
||||
@@ -28,6 +28,10 @@
|
||||
|
||||
#include <libxml/parser.h>
|
||||
#include <libxml/parserInternals.h>
|
||||
+#include <libxml/xmlversion.h>
|
||||
+#if defined(LIBXML_CATALOG_ENABLED)
|
||||
+#include <libxml/catalog.h>
|
||||
+#endif
|
||||
#include <libxslt/xslt.h>
|
||||
|
||||
#include <memory>
|
||||
@@ -538,10 +542,6 @@
|
||||
static bool ShouldAllowExternalLoad(const KURL& url) {
|
||||
String url_string = url.GetString();
|
||||
|
||||
- // libxml should not be configured with catalogs enabled, so it
|
||||
- // should not be asking to load default catalogs.
|
||||
- CHECK(!IsLibxmlDefaultCatalogFile(url));
|
||||
-
|
||||
// The most common DTD. There isn't much point in hammering www.w3c.org by
|
||||
// requesting this URL for every XHTML document.
|
||||
if (url_string.StartsWithIgnoringASCIICase("http://www.w3.org/TR/xhtml"))
|
||||
@@ -648,6 +648,9 @@
|
||||
if (did_init)
|
||||
return;
|
||||
|
||||
+#if defined(LIBXML_CATALOG_ENABLED)
|
||||
+ xmlCatalogSetDefaults(XML_CATA_ALLOW_NONE);
|
||||
+#endif
|
||||
xmlInitParser();
|
||||
xmlRegisterInputCallbacks(MatchFunc, OpenFunc, ReadFunc, CloseFunc);
|
||||
xmlRegisterOutputCallbacks(MatchFunc, OpenFunc, WriteFunc, CloseFunc);
|
Loading…
Reference in a new issue