mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/ceph to 10.2.2-2
This commit is contained in:
parent
52c85811b1
commit
c14a88c0fd
9 changed files with 217 additions and 79 deletions
11
extra/ceph/01-virtualenv2.patch
Normal file
11
extra/ceph/01-virtualenv2.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/src/tools/setup-virtualenv.sh 2016-06-14 13:43:58.000000000 +0200
|
||||||
|
+++ b/src/tools/setup-virtualenv.sh 2016-08-18 02:13:31.418624320 +0200
|
||||||
|
@@ -18,7 +18,7 @@
|
||||||
|
DIR=$1
|
||||||
|
rm -fr $DIR
|
||||||
|
mkdir -p $DIR
|
||||||
|
-virtualenv --python python2.7 $DIR
|
||||||
|
+virtualenv2 --python python2.7 $DIR
|
||||||
|
. $DIR/bin/activate
|
||||||
|
# older versions of pip will not install wrap_console scripts
|
||||||
|
# when using wheel packages
|
38
extra/ceph/02-setup-python2.patch
Normal file
38
extra/ceph/02-setup-python2.patch
Normal file
|
@ -0,0 +1,38 @@
|
||||||
|
--- a/src/Makefile.in 2016-06-14 13:44:59.000000000 +0200
|
||||||
|
+++ b/src/Makefile.in 2016-08-19 22:09:15.526703376 +0200
|
||||||
|
@@ -32623,7 +32623,7 @@
|
||||||
|
cd $(srcdir)/ceph-detect-init ; ../tools/setup-virtualenv.sh ${CEPH_DETECT_INIT_VIRTUALENV} ; test -d wheelhouse && export NO_INDEX=--no-index ; ${CEPH_DETECT_INIT_VIRTUALENV}/bin/pip install $$NO_INDEX --use-wheel --find-links=file://$$(pwd)/wheelhouse -e .
|
||||||
|
|
||||||
|
ceph-detect-init-clean:
|
||||||
|
- cd $(srcdir)/ceph-detect-init ; python setup.py clean ; rm -fr wheelhouse .tox build ${CEPH_DETECT_INIT_VIRTUALENV} .coverage *.egg-info
|
||||||
|
+ cd $(srcdir)/ceph-detect-init ; python2 setup.py clean ; rm -fr wheelhouse .tox build ${CEPH_DETECT_INIT_VIRTUALENV} .coverage *.egg-info
|
||||||
|
|
||||||
|
ceph-detect-init-install-data:
|
||||||
|
cd $(srcdir)/ceph-detect-init ; \
|
||||||
|
@@ -32635,7 +32635,7 @@
|
||||||
|
fi ; \
|
||||||
|
root="--root=$(DESTDIR)" ; \
|
||||||
|
fi ; \
|
||||||
|
- python setup.py install $$root $$options
|
||||||
|
+ python2 setup.py install $$root $$options
|
||||||
|
|
||||||
|
export CEPH_DISK_VIRTUALENV = ${CEPH_BUILD_VIRTUALENV}/ceph-disk-virtualenv
|
||||||
|
|
||||||
|
@@ -32645,7 +32645,7 @@
|
||||||
|
cd $(srcdir)/ceph-disk ; ../tools/setup-virtualenv.sh ${CEPH_DISK_VIRTUALENV} ; test -d wheelhouse && export NO_INDEX=--no-index ; ${CEPH_DISK_VIRTUALENV}/bin/pip install $$NO_INDEX --use-wheel --find-links=file://$$(pwd)/wheelhouse -e .
|
||||||
|
|
||||||
|
ceph-disk-clean:
|
||||||
|
- cd $(srcdir)/ceph-disk ; python setup.py clean ; rm -fr wheelhouse .tox build ${CEPH_DISK_VIRTUALENV} .coverage *.egg-info
|
||||||
|
+ cd $(srcdir)/ceph-disk ; python2 setup.py clean ; rm -fr wheelhouse .tox build ${CEPH_DISK_VIRTUALENV} .coverage *.egg-info
|
||||||
|
|
||||||
|
ceph-disk-install-data:
|
||||||
|
cd $(srcdir)/ceph-disk ; \
|
||||||
|
@@ -32657,7 +32657,7 @@
|
||||||
|
fi ; \
|
||||||
|
root="--root=$(DESTDIR) --install-script=/usr/sbin" ; \
|
||||||
|
fi ; \
|
||||||
|
- python setup.py install $$root $$options
|
||||||
|
+ python2 setup.py install $$root $$options
|
||||||
|
|
||||||
|
#crush_includedir = $(includedir)/crush
|
||||||
|
#crush_include_DATA = \
|
|
@ -5,82 +5,87 @@
|
||||||
# - patch to remove neon detection in configure
|
# - patch to remove neon detection in configure
|
||||||
|
|
||||||
pkgname=ceph
|
pkgname=ceph
|
||||||
pkgver=0.94.5
|
pkgver=10.2.2
|
||||||
pkgrel=3
|
pkgrel=2
|
||||||
pkgdesc='Distributed, fault-tolerant storage platform delivering object, block, and file system'
|
pkgdesc='Distributed, fault-tolerant storage platform delivering object, block, and file system'
|
||||||
arch=('x86_64' 'i686')
|
arch=('x86_64' 'i686')
|
||||||
url='http://ceph.com/'
|
url='http://ceph.com/'
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
makedepends=('boost' 'systemd' 'xfsprogs')
|
makedepends=('boost' 'systemd' 'xfsprogs' 'python2-setuptools' 'python2-sphinx'
|
||||||
depends=('boost-libs'
|
'python2-virtualenv' 'cython2')
|
||||||
'curl'
|
depends=('boost-libs' 'curl' 'expat' 'fcgi' 'fuse' 'gcc-libs' 'glibc'
|
||||||
'expat'
|
'gperftools' 'keyutils' 'leveldb' 'libaio' 'libatomic_ops' 'libedit'
|
||||||
'fcgi'
|
'libsystemd' 'libutil-linux' 'ncurses' 'nss' 'python2' 'snappy')
|
||||||
'fuse'
|
|
||||||
'gcc-libs'
|
|
||||||
'glibc'
|
|
||||||
'gperftools'
|
|
||||||
'keyutils'
|
|
||||||
'leveldb'
|
|
||||||
'libaio'
|
|
||||||
'libatomic_ops'
|
|
||||||
'libedit'
|
|
||||||
'libsystemd'
|
|
||||||
'libutil-linux'
|
|
||||||
'ncurses'
|
|
||||||
'nss'
|
|
||||||
'python2'
|
|
||||||
'snappy')
|
|
||||||
optdepends=('xfsprogs: support xfs backend')
|
optdepends=('xfsprogs: support xfs backend')
|
||||||
options=('emptydirs')
|
options=('emptydirs')
|
||||||
source=("http://ceph.com/download/$pkgname-$pkgver.tar.bz2"
|
install=ceph.install
|
||||||
'ceph-osd@.service'
|
source=("http://ceph.com/download/$pkgname-$pkgver.tar.gz"
|
||||||
'ceph-mon@.service'
|
'ceph.sysusers'
|
||||||
'ceph-mds@.service'
|
'01-virtualenv2.patch'
|
||||||
|
'02-setup-python2.patch'
|
||||||
'no-neon.patch')
|
'no-neon.patch')
|
||||||
md5sums=('e7c35581f8d36d34f7cde16a862e54fb'
|
md5sums=('5cba47af53b3b17002aad3c854e5405c'
|
||||||
'9104b5b90349d2aa7802eb89158456e8'
|
'b3e24e3aa005a657ab475f84bfe3291a'
|
||||||
'63a584aa2a4e2b0efbee4e8fd32593f0'
|
'a3f72dc8e97f9fd5708d52256bcd9e75'
|
||||||
'd2411c41208d95743baa6d899cc1e0b0'
|
'f11582acceeb6c1790518c3a5a29bb18'
|
||||||
'7bc1737bb952b08db8e9a0780aee21d8')
|
'97d293b08d5d4b4a2db37030c28bc617')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
# patch -p1 -d $pkgname-$pkgver < 01-boost-158.patch
|
cd $pkgname-$pkgver
|
||||||
patch -p1 -d $pkgname-$pkgver -i ../no-neon.patch
|
# apply patch from the source array (should be a pacman feature)
|
||||||
|
local filename
|
||||||
|
for filename in "${source[@]}"; do
|
||||||
|
if [[ "$filename" =~ \.patch$ ]]; then
|
||||||
|
msg2 "Applying patch $filename"
|
||||||
|
patch -p1 -N -i "$srcdir/$filename"
|
||||||
|
fi
|
||||||
|
done
|
||||||
|
:
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd $pkgname-$pkgver
|
cd $pkgname-$pkgver
|
||||||
export PYTHON=/usr/bin/python2
|
|
||||||
./configure \
|
./configure \
|
||||||
--prefix=/usr \
|
--prefix=/usr \
|
||||||
--sbindir=/usr/bin \
|
--sbindir=/usr/bin \
|
||||||
--libexecdir=/usr/lib \
|
--libexecdir=/usr/lib \
|
||||||
--sysconfdir=/etc \
|
--sysconfdir=/etc \
|
||||||
--localstatedir=/var \
|
--localstatedir=/var \
|
||||||
--with-radosgw
|
--with-man-pages \
|
||||||
|
--with-radosgw \
|
||||||
|
--without-openldap \
|
||||||
|
PYTHON=/usr/bin/python2 \
|
||||||
|
CYTHON_CHECK=yes \
|
||||||
|
PYTHON_CONFIG_CHECK=yes \
|
||||||
|
SPHINX_BUILD=sphinx-build2
|
||||||
make
|
make
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
make -C $pkgname-$pkgver DESTDIR="$pkgdir" install
|
cd $pkgname-$pkgver
|
||||||
|
|
||||||
|
make DESTDIR="$pkgdir" install
|
||||||
|
|
||||||
|
# install tmpfiles.d
|
||||||
|
install -Dm644 systemd/ceph.tmpfiles.d "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
|
||||||
|
install -Dm644 "$srcdir"/ceph.sysusers "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
|
||||||
|
|
||||||
cd "$pkgdir"
|
cd "$pkgdir"
|
||||||
|
|
||||||
# systemd
|
# fix sbin path
|
||||||
install -dm755 usr/lib/{systemd/system,udev/rules.d}
|
msg2 'Fix sbin paths'
|
||||||
install -Dm644 "$srcdir"/ceph-{osd,mon,mds}@.service usr/lib/systemd/system
|
mv -v sbin/* usr/sbin/* usr/bin
|
||||||
install -Dm644 "$srcdir"/$pkgname-$pkgver/udev/* usr/lib/udev/rules.d
|
rmdir -v sbin usr/sbin
|
||||||
|
|
||||||
# fix directories path
|
# fix bash completions path
|
||||||
mv sbin/* usr/bin
|
msg2 'Fix bash completion path'
|
||||||
rmdir sbin
|
|
||||||
install -d -m 755 usr/share/bash-completion
|
install -d -m 755 usr/share/bash-completion
|
||||||
mv etc/bash_completion.d usr/share/bash-completion/completions
|
mv etc/bash_completion.d usr/share/bash-completion/completions
|
||||||
|
|
||||||
# fix python2 shebang, did not do it in prepare() anymore because it
|
# fix python2 shebang, did not do it in prepare() anymore because it
|
||||||
# confuse automake
|
# confuse automake
|
||||||
find . -type f -exec \
|
msg2 'Fix python2 shebang'
|
||||||
|
find . -type f -executable -exec \
|
||||||
sed -i '1s,^#! \?/usr/bin/\(env \|\)python$,#!/usr/bin/python2,' {} \;
|
sed -i '1s,^#! \?/usr/bin/\(env \|\)python$,#!/usr/bin/python2,' {} \;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -1,9 +0,0 @@
|
||||||
[Unit]
|
|
||||||
Description=Ceph MDS %i
|
|
||||||
After=network.target
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
ExecStart=/usr/bin/ceph-mds -f -i %i
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
WantedBy=multi-user.target
|
|
|
@ -1,9 +0,0 @@
|
||||||
[Unit]
|
|
||||||
Description=Ceph MON %i
|
|
||||||
After=network.target
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
ExecStart=/usr/bin/ceph-mon -f -i %i
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
WantedBy=multi-user.target
|
|
|
@ -1,9 +0,0 @@
|
||||||
[Unit]
|
|
||||||
Description=Ceph OSD %i
|
|
||||||
After=network.target
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
ExecStart=/usr/bin/ceph-osd -f -i %i
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
WantedBy=multi-user.target
|
|
16
extra/ceph/ceph.install
Normal file
16
extra/ceph/ceph.install
Normal file
|
@ -0,0 +1,16 @@
|
||||||
|
# vim: ft=sh ts=2 sw=2 et:
|
||||||
|
|
||||||
|
# arg 1: the new package version
|
||||||
|
post_install() {
|
||||||
|
systemd-sysusers ceph.conf
|
||||||
|
systemd-tmpfiles --create ceph.conf
|
||||||
|
}
|
||||||
|
|
||||||
|
# arg 1: the new package version
|
||||||
|
# arg 2: the old package version
|
||||||
|
post_upgrade() {
|
||||||
|
if (( "$(vercmp $2 '10.2.2-1')" < 0 )); then
|
||||||
|
systemd-sysusers ceph.conf
|
||||||
|
systemd-tmpfiles --create ceph.conf
|
||||||
|
fi
|
||||||
|
}
|
1
extra/ceph/ceph.sysusers
Normal file
1
extra/ceph/ceph.sysusers
Normal file
|
@ -0,0 +1 @@
|
||||||
|
u ceph - - /run/ceph
|
|
@ -1,12 +1,14 @@
|
||||||
diff -urN a/configure b/configure
|
diff -urN a/configure b/configure
|
||||||
--- a/configure 2015-08-26 11:51:18.000000000 -0600
|
--- a/configure 2016-06-14 05:44:54.000000000 -0600
|
||||||
+++ b/configure 2015-09-17 20:46:42.152578212 -0600
|
+++ b/configure 2016-09-10 11:30:50.025304378 -0600
|
||||||
@@ -20782,112 +20782,8 @@
|
@@ -21627,204 +21627,11 @@
|
||||||
|
|
||||||
fi
|
fi
|
||||||
|
|
||||||
-# Find supported SIMD / NEON / SSE extensions supported by the compiler
|
-# Find supported SIMD / NEON / SSE extensions supported by the compiler
|
||||||
-
|
+HAVE_NEON_TRUE='#'
|
||||||
|
+HAVE_NEON_FALSE=
|
||||||
|
|
||||||
-
|
-
|
||||||
-
|
-
|
||||||
- case $target_cpu in
|
- case $target_cpu in
|
||||||
|
@ -56,6 +58,45 @@ diff -urN a/configure b/configure
|
||||||
- fi
|
- fi
|
||||||
- ;;
|
- ;;
|
||||||
- aarch64*)
|
- aarch64*)
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -march=armv8-a" >&5
|
||||||
|
-$as_echo_n "checking whether C compiler accepts -march=armv8-a... " >&6; }
|
||||||
|
-if ${ax_cv_check_cflags___march_armv8_a+:} false; then :
|
||||||
|
- $as_echo_n "(cached) " >&6
|
||||||
|
-else
|
||||||
|
-
|
||||||
|
- ax_check_save_flags=$CFLAGS
|
||||||
|
- CFLAGS="$CFLAGS -march=armv8-a"
|
||||||
|
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||||
|
-/* end confdefs.h. */
|
||||||
|
-
|
||||||
|
-int
|
||||||
|
-main ()
|
||||||
|
-{
|
||||||
|
-
|
||||||
|
- ;
|
||||||
|
- return 0;
|
||||||
|
-}
|
||||||
|
-_ACEOF
|
||||||
|
-if ac_fn_c_try_compile "$LINENO"; then :
|
||||||
|
- ax_cv_check_cflags___march_armv8_a=yes
|
||||||
|
-else
|
||||||
|
- ax_cv_check_cflags___march_armv8_a=no
|
||||||
|
-fi
|
||||||
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||||
|
- CFLAGS=$ax_check_save_flags
|
||||||
|
-fi
|
||||||
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___march_armv8_a" >&5
|
||||||
|
-$as_echo "$ax_cv_check_cflags___march_armv8_a" >&6; }
|
||||||
|
-if test x"$ax_cv_check_cflags___march_armv8_a" = xyes; then :
|
||||||
|
- ax_cv_support_armv8=yes
|
||||||
|
-else
|
||||||
|
- :
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
- if test x"$ax_cv_support_armv8" = x"yes"; then
|
||||||
|
- ARM_ARCH_FLAGS="-march=armv8-a"
|
||||||
|
- ARM_DEFINE_FLAGS="-DARCH_AARCH64"
|
||||||
|
- fi
|
||||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -march=armv8-a+simd" >&5
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -march=armv8-a+simd" >&5
|
||||||
-$as_echo_n "checking whether C compiler accepts -march=armv8-a+simd... " >&6; }
|
-$as_echo_n "checking whether C compiler accepts -march=armv8-a+simd... " >&6; }
|
||||||
-if ${ax_cv_check_cflags___march_armv8_apsimd+:} false; then :
|
-if ${ax_cv_check_cflags___march_armv8_apsimd+:} false; then :
|
||||||
|
@ -92,13 +133,58 @@ diff -urN a/configure b/configure
|
||||||
-fi
|
-fi
|
||||||
-
|
-
|
||||||
- if test x"$ax_cv_support_neon_ext" = x"yes"; then
|
- if test x"$ax_cv_support_neon_ext" = x"yes"; then
|
||||||
|
- ARM_ARCH_FLAGS="$ARM_ARCH_FLAGS+simd"
|
||||||
|
- ARM_DEFINE_FLAGS="$ARM_DEFINE_FLAGS -DARM_NEON"
|
||||||
- ARM_NEON_FLAGS="-march=armv8-a+simd -DARCH_AARCH64 -DARM_NEON"
|
- ARM_NEON_FLAGS="-march=armv8-a+simd -DARCH_AARCH64 -DARM_NEON"
|
||||||
-
|
-
|
||||||
- ARM_FLAGS="$ARM_FLAGS $ARM_NEON_FLAGS"
|
|
||||||
-
|
|
||||||
-$as_echo "#define HAVE_NEON /**/" >>confdefs.h
|
-$as_echo "#define HAVE_NEON /**/" >>confdefs.h
|
||||||
-
|
-
|
||||||
|
-
|
||||||
- fi
|
- fi
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -march=armv8-a+crc" >&5
|
||||||
|
-$as_echo_n "checking whether C compiler accepts -march=armv8-a+crc... " >&6; }
|
||||||
|
-if ${ax_cv_check_cflags___march_armv8_apcrc+:} false; then :
|
||||||
|
- $as_echo_n "(cached) " >&6
|
||||||
|
-else
|
||||||
|
-
|
||||||
|
- ax_check_save_flags=$CFLAGS
|
||||||
|
- CFLAGS="$CFLAGS -march=armv8-a+crc"
|
||||||
|
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||||
|
-/* end confdefs.h. */
|
||||||
|
-
|
||||||
|
-int
|
||||||
|
-main ()
|
||||||
|
-{
|
||||||
|
-
|
||||||
|
- ;
|
||||||
|
- return 0;
|
||||||
|
-}
|
||||||
|
-_ACEOF
|
||||||
|
-if ac_fn_c_try_compile "$LINENO"; then :
|
||||||
|
- ax_cv_check_cflags___march_armv8_apcrc=yes
|
||||||
|
-else
|
||||||
|
- ax_cv_check_cflags___march_armv8_apcrc=no
|
||||||
|
-fi
|
||||||
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||||
|
- CFLAGS=$ax_check_save_flags
|
||||||
|
-fi
|
||||||
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___march_armv8_apcrc" >&5
|
||||||
|
-$as_echo "$ax_cv_check_cflags___march_armv8_apcrc" >&6; }
|
||||||
|
-if test x"$ax_cv_check_cflags___march_armv8_apcrc" = xyes; then :
|
||||||
|
- ax_cv_support_crc_ext=yes
|
||||||
|
-else
|
||||||
|
- :
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
- if test x"$ax_cv_support_crc_ext" = x"yes"; then
|
||||||
|
- ARM_ARCH_FLAGS="$ARM_ARCH_FLAGS+crc"
|
||||||
|
- ARM_CRC_FLAGS="-march=armv8-a+crc -DARCH_AARCH64"
|
||||||
|
-
|
||||||
|
-$as_echo "#define HAVE_ARMV8_CRC /**/" >>confdefs.h
|
||||||
|
-
|
||||||
|
-
|
||||||
|
- fi
|
||||||
|
- ARM_FLAGS="$ARM_ARCH_FLAGS $ARM_DEFINE_FLAGS"
|
||||||
- ;;
|
- ;;
|
||||||
- esac
|
- esac
|
||||||
-
|
-
|
||||||
|
@ -111,8 +197,16 @@ diff -urN a/configure b/configure
|
||||||
- HAVE_NEON_TRUE='#'
|
- HAVE_NEON_TRUE='#'
|
||||||
- HAVE_NEON_FALSE=
|
- HAVE_NEON_FALSE=
|
||||||
-fi
|
-fi
|
||||||
+HAVE_NEON_TRUE='#'
|
-
|
||||||
+HAVE_NEON_FALSE=
|
- if test "x$ax_cv_support_crc_ext" = "xyes"; then
|
||||||
|
- HAVE_ARMV8_CRC_TRUE=
|
||||||
|
- HAVE_ARMV8_CRC_FALSE='#'
|
||||||
|
-else
|
||||||
|
- HAVE_ARMV8_CRC_TRUE='#'
|
||||||
|
- HAVE_ARMV8_CRC_FALSE=
|
||||||
|
-fi
|
||||||
|
+HAVE_ARMV8_CRC_TRUE='#'
|
||||||
|
+HAVE_ARMV8_CRC_FALSE=
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue