mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/linux-mmp to 3.10.84-1
This commit is contained in:
parent
e6326b4714
commit
c199425acc
3 changed files with 4 additions and 124 deletions
|
@ -1,85 +0,0 @@
|
||||||
From 7a2b9a1cdc8bb2813391a7d17dfafdc63b822fd2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
Date: Thu, 30 Apr 2015 20:15:13 -0600
|
|
||||||
Subject: [PATCH] AUFS fix for 3.10.76
|
|
||||||
|
|
||||||
---
|
|
||||||
fs/aufs/dcsub.c | 4 ++--
|
|
||||||
fs/aufs/debug.c | 2 +-
|
|
||||||
fs/aufs/export.c | 2 +-
|
|
||||||
fs/aufs/hnotify.c | 4 ++--
|
|
||||||
4 files changed, 6 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/fs/aufs/dcsub.c b/fs/aufs/dcsub.c
|
|
||||||
index 1746e79..c2e69fe 100644
|
|
||||||
--- a/fs/aufs/dcsub.c
|
|
||||||
+++ b/fs/aufs/dcsub.c
|
|
||||||
@@ -133,7 +133,7 @@ resume:
|
|
||||||
while (next != &this_parent->d_subdirs) {
|
|
||||||
struct list_head *tmp = next;
|
|
||||||
struct dentry *dentry = list_entry(tmp, struct dentry,
|
|
||||||
- d_u.d_child);
|
|
||||||
+ d_child);
|
|
||||||
|
|
||||||
next = tmp->next;
|
|
||||||
spin_lock_nested(&dentry->d_lock, DENTRY_D_LOCK_NESTED);
|
|
||||||
@@ -169,7 +169,7 @@ resume:
|
|
||||||
this_parent = tmp;
|
|
||||||
spin_lock(&this_parent->d_lock);
|
|
||||||
rcu_read_unlock();
|
|
||||||
- next = child->d_u.d_child.next;
|
|
||||||
+ next = child->d_child.next;
|
|
||||||
goto resume;
|
|
||||||
}
|
|
||||||
|
|
||||||
diff --git a/fs/aufs/debug.c b/fs/aufs/debug.c
|
|
||||||
index 3465e79..5cc8337 100644
|
|
||||||
--- a/fs/aufs/debug.c
|
|
||||||
+++ b/fs/aufs/debug.c
|
|
||||||
@@ -169,7 +169,7 @@ void au_dpri_dalias(struct inode *inode)
|
|
||||||
struct dentry *d;
|
|
||||||
|
|
||||||
spin_lock(&inode->i_lock);
|
|
||||||
- hlist_for_each_entry(d, &inode->i_dentry, d_alias)
|
|
||||||
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias)
|
|
||||||
au_dpri_dentry(d);
|
|
||||||
spin_unlock(&inode->i_lock);
|
|
||||||
}
|
|
||||||
diff --git a/fs/aufs/export.c b/fs/aufs/export.c
|
|
||||||
index 484794d..bbeb8dd 100644
|
|
||||||
--- a/fs/aufs/export.c
|
|
||||||
+++ b/fs/aufs/export.c
|
|
||||||
@@ -243,7 +243,7 @@ static struct dentry *decode_by_ino(struct super_block *sb, ino_t ino,
|
|
||||||
dentry = d_find_alias(inode);
|
|
||||||
else {
|
|
||||||
spin_lock(&inode->i_lock);
|
|
||||||
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
|
|
||||||
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
|
|
||||||
spin_lock(&d->d_lock);
|
|
||||||
if (!au_test_anon(d)
|
|
||||||
&& d->d_parent->d_inode->i_ino == dir_ino) {
|
|
||||||
diff --git a/fs/aufs/hnotify.c b/fs/aufs/hnotify.c
|
|
||||||
index 6b5b85e..6b2e1fa 100644
|
|
||||||
--- a/fs/aufs/hnotify.c
|
|
||||||
+++ b/fs/aufs/hnotify.c
|
|
||||||
@@ -211,7 +211,7 @@ static int hn_gen_by_inode(char *name, unsigned int nlen, struct inode *inode,
|
|
||||||
AuDebugOn(!name);
|
|
||||||
au_iigen_dec(inode);
|
|
||||||
spin_lock(&inode->i_lock);
|
|
||||||
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
|
|
||||||
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
|
|
||||||
spin_lock(&d->d_lock);
|
|
||||||
dname = &d->d_name;
|
|
||||||
if (dname->len != nlen
|
|
||||||
@@ -378,7 +378,7 @@ static struct dentry *lookup_wlock_by_name(char *name, unsigned int nlen,
|
|
||||||
|
|
||||||
dentry = NULL;
|
|
||||||
spin_lock(&parent->d_lock);
|
|
||||||
- list_for_each_entry(d, &parent->d_subdirs, d_u.d_child) {
|
|
||||||
+ list_for_each_entry(d, &parent->d_subdirs, d_child) {
|
|
||||||
/* AuDbg("%.*s\n", AuDLNPair(d)); */
|
|
||||||
spin_lock_nested(&d->d_lock, DENTRY_D_LOCK_NESTED);
|
|
||||||
dname = &d->d_name;
|
|
||||||
--
|
|
||||||
2.3.7
|
|
||||||
|
|
|
@ -7,7 +7,7 @@ pkgbase=linux-mmp
|
||||||
_srcname=linux-3.10
|
_srcname=linux-3.10
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="Marvell PXA168/MMP platforms"
|
_desc="Marvell PXA168/MMP platforms"
|
||||||
pkgver=3.10.82
|
pkgver=3.10.84
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="https://github.com/Marvell-Semi/PXA168_kernel/tree/gplugd-dev"
|
url="https://github.com/Marvell-Semi/PXA168_kernel/tree/gplugd-dev"
|
||||||
|
@ -16,16 +16,12 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'uboot-mkimage' 'git'
|
||||||
options=('!strip')
|
options=('!strip')
|
||||||
source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
|
source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
|
||||||
"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
|
"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
|
||||||
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}.x"
|
|
||||||
'http://archlinuxarm.org/builder/src/0001-Guruplug-Display-support.patch'
|
'http://archlinuxarm.org/builder/src/0001-Guruplug-Display-support.patch'
|
||||||
'0001-AUFS-fix-for-3.10.76.patch'
|
|
||||||
'config')
|
'config')
|
||||||
md5sums=('4f25cd5bec5f8d5a7d935b3f2ccb8481'
|
md5sums=('4f25cd5bec5f8d5a7d935b3f2ccb8481'
|
||||||
'1360bfaddcd75812470952df17b8a933'
|
'80a327cd3bc02259a7faf698352b0072'
|
||||||
'SKIP'
|
|
||||||
'abaf1ca25f914085c5c54b5ecdb2ca4e'
|
'abaf1ca25f914085c5c54b5ecdb2ca4e'
|
||||||
'fc05379f7cf47170556a906d415822aa'
|
'e0df8b4bc3c48a4a05c4c60c5818abe6')
|
||||||
'f11f084e2a7055cd5a39c6c62946e59e')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${srcdir}/${_srcname}"
|
cd "${srcdir}/${_srcname}"
|
||||||
|
@ -33,19 +29,6 @@ prepare() {
|
||||||
# upstream patch
|
# upstream patch
|
||||||
git apply --whitespace=nowarn ../patch-${pkgver}
|
git apply --whitespace=nowarn ../patch-${pkgver}
|
||||||
|
|
||||||
# AUFS patches
|
|
||||||
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
|
||||||
cp -ru "${srcdir}/aufs3-standalone/fs" .
|
|
||||||
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" ./include/linux
|
|
||||||
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" ./include/uapi/linux
|
|
||||||
|
|
||||||
git apply --whitespace=nowarn ../aufs3-standalone/aufs3-kbuild.patch
|
|
||||||
git apply --whitespace=nowarn ../aufs3-standalone/aufs3-base.patch
|
|
||||||
git apply --whitespace=nowarn ../aufs3-standalone/aufs3-mmap.patch
|
|
||||||
git apply --whitespace=nowarn ../aufs3-standalone/aufs3-standalone.patch
|
|
||||||
|
|
||||||
git apply ../0001-AUFS-fix-for-3.10.76.patch
|
|
||||||
|
|
||||||
# gplugd patch
|
# gplugd patch
|
||||||
git apply --whitespace=nowarn ../0001-Guruplug-Display-support.patch
|
git apply --whitespace=nowarn ../0001-Guruplug-Display-support.patch
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
#
|
#
|
||||||
# Automatically generated file; DO NOT EDIT.
|
# Automatically generated file; DO NOT EDIT.
|
||||||
# Linux/arm 3.10.63-1 Kernel Configuration
|
# Linux/arm 3.10.84-1 Kernel Configuration
|
||||||
#
|
#
|
||||||
CONFIG_ARM=y
|
CONFIG_ARM=y
|
||||||
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
|
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
|
||||||
|
@ -3092,24 +3092,6 @@ CONFIG_F2FS_FS=y
|
||||||
CONFIG_F2FS_STAT_FS=y
|
CONFIG_F2FS_STAT_FS=y
|
||||||
CONFIG_F2FS_FS_XATTR=y
|
CONFIG_F2FS_FS_XATTR=y
|
||||||
CONFIG_F2FS_FS_POSIX_ACL=y
|
CONFIG_F2FS_FS_POSIX_ACL=y
|
||||||
CONFIG_AUFS_FS=y
|
|
||||||
CONFIG_AUFS_BRANCH_MAX_127=y
|
|
||||||
# CONFIG_AUFS_BRANCH_MAX_511 is not set
|
|
||||||
# CONFIG_AUFS_BRANCH_MAX_1023 is not set
|
|
||||||
# CONFIG_AUFS_BRANCH_MAX_32767 is not set
|
|
||||||
CONFIG_AUFS_SBILIST=y
|
|
||||||
CONFIG_AUFS_HNOTIFY=y
|
|
||||||
CONFIG_AUFS_HFSNOTIFY=y
|
|
||||||
CONFIG_AUFS_EXPORT=y
|
|
||||||
CONFIG_AUFS_XATTR=y
|
|
||||||
CONFIG_AUFS_FHSM=y
|
|
||||||
CONFIG_AUFS_RDU=y
|
|
||||||
CONFIG_AUFS_SHWH=y
|
|
||||||
CONFIG_AUFS_BR_RAMFS=y
|
|
||||||
CONFIG_AUFS_BR_FUSE=y
|
|
||||||
CONFIG_AUFS_POLL=y
|
|
||||||
CONFIG_AUFS_BDEV_LOOP=y
|
|
||||||
# CONFIG_AUFS_DEBUG is not set
|
|
||||||
CONFIG_NETWORK_FILESYSTEMS=y
|
CONFIG_NETWORK_FILESYSTEMS=y
|
||||||
CONFIG_NFS_FS=y
|
CONFIG_NFS_FS=y
|
||||||
CONFIG_NFS_V2=y
|
CONFIG_NFS_V2=y
|
||||||
|
|
Loading…
Reference in a new issue