mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/thunderbird to 60.8.0-1
This commit is contained in:
parent
fb077971f9
commit
c1eb410bde
3 changed files with 55 additions and 46 deletions
|
@ -13,7 +13,7 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=thunderbird
|
||||
pkgver=60.7.2
|
||||
pkgver=60.8.0
|
||||
pkgrel=1
|
||||
pkgdesc='Standalone mail and news reader from mozilla.org'
|
||||
url='https://www.mozilla.org/thunderbird/'
|
||||
|
@ -25,13 +25,15 @@ makedepends=(unzip zip diffutils python2 yasm mesa imake libpulse inetutils xorg
|
|||
autoconf2.13 rust clang llvm gtk2)
|
||||
optdepends=('libcanberra: sound support')
|
||||
options=(!emptydirs !makeflags)
|
||||
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
|
||||
rust-1.33.patch
|
||||
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz{,.asc}
|
||||
rust-1.35.patch
|
||||
$pkgname.desktop
|
||||
Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch)
|
||||
sha256sums=('fc89a5f66b17d554fc0b9c153483edcc74b1bacc916dfd6dccead8478060af31'
|
||||
'2b0244a9f7a30f28bcc12055f171e5506c7e3b929d85c3b3514b7e4e4c251784'
|
||||
sha256sums=('1e7a13e64b63476d2235aaac6823fdab949af45cfcd5a25ee710cbae08c2f5d1'
|
||||
'SKIP'
|
||||
'3257987cc0ab0559c65561d523eb4d0e73b5edb86d9d18a2487818d9fca0bb30'
|
||||
'36a655ce3987159990d46a13d9955305a72a8a737e6af983eb170c4f652eb39a')
|
||||
validpgpkeys=(14F26682D0916CDD81E37B6D61B7B526D98F0353) # Mozilla Software Releases <release@mozilla.com>
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
# Note: These are for Arch Linux use ONLY. For your own distribution, please
|
||||
|
@ -48,8 +50,7 @@ _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
|
|||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1539901 (Patch from Fedora)
|
||||
patch -Np1 -i ../rust-1.33.patch
|
||||
patch -Np1 -i ../rust-1.35.patch # Fix build with rust 1.35 (Fedora)
|
||||
|
||||
echo -n "$_google_api_key" >google-api-key
|
||||
echo -n "$_mozilla_api_key" >mozilla-api-key
|
||||
|
|
|
@ -1,39 +0,0 @@
|
|||
diff -up thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py.rust-1.33-build thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py
|
||||
--- thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py.rust-1.33-build 2019-03-04 19:17:31.000000000 +0100
|
||||
+++ thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py 2019-03-13 15:05:58.965726109 +0100
|
||||
@@ -202,6 +202,7 @@ RULE_TEMPLATE = ('("{atom}") =>\n '
|
||||
' }}}};')
|
||||
|
||||
MACRO = '''
|
||||
+/// Returns a static atom by passing the literal string it represents.
|
||||
#[macro_export]
|
||||
macro_rules! atom {{
|
||||
{}
|
||||
diff -up thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs.rust-1.33-build thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs
|
||||
--- thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs.rust-1.33-build 2019-03-04 19:17:30.000000000 +0100
|
||||
+++ thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs 2019-03-13 15:05:58.966726107 +0100
|
||||
@@ -55,6 +55,7 @@ use style_adjuster::StyleAdjuster;
|
||||
|
||||
pub use self::declaration_block::*;
|
||||
|
||||
+/// Generated
|
||||
#[cfg(feature = "gecko")]
|
||||
#[macro_export]
|
||||
macro_rules! property_name {
|
||||
@@ -3852,7 +3853,7 @@ impl fmt::Debug for AliasId {
|
||||
}
|
||||
}
|
||||
|
||||
-// NOTE(emilio): Callers are responsible to deal with prefs.
|
||||
+/// Callers are responsible to deal with prefs.
|
||||
#[macro_export]
|
||||
macro_rules! css_properties_accessors {
|
||||
($macro_name: ident) => {
|
||||
@@ -3875,6 +3876,7 @@ macro_rules! css_properties_accessors {
|
||||
}
|
||||
}
|
||||
|
||||
+/// Neco
|
||||
#[macro_export]
|
||||
macro_rules! longhand_properties_idents {
|
||||
($macro_name: ident) => {
|
47
extra/thunderbird/rust-1.35.patch
Normal file
47
extra/thunderbird/rust-1.35.patch
Normal file
|
@ -0,0 +1,47 @@
|
|||
diff -up thunderbird-60.8.0/servo/components/style_traits/values.rs.rust-1.33-build thunderbird-60.8.0/servo/components/style_traits/values.rs
|
||||
--- thunderbird-60.8.0/servo/components/style_traits/values.rs.rust-1.33-build 2019-07-03 17:25:28.000000000 +0200
|
||||
+++ thunderbird-60.8.0/servo/components/style_traits/values.rs 2019-07-11 13:38:53.687318154 +0200
|
||||
@@ -135,6 +135,7 @@ where
|
||||
}
|
||||
}
|
||||
|
||||
+/// Some comment
|
||||
#[macro_export]
|
||||
macro_rules! serialize_function {
|
||||
($dest: expr, $name: ident($( $arg: expr, )+)) => {
|
||||
@@ -404,6 +405,7 @@ impl_to_css_for_predefined_type!(::csspa
|
||||
impl_to_css_for_predefined_type!(::cssparser::Color);
|
||||
impl_to_css_for_predefined_type!(::cssparser::UnicodeRange);
|
||||
|
||||
+/// Some comment
|
||||
#[macro_export]
|
||||
macro_rules! define_css_keyword_enum {
|
||||
(pub enum $name:ident { $($variant:ident = $css:expr,)+ }) => {
|
||||
diff -up thunderbird-60.8.0/servo/components/style/properties/properties.mako.rs.old thunderbird-60.8.0/servo/components/style/properties/properties.mako.rs
|
||||
--- thunderbird-60.8.0/servo/components/style/properties/properties.mako.rs.old 2019-07-11 14:22:51.393784701 +0200
|
||||
+++ thunderbird-60.8.0/servo/components/style/properties/properties.mako.rs 2019-07-11 14:24:03.182578100 +0200
|
||||
@@ -55,6 +55,7 @@ use style_adjuster::StyleAdjuster;
|
||||
|
||||
pub use self::declaration_block::*;
|
||||
|
||||
+/// Neco
|
||||
#[cfg(feature = "gecko")]
|
||||
#[macro_export]
|
||||
macro_rules! property_name {
|
||||
@@ -3852,7 +3853,7 @@ impl fmt::Debug for AliasId {
|
||||
}
|
||||
}
|
||||
|
||||
-// NOTE(emilio): Callers are responsible to deal with prefs.
|
||||
+/// NOTE(emilio): Callers are responsible to deal with prefs.
|
||||
#[macro_export]
|
||||
macro_rules! css_properties_accessors {
|
||||
($macro_name: ident) => {
|
||||
@@ -3875,6 +3876,7 @@ macro_rules! css_properties_accessors {
|
||||
}
|
||||
}
|
||||
|
||||
+/// Neco
|
||||
#[macro_export]
|
||||
macro_rules! longhand_properties_idents {
|
||||
($macro_name: ident) => {
|
Loading…
Reference in a new issue