extra/mesa to 20.3.0-3

This commit is contained in:
Kevin Mihelich 2020-12-08 20:40:49 +00:00
parent b3178e51b0
commit c2187dd196
2 changed files with 40 additions and 1 deletions

View file

@ -0,0 +1,35 @@
From 7c075bae56e45f268e62efcd82589111bce92ae3 Mon Sep 17 00:00:00 2001
From: Dave Airlie <airlied@redhat.com>
Date: Mon, 7 Dec 2020 09:47:35 +1000
Subject: [PATCH] radeonsi: fix regression on gpus using the radeon winsys.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
For GPUs using the radeon kernel driver, num_se was never
getting initialised.
Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/3939
Fixes: f2977a162af4 ("ac: fix min/max_good_num_cu_per_sa on gfx10.3 with disabled SEs")
Reviewed-by: Marek Olšák <marek.olsak@amd.com>
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/7954>
---
src/gallium/winsys/radeon/drm/radeon_drm_winsys.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/gallium/winsys/radeon/drm/radeon_drm_winsys.c b/src/gallium/winsys/radeon/drm/radeon_drm_winsys.c
index 0aab59cd236..ef7434d7589 100644
--- a/src/gallium/winsys/radeon/drm/radeon_drm_winsys.c
+++ b/src/gallium/winsys/radeon/drm/radeon_drm_winsys.c
@@ -530,6 +530,8 @@ static bool do_winsys_init(struct radeon_drm_winsys *ws)
}
}
+ ws->info.num_se = ws->info.max_se;
+
radeon_get_drm_value(ws->fd, RADEON_INFO_MAX_SH_PER_SE, NULL,
&ws->info.max_sa_per_se);
if (ws->gen == DRV_SI) {
--
GitLab

View file

@ -12,7 +12,7 @@ pkgbase=mesa
pkgname=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-radeon' 'vulkan-mesa' 'libva-mesa-driver' 'mesa-vdpau' 'mesa')
pkgdesc="An open-source implementation of the OpenGL specification"
pkgver=20.3.0
pkgrel=2
pkgrel=3
arch=('x86_64')
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
'libxdamage' 'libvdpau' 'libva' 'wayland' 'wayland-protocols' 'zstd' 'elfutils' 'llvm'
@ -21,10 +21,12 @@ makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence
url="https://www.mesa3d.org/"
license=('custom')
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
0001-radeonsi-fix-regression-on-gpus-using-the-radeon-winsys.patch
0001-Rip-out-VC4-forced-NEON.patch
LICENSE)
sha512sums=('69ee0bc1e7a69a519597dd55f4d601f35fe51ed6687d6f6beff6aef3da8d82de932220305fc187e06a52aaf0073d434a6e3458619c767b9b7932464a2cbb2cf2'
'SKIP'
'a133f5689e1007dc43234ed6a022f83c5ffbb256ed6207c73e30bee221c2617820aa8848e17d7f14fa629b4907a115c4f8a033dc40c7b53c473c2eef26bf8bf6'
'ba55fd9816ebd9147be120da1fd4fa0364d19967a11570e6d5dd9d8b4f7971df46ced8b151ee07afaaa98043e131eed14918ec25f8c9b0f7e5c53f452674ee5c'
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7')
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
@ -37,6 +39,8 @@ validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l
prepare() {
cd mesa-$pkgver
patch -Np1 < ../0001-radeonsi-fix-regression-on-gpus-using-the-radeon-winsys.patch
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && patch -p1 -i ../0001-Rip-out-VC4-forced-NEON.patch || true
}