community/kbibtex to 0.6-5

This commit is contained in:
Kevin Mihelich 2017-01-26 01:01:49 +00:00
parent d1a80393f0
commit c235b2dd40
2 changed files with 40 additions and 2 deletions

View file

@ -9,7 +9,7 @@
pkgname=kbibtex
pkgver=0.6
_branch=0.6
pkgrel=4
pkgrel=5
pkgdesc="A BibTeX editor for KDE"
arch=('i686' 'x86_64')
url='http://home.gna.org/kbibtex/'
@ -17,14 +17,18 @@ license=('GPL')
depends=('kdebase-runtime' 'poppler-qt4')
optdepends=('okular: Document preview')
makedepends=('cmake' 'automoc4')
source=("http://download.gna.org/$pkgname/$_branch/$pkgname-$pkgver.tar.xz"
source=("http://download.gna.org/$pkgname/$_branch/$pkgname-$pkgver.tar.xz" kbibtex-no-qtwebkit.patch
'0001-remove-qreal-cast-for-arm.patch')
md5sums=('f1a9c1867d94c36fe88cfa0470b85dac'
'73a6be6e48e0e9106f60b65ad07d73e6'
'fae1a894b4dbc9339b0ad70a3a3b185c')
prepare() {
cd "$pkgname-$pkgver"
# Disable insecure qtwebkit
patch -p1 -i ../kbibtex-no-qtwebkit.patch
if [[ $CARCH != "aarch64" ]]; then
patch -p1 -i ../0001-remove-qreal-cast-for-arm.patch
fi

View file

@ -0,0 +1,34 @@
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 04222a74..1485acc1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -34,29 +34,6 @@ include(
##SET(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} -pg")
##SET(CMAKE_CXX_FLAGS_DISTRIBUTION "${CMAKE_CXX_FLAGS_DISTRIBUTION} -pg")
-# check if QtWebKit is available, which seems to be not available
-# on e.g. RedHat Enterprise Linux 6 or Scientific Linux 6
-if(
- QT_QTWEBKIT_FOUND
-)
- message(
- STATUS
- "Found QtWebKit, enabling WebKit support"
- )
- add_definitions(
- -DHAVE_QTWEBKIT
- )
-else(
- QT_QTWEBKIT_FOUND
-)
- message(
- STATUS
- "QtWebKit not found, disabling WebKit support"
- )
-endif(
- QT_QTWEBKIT_FOUND
-)
-
add_definitions(
${QT_DEFINITIONS}
${KDE4_DEFINITIONS}