mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/openscenegraph to 3.6.3-1
This commit is contained in:
parent
50cd86163f
commit
c26d73b8b3
2 changed files with 10 additions and 175 deletions
|
@ -5,12 +5,11 @@
|
|||
# Contributor: Colin Pitrat <colin.pitrat@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - upstream patch for signed char
|
||||
# - comment moving non-existent lib64 directory in package
|
||||
|
||||
pkgname=openscenegraph
|
||||
pkgver=3.4.1
|
||||
pkgrel=4
|
||||
pkgver=3.6.3
|
||||
pkgrel=1
|
||||
pkgdesc='Open Source, high performance real-time graphics toolkit'
|
||||
url='http://www.openscenegraph.org'
|
||||
arch=('x86_64')
|
||||
|
@ -20,32 +19,25 @@ makedepends=('cmake' 'libvncserver' 'qt5-base' 'ffmpeg' 'mesa')
|
|||
optdepends=('libvncserver' 'gdal' 'openexr' 'poppler-glib' 'qt5-base' 'ffmpeg')
|
||||
conflicts=('openthreads')
|
||||
provides=('openthreads')
|
||||
source=(https://github.com/openscenegraph/OpenSceneGraph/archive/OpenSceneGraph-${pkgver}.tar.gz
|
||||
https://github.com/openscenegraph/OpenSceneGraph/commit/01c712e85195803993acb1d7712796cf494943c6.patch)
|
||||
sha256sums=('930eb46f05781a76883ec16c5f49cfb29a059421db131005d75bec4d78401fd5'
|
||||
'7019627aab6f5e8bfdf08d6aad824d7d3408ef08daa4122e69b142c9d34fc241')
|
||||
sha512sums=('4a65625e208d24256b5564bbe9d6f557758b51fae0acf85d1f71968a237fec299088536830fc862d25e02039de9ea13176b298a68aaa644eac958acbe1f4e143'
|
||||
'a21c930f7166e0aec2607569e8b3fc167a13a697ed8d5bfee4ee027d054e64de3aa83020ef1e6d2bd52c180f3bd1d8deab22242856dfc3ea8b4fc8d539f6f3d2')
|
||||
|
||||
prepare() {
|
||||
mkdir -p OpenSceneGraph-OpenSceneGraph-${pkgver}/build
|
||||
cd OpenSceneGraph-OpenSceneGraph-$pkgver
|
||||
patch -p1 -i ../01c712e85195803993acb1d7712796cf494943c6.patch
|
||||
}
|
||||
source=(https://github.com/openscenegraph/OpenSceneGraph/archive/OpenSceneGraph-${pkgver}.tar.gz)
|
||||
sha256sums=('51bbc79aa73ca602cd1518e4e25bd71d41a10abd296e18093a8acfebd3c62696')
|
||||
sha512sums=('5d66002cffa935ce670a119ffaebd8e4709acdf79ae2b34b37ad9df284ec8a1a74fee5a7a4109fbf3da6b8bd857960f2b7ae68c4c2e26036edbf484fccf08322')
|
||||
|
||||
build() {
|
||||
mkdir -p OpenSceneGraph-OpenSceneGraph-${pkgver}/build
|
||||
cd OpenSceneGraph-OpenSceneGraph-${pkgver}/build
|
||||
cmake \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_LIBDIR=lib \
|
||||
..
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd OpenSceneGraph-OpenSceneGraph-${pkgver}/build
|
||||
make DESTDIR="${pkgdir}" install
|
||||
install -Dm 644 ../LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
|
||||
cd OpenSceneGraph-OpenSceneGraph-${pkgver}
|
||||
make -C build DESTDIR="${pkgdir}" install
|
||||
install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
|
||||
#mv "${pkgdir}/usr/lib64" "${pkgdir}/usr/lib"
|
||||
}
|
||||
|
||||
|
|
|
@ -1,157 +0,0 @@
|
|||
Description: Replace deprecated FFmpeg API
|
||||
Author: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
|
||||
Last-Update: <2015-11-02>
|
||||
|
||||
--- openscenegraph-3.2.1.orig/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.cpp
|
||||
+++ openscenegraph-3.2.1/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.cpp
|
||||
@@ -71,7 +71,7 @@ void FFmpegDecoderVideo::open(AVStream *
|
||||
findAspectRatio();
|
||||
|
||||
// Find out whether we support Alpha channel
|
||||
- m_alpha_channel = (m_context->pix_fmt == PIX_FMT_YUVA420P);
|
||||
+ m_alpha_channel = (m_context->pix_fmt == AV_PIX_FMT_YUVA420P);
|
||||
|
||||
// Find out the framerate
|
||||
m_frame_rate = av_q2d(stream->avg_frame_rate);
|
||||
@@ -91,20 +91,19 @@ void FFmpegDecoderVideo::open(AVStream *
|
||||
throw std::runtime_error("avcodec_open() failed");
|
||||
|
||||
// Allocate video frame
|
||||
- m_frame.reset(avcodec_alloc_frame());
|
||||
+ m_frame.reset(av_frame_alloc());
|
||||
|
||||
// Allocate converted RGB frame
|
||||
- m_frame_rgba.reset(avcodec_alloc_frame());
|
||||
- m_buffer_rgba[0].resize(avpicture_get_size(PIX_FMT_RGB24, width(), height()));
|
||||
+ m_frame_rgba.reset(av_frame_alloc());
|
||||
+ m_buffer_rgba[0].resize(avpicture_get_size(AV_PIX_FMT_RGB24, width(), height()));
|
||||
m_buffer_rgba[1].resize(m_buffer_rgba[0].size());
|
||||
|
||||
// Assign appropriate parts of the buffer to image planes in m_frame_rgba
|
||||
- avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[0])[0], PIX_FMT_RGB24, width(), height());
|
||||
+ avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[0])[0], AV_PIX_FMT_RGB24, width(), height());
|
||||
|
||||
// Override get_buffer()/release_buffer() from codec context in order to retrieve the PTS of each frame.
|
||||
m_context->opaque = this;
|
||||
- m_context->get_buffer = getBuffer;
|
||||
- m_context->release_buffer = releaseBuffer;
|
||||
+ m_context->get_buffer2 = getBuffer;
|
||||
}
|
||||
|
||||
|
||||
@@ -263,8 +262,8 @@ int FFmpegDecoderVideo::convert(AVPictur
|
||||
#ifdef USE_SWSCALE
|
||||
if (m_swscale_ctx==0)
|
||||
{
|
||||
- m_swscale_ctx = sws_getContext(src_width, src_height, (PixelFormat) src_pix_fmt,
|
||||
- src_width, src_height, (PixelFormat) dst_pix_fmt,
|
||||
+ m_swscale_ctx = sws_getContext(src_width, src_height, (AVPixelFormat) src_pix_fmt,
|
||||
+ src_width, src_height, (AVPixelFormat) dst_pix_fmt,
|
||||
/*SWS_BILINEAR*/ SWS_BICUBIC, NULL, NULL, NULL);
|
||||
}
|
||||
|
||||
@@ -311,14 +310,14 @@ void FFmpegDecoderVideo::publishFrame(co
|
||||
AVPicture * const dst = (AVPicture *) m_frame_rgba.get();
|
||||
|
||||
// Assign appropriate parts of the buffer to image planes in m_frame_rgba
|
||||
- avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[m_writeBuffer])[0], PIX_FMT_RGB24, width(), height());
|
||||
+ avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[m_writeBuffer])[0], AV_PIX_FMT_RGB24, width(), height());
|
||||
|
||||
// Convert YUVA420p (i.e. YUV420p plus alpha channel) using our own routine
|
||||
|
||||
- if (m_context->pix_fmt == PIX_FMT_YUVA420P)
|
||||
+ if (m_context->pix_fmt == AV_PIX_FMT_YUVA420P)
|
||||
yuva420pToRgba(dst, src, width(), height());
|
||||
else
|
||||
- convert(dst, PIX_FMT_RGB24, src, m_context->pix_fmt, width(), height());
|
||||
+ convert(dst, AV_PIX_FMT_RGB24, src, m_context->pix_fmt, width(), height());
|
||||
|
||||
// Wait 'delay' seconds before publishing the picture.
|
||||
int i_delay = static_cast<int>(delay * 1000000 + 0.5);
|
||||
@@ -345,7 +344,7 @@ void FFmpegDecoderVideo::publishFrame(co
|
||||
|
||||
void FFmpegDecoderVideo::yuva420pToRgba(AVPicture * const dst, AVPicture * const src, int width, int height)
|
||||
{
|
||||
- convert(dst, PIX_FMT_RGB24, src, m_context->pix_fmt, width, height);
|
||||
+ convert(dst, AV_PIX_FMT_RGB24, src, m_context->pix_fmt, width, height);
|
||||
|
||||
const size_t bpp = 4;
|
||||
|
||||
@@ -363,31 +362,28 @@ void FFmpegDecoderVideo::yuva420pToRgba(
|
||||
}
|
||||
}
|
||||
|
||||
-
|
||||
-
|
||||
-int FFmpegDecoderVideo::getBuffer(AVCodecContext * const context, AVFrame * const picture)
|
||||
+int FFmpegDecoderVideo::getBuffer(AVCodecContext * const context, AVFrame * const picture, int flags)
|
||||
{
|
||||
+ AVBufferRef *ref;
|
||||
const FFmpegDecoderVideo * const this_ = reinterpret_cast<const FFmpegDecoderVideo*>(context->opaque);
|
||||
|
||||
- const int result = avcodec_default_get_buffer(context, picture);
|
||||
+ const int result = avcodec_default_get_buffer2(context, picture, flags);
|
||||
int64_t * p_pts = reinterpret_cast<int64_t*>( av_malloc(sizeof(int64_t)) );
|
||||
|
||||
*p_pts = this_->m_packet_pts;
|
||||
picture->opaque = p_pts;
|
||||
|
||||
+ ref = av_buffer_create((uint8_t *)picture->opaque, sizeof(int64_t), FFmpegDecoderVideo::freeBuffer, picture->buf[0], flags);
|
||||
+ picture->buf[0] = ref;
|
||||
+
|
||||
return result;
|
||||
}
|
||||
|
||||
-
|
||||
-
|
||||
-void FFmpegDecoderVideo::releaseBuffer(AVCodecContext * const context, AVFrame * const picture)
|
||||
+void FFmpegDecoderVideo::freeBuffer(void *opaque, uint8_t *data)
|
||||
{
|
||||
- if (picture != 0)
|
||||
- av_freep(&picture->opaque);
|
||||
-
|
||||
- avcodec_default_release_buffer(context, picture);
|
||||
+ AVBufferRef *ref = (AVBufferRef *)opaque;
|
||||
+ av_buffer_unref(&ref);
|
||||
+ av_free(data);
|
||||
}
|
||||
|
||||
-
|
||||
-
|
||||
} // namespace osgFFmpeg
|
||||
--- openscenegraph-3.2.1.orig/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.hpp
|
||||
+++ openscenegraph-3.2.1/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.hpp
|
||||
@@ -94,8 +94,8 @@ private:
|
||||
int src_pix_fmt, int src_width, int src_height);
|
||||
|
||||
|
||||
- static int getBuffer(AVCodecContext * context, AVFrame * picture);
|
||||
- static void releaseBuffer(AVCodecContext * context, AVFrame * picture);
|
||||
+ static int getBuffer(AVCodecContext * context, AVFrame * picture, int flags);
|
||||
+ static void freeBuffer(void * opaque, uint8_t *data);
|
||||
|
||||
PacketQueue & m_packets;
|
||||
FFmpegClocks & m_clocks;
|
||||
--- openscenegraph-3.2.1.orig/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegParameters.cpp
|
||||
+++ openscenegraph-3.2.1/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegParameters.cpp
|
||||
@@ -19,7 +19,7 @@ extern "C"
|
||||
#include <libavutil/pixdesc.h>
|
||||
}
|
||||
|
||||
-inline PixelFormat osg_av_get_pix_fmt(const char *name) { return av_get_pix_fmt(name); }
|
||||
+inline AVPixelFormat osg_av_get_pix_fmt(const char *name) { return av_get_pix_fmt(name); }
|
||||
|
||||
|
||||
namespace osgFFmpeg {
|
||||
--- src/OpenSceneGraph-3.4.0/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp.orig 2016-02-18 21:25:39.627923629 +0000
|
||||
+++ src/OpenSceneGraph-3.4.0/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp 2016-02-18 21:26:17.071140100 +0000
|
||||
@@ -227,8 +227,7 @@
|
||||
if (avcodec_open2(m_context, p_codec, NULL) < 0)
|
||||
throw std::runtime_error("avcodec_open() failed");
|
||||
|
||||
- m_context->get_buffer = avcodec_default_get_buffer;
|
||||
- m_context->release_buffer = avcodec_default_release_buffer;
|
||||
+ m_context->get_buffer2 = avcodec_default_get_buffer2;
|
||||
|
||||
}
|
||||
|
Loading…
Reference in a new issue