mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
removed extra/ghostscript
This commit is contained in:
parent
9789687018
commit
c272f45051
2 changed files with 0 additions and 107 deletions
|
@ -1,82 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: AndyRTR <andyrtr@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - build v7 and v8 with -fPIC
|
||||
|
||||
pkgname=ghostscript
|
||||
pkgver=9.22
|
||||
pkgrel=1
|
||||
pkgdesc="An interpreter for the PostScript language"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('AGPL' 'custom')
|
||||
depends=('libxt' 'libcups' 'fontconfig' 'zlib' 'libpng' 'libjpeg'
|
||||
'jbig2dec' 'libtiff' 'lcms2' 'dbus' 'libpaper' 'ijs')
|
||||
makedepends=('gtk3' 'gnutls')
|
||||
optdepends=('texlive-core: needed for dvipdf'
|
||||
'gtk3: needed for gsx')
|
||||
url="http://www.ghostscript.com/"
|
||||
source=(https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${pkgver/./}/ghostscript-${pkgver}.tar.xz
|
||||
ghostscript-sys-zlib.patch)
|
||||
options=('!makeflags')
|
||||
# https://github.com/ArtifexSoftware/ghostpdl-downloads/releases
|
||||
sha256sums=('c1f862e6f40f997dbe3feba89355e8cb05d55818994e10f4932b0dd9b627d1bb'
|
||||
'c08c7e1354aaa243e753517c61ff86a799a49e0177c7bf6fe0029abc693386f6')
|
||||
|
||||
prepare() {
|
||||
cd ghostscript-${pkgver}
|
||||
# fix build with system zlib
|
||||
patch -Np1 -i ${srcdir}/ghostscript-sys-zlib.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ghostscript-${pkgver}
|
||||
|
||||
[[ $CARCH == "armv7h" || $CARCH == "aarch64" ]] && CFLAGS+=" -fPIC" && CXXFLAGS+=" -fPIC"
|
||||
|
||||
# force it to use system-libs
|
||||
# keep heavily patched included openjpeg, leads to segfault with system openjpeg
|
||||
# https://bugs.archlinux.org/task/38226
|
||||
rm -rfv cups/libs freetype ijs jbig2dec jpeg lcms2 libpng tiff zlib
|
||||
|
||||
autoconf --force
|
||||
|
||||
./configure --prefix=/usr \
|
||||
--enable-dynamic \
|
||||
--with-ijs \
|
||||
--with-jbig2dec \
|
||||
--without-omni \
|
||||
--with-x \
|
||||
--with-drivers=ALL\
|
||||
--with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
|
||||
--enable-fontconfig \
|
||||
--enable-freetype \
|
||||
--enable-openjpeg \
|
||||
--without-luratech \
|
||||
--with-system-libtiff \
|
||||
--with-libpaper \
|
||||
--disable-compile-inits #--help # needed for linking with system-zlib
|
||||
make so
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ghostscript-${pkgver}
|
||||
make DESTDIR="${pkgdir}" \
|
||||
cups_serverroot="${pkgdir}"/etc/cups \
|
||||
cups_serverbin="${pkgdir}"/usr/lib/cups install install-so
|
||||
|
||||
# drop full libs linked gs, prefer gsc dynamically linked against libgs; FS#50422
|
||||
ln -sf /usr/bin/gsc "${pkgdir}"/usr/bin/gs
|
||||
|
||||
# install missing doc files # http://bugs.archlinux.org/task/18023
|
||||
install -m 644 "${srcdir}"/ghostscript-${pkgver}/doc/{VectorDevices.htm,gs-vms.hlp,gsdoc.el,pscet_status.txt} "${pkgdir}"/usr/share/ghostscript/$pkgver/doc/
|
||||
|
||||
install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
|
||||
|
||||
# remove unwanted localized man-pages
|
||||
rm -rf "$pkgdir"/usr/share/man/[^man1]*
|
||||
|
||||
# remove filters that are now maintained in cups-filters as upstream home
|
||||
rm -rf "$pkgdir"/usr/lib/cups/filter/{gstopxl,gstoraster}
|
||||
}
|
|
@ -1,25 +0,0 @@
|
|||
diff -up ghostscript-9.12/configure.ac.sys-zlib ghostscript-9.12/configure.ac
|
||||
--- ghostscript-9.12/configure.ac.sys-zlib 2014-03-26 11:48:54.983972222 +0000
|
||||
+++ ghostscript-9.12/configure.ac 2014-03-26 11:49:36.807230531 +0000
|
||||
@@ -854,7 +854,7 @@ AC_MSG_CHECKING([for local zlib source])
|
||||
dnl zlib is needed for language level 3, and libpng
|
||||
# we must define ZLIBDIR regardless because png.mak does a -I$(ZLIBDIR)
|
||||
# this seems a harmless default
|
||||
-ZLIBDIR=src
|
||||
+ZLIBDIR=$includedir
|
||||
AUX_SHARED_ZLIB=
|
||||
|
||||
if test -d $srcdir/zlib; then
|
||||
diff -up ghostscript-9.12/configure.sys-zlib ghostscript-9.12/configure
|
||||
--- ghostscript-9.12/configure.sys-zlib 2014-03-26 11:49:45.547284521 +0000
|
||||
+++ ghostscript-9.12/configure 2014-03-26 11:49:56.171350127 +0000
|
||||
@@ -6254,7 +6254,7 @@ fi
|
||||
$as_echo_n "checking for local zlib source... " >&6; }
|
||||
# we must define ZLIBDIR regardless because png.mak does a -I$(ZLIBDIR)
|
||||
# this seems a harmless default
|
||||
-ZLIBDIR=src
|
||||
+ZLIBDIR=$includedir
|
||||
AUX_SHARED_ZLIB=
|
||||
|
||||
if test -d $srcdir/zlib; then
|
||||
|
Loading…
Reference in a new issue