diff --git a/community/rust/PKGBUILD b/community/rust/PKGBUILD
index bf3251d33..8887a84e5 100644
--- a/community/rust/PKGBUILD
+++ b/community/rust/PKGBUILD
@@ -23,7 +23,7 @@ install=rust.install
 options=(staticlibs)
 
 build() {
-  cd rust-nightly
+  cd rust-$pkgver
 
   ./configure --prefix=/usr --disable-docs --disable-rpath --disable-verify-install --enable-local-rust --local-rust-root=/usr
 
@@ -34,12 +34,12 @@ build() {
 }
 
 #check() {
-  #cd rust-nightly
+  #cd rust-$pkgver
   #make check
 #}
 
 package() {
-  cd rust-nightly
+  cd rust-$pkgver
   make DESTDIR="$pkgdir" install
 
   mkdir -p "$pkgdir/usr/share/vim" "$pkgdir/usr/share/licenses/$pkgname"