core/linux-armv5-rc to 4.16.rc3-1

This commit is contained in:
Kevin Mihelich 2018-02-27 01:43:53 +00:00
parent 739d69ed85
commit c35a6c1ba9
13 changed files with 1333 additions and 146 deletions

View file

@ -1,7 +1,7 @@
From 66234f0fc645a26b57c9101b1b4c2ef6176dc1b1 Mon Sep 17 00:00:00 2001
From 53e7e1b9714a896948d4443ccd8672973a197b18 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 1/3] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 1/9] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
@ -91,5 +91,5 @@ index 309b88acd3d0..7bc9feb891a1 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.15.0
2.16.1

View file

@ -1,7 +1,7 @@
From 8b607cf0243c52c2d5528080c3f4b89453d562ae Mon Sep 17 00:00:00 2001
From f2c457ee01dff99f52b53c13f9287480a4495518 Mon Sep 17 00:00:00 2001
From: Douglas Gilbert <[mailto:dgilbert@interlog.com]>
Date: Mon, 12 Aug 2013 10:36:25 -0500
Subject: [PATCH 2/3] at91: ariag25 updates
Subject: [PATCH 2/9] at91: ariag25 updates
v2: dropped at91sam9x5 usart fix, as merged mainline
@ -12,10 +12,10 @@ Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
1 file changed, 36 insertions(+), 3 deletions(-)
diff --git a/arch/arm/boot/dts/at91-ariag25.dts b/arch/arm/boot/dts/at91-ariag25.dts
index 1c86537a42a0..2819cc07fdd6 100644
index e3e14b7e25aa..6fa702d84f14 100644
--- a/arch/arm/boot/dts/at91-ariag25.dts
+++ b/arch/arm/boot/dts/at91-ariag25.dts
@@ -108,7 +108,7 @@
@@ -120,7 +120,7 @@
* following can be overwritten by bootloader:
* for example u-boot 'ftd set' command
*/
@ -24,7 +24,7 @@ index 1c86537a42a0..2819cc07fdd6 100644
status = "okay";
};
@@ -118,13 +118,41 @@
@@ -130,13 +130,41 @@
* Change to "okay" if you need additional serial ports
*/
uart0: serial@f8040000 {
@ -67,7 +67,7 @@ index 1c86537a42a0..2819cc07fdd6 100644
adc0: adc@f804c000 {
status = "okay";
atmel,adc-channels-used = <0xf>;
@@ -137,7 +165,7 @@
@@ -149,7 +177,7 @@
pinctrl@fffff400 {
w1_0 {
pinctrl_w1_0: w1_0-0 {
@ -76,7 +76,7 @@ index 1c86537a42a0..2819cc07fdd6 100644
};
};
};
@@ -145,6 +173,11 @@
@@ -157,6 +185,11 @@
rtc@fffffeb0 {
status = "okay";
};
@ -89,5 +89,5 @@ index 1c86537a42a0..2819cc07fdd6 100644
usb0: ohci@600000 {
--
2.15.0
2.16.1

View file

@ -1,7 +1,7 @@
From c49c5e6bfcaf363450586dd20e67dacdee96a775 Mon Sep 17 00:00:00 2001
From 13ac2aaac652fe638aee16ce69393e03177b27e3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 13 Jun 2015 13:46:30 -0600
Subject: [PATCH 3/3] at91: arietta-g25 support
Subject: [PATCH 3/9] at91: arietta-g25 support
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -13,10 +13,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
create mode 100644 arch/arm/boot/dts/at91-arietta256.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index d0381e9caf21..b2dc7069634b 100644
index ade7a38543dc..b5939b43ae3a 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -37,6 +37,8 @@ dtb-$(CONFIG_SOC_AT91SAM9) += \
@@ -35,6 +35,8 @@ dtb-$(CONFIG_SOC_AT91SAM9) += \
at91sam9n12ek.dtb \
at91sam9rlek.dtb \
at91-ariag25.dtb \
@ -368,5 +368,5 @@ index 000000000000..cf18f869611a
+
+};
--
2.15.0
2.16.1

View file

@ -0,0 +1,112 @@
From 4058a4acb326b16fdde72d35d16930efaf7eecdd Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:32:06 -0700
Subject: [PATCH 4/9] leds: trigger: Introduce a SATA trigger
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
drivers/leds/trigger/Kconfig | 6 ++++++
drivers/leds/trigger/Makefile | 1 +
drivers/leds/trigger/ledtrig-sata.c | 43 +++++++++++++++++++++++++++++++++++++
include/linux/leds.h | 6 ++++++
4 files changed, 56 insertions(+)
create mode 100644 drivers/leds/trigger/ledtrig-sata.c
diff --git a/drivers/leds/trigger/Kconfig b/drivers/leds/trigger/Kconfig
index a2559b4fdfff..592f942e0300 100644
--- a/drivers/leds/trigger/Kconfig
+++ b/drivers/leds/trigger/Kconfig
@@ -41,6 +41,12 @@ config LEDS_TRIGGER_DISK
This allows LEDs to be controlled by disk activity.
If unsure, say Y.
+config LEDS_TRIGGER_SATA
+ bool "LED SATA Disk Trigger for Kirkwood SOC"
+ depends on LEDS_TRIGGERS
+ help
+ This allows LEDs to be controlled by IDE disk activity.
+
config LEDS_TRIGGER_MTD
bool "LED MTD (NAND/NOR) Trigger"
depends on MTD
diff --git a/drivers/leds/trigger/Makefile b/drivers/leds/trigger/Makefile
index f3cfe1950538..f294704a3ebe 100644
--- a/drivers/leds/trigger/Makefile
+++ b/drivers/leds/trigger/Makefile
@@ -2,6 +2,7 @@
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
obj-$(CONFIG_LEDS_TRIGGER_ONESHOT) += ledtrig-oneshot.o
obj-$(CONFIG_LEDS_TRIGGER_DISK) += ledtrig-disk.o
+obj-$(CONFIG_LEDS_TRIGGER_SATA) += ledtrig-sata.o
obj-$(CONFIG_LEDS_TRIGGER_MTD) += ledtrig-mtd.o
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
diff --git a/drivers/leds/trigger/ledtrig-sata.c b/drivers/leds/trigger/ledtrig-sata.c
new file mode 100644
index 000000000000..f1798f43666f
--- /dev/null
+++ b/drivers/leds/trigger/ledtrig-sata.c
@@ -0,0 +1,43 @@
+/*
+ * LED SATA-Disk Activity Trigger
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 as
+ * published by the Free Software Foundation.
+ *
+ */
+
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/leds.h>
+
+#define BLINK_DELAY 30
+
+DEFINE_LED_TRIGGER(ledtrig_sata1);
+DEFINE_LED_TRIGGER(ledtrig_sata2);
+
+void ledtrig_sata_activity(int port_number)
+{
+ unsigned long sata_blink_delay = BLINK_DELAY;
+
+ switch (port_number) {
+ case 0:
+ led_trigger_blink_oneshot(ledtrig_sata1, &sata_blink_delay, &sata_blink_delay, 0);
+ break;
+ case 1:
+ led_trigger_blink_oneshot(ledtrig_sata2, &sata_blink_delay, &sata_blink_delay, 0);
+ break;
+ default:
+ break;
+ }
+}
+EXPORT_SYMBOL(ledtrig_sata_activity);
+
+static int __init ledtrig_sata_init(void)
+{
+ led_trigger_register_simple("sata-disk1", &ledtrig_sata1);
+ led_trigger_register_simple("sata-disk2", &ledtrig_sata2);
+
+ return 0;
+}
+device_initcall(ledtrig_sata_init);
diff --git a/include/linux/leds.h b/include/linux/leds.h
index 5579c64c8fd6..77fd36d6173e 100644
--- a/include/linux/leds.h
+++ b/include/linux/leds.h
@@ -351,6 +351,12 @@ extern void ledtrig_disk_activity(void);
static inline void ledtrig_disk_activity(void) {}
#endif
+#ifdef CONFIG_LEDS_TRIGGER_SATA
+extern void ledtrig_sata_activity(int port_number);
+#else
+static inline void ledtrig_sata_activity(int port_number) {}
+#endif
+
#ifdef CONFIG_LEDS_TRIGGER_MTD
extern void ledtrig_mtd_activity(void);
#else
--
2.16.1

View file

@ -0,0 +1,34 @@
From 2b2fd91a42c24c563254942524caac40075af186 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:34:33 -0700
Subject: [PATCH 5/9] ata: sata_mv: Add SATA activity LED trigger support
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
drivers/ata/sata_mv.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/drivers/ata/sata_mv.c b/drivers/ata/sata_mv.c
index 42d4589b43d4..cd3cdd5efc8b 100644
--- a/drivers/ata/sata_mv.c
+++ b/drivers/ata/sata_mv.c
@@ -72,6 +72,7 @@
#include <scsi/scsi_cmnd.h>
#include <scsi/scsi_device.h>
#include <linux/libata.h>
+#include <linux/leds.h>
#define DRV_NAME "sata_mv"
#define DRV_VERSION "1.28"
@@ -1175,6 +1176,8 @@ static void mv_start_edma(struct ata_port *ap, void __iomem *port_mmio,
{
int want_ncq = (protocol == ATA_PROT_NCQ);
+ ledtrig_sata_activity(ap->port_no);
+
if (pp->pp_flags & MV_PP_FLAG_EDMA_EN) {
int using_ncq = ((pp->pp_flags & MV_PP_FLAG_NCQ_EN) != 0);
if (want_ncq != using_ncq)
--
2.16.1

View file

@ -0,0 +1,26 @@
From 8050b13e64804c199257e2b7cb21606958b34cca Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:37:08 -0700
Subject: [PATCH 6/9] ARM: dts: kirkwood-pogo_e02: Set health LED to default-on
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
arch/arm/boot/dts/kirkwood-pogo_e02.dts | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/kirkwood-pogo_e02.dts b/arch/arm/boot/dts/kirkwood-pogo_e02.dts
index a190080c9c4f..13eccf28003b 100644
--- a/arch/arm/boot/dts/kirkwood-pogo_e02.dts
+++ b/arch/arm/boot/dts/kirkwood-pogo_e02.dts
@@ -38,7 +38,7 @@
health {
label = "pogo_e02:green:health";
gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
- default-state = "keep";
+ default-state = "default-on";
};
fault {
label = "pogo_e02:orange:fault";
--
2.16.1

View file

@ -0,0 +1,70 @@
From ca12692bcff940e7be7e7c3d102d6b17418f550f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:38:04 -0700
Subject: [PATCH 7/9] Fix mvsdio SD card detection
Helps SD card detection on PPv4.
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
drivers/mmc/core/core.c | 2 +-
drivers/mmc/core/sd.c | 9 +++++++++
drivers/mmc/host/mvsdio.c | 2 ++
3 files changed, 12 insertions(+), 1 deletion(-)
diff --git a/drivers/mmc/core/core.c b/drivers/mmc/core/core.c
index c0ba6d8823b7..281a2feb2a6a 100644
--- a/drivers/mmc/core/core.c
+++ b/drivers/mmc/core/core.c
@@ -717,7 +717,7 @@ void mmc_set_data_timeout(struct mmc_data *data, const struct mmc_card *card)
*/
limit_us = 3000000;
else
- limit_us = 100000;
+ limit_us = 200000;
/*
* SDHC cards always use these fixed values.
diff --git a/drivers/mmc/core/sd.c b/drivers/mmc/core/sd.c
index 62b84dd8f9fe..7d38988c36df 100644
--- a/drivers/mmc/core/sd.c
+++ b/drivers/mmc/core/sd.c
@@ -358,6 +358,15 @@ int mmc_sd_switch_hs(struct mmc_card *card)
if (!status)
return -ENOMEM;
+ /*
+ * Some SDHC cards, notably those with a Sandisk SD controller
+ * (also found in Kingston products) need a bit of slack
+ * before successfully handling the SWITCH command. So far,
+ * cards identifying themselves as "SD04G" and "SD08G" are
+ * affected
+ */
+ udelay(100);
+
err = mmc_sd_switch(card, 1, 0, 1, status);
if (err)
goto out;
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
index 210247b3d11a..05029d5bd72a 100644
--- a/drivers/mmc/host/mvsdio.c
+++ b/drivers/mmc/host/mvsdio.c
@@ -23,6 +23,7 @@
#include <linux/of_irq.h>
#include <linux/mmc/host.h>
#include <linux/mmc/slot-gpio.h>
+#include <linux/mmc/sd.h>
#include <asm/sizes.h>
#include <asm/unaligned.h>
@@ -149,6 +150,7 @@ static void mvsd_request(struct mmc_host *mmc, struct mmc_request *mrq)
dev_dbg(host->dev, "cmd %d (hw state 0x%04x)\n",
cmd->opcode, mvsd_read(MVSD_HW_STATE));
+ if (cmd->opcode == SD_SWITCH) mdelay(1); /* Voodoo */
cmdreg = MVSD_CMD_INDEX(cmd->opcode);
--
2.16.1

View file

@ -0,0 +1,160 @@
From ee7da1cc44e9e8ab5e0d2069de036caf31f92c45 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:42:40 -0700
Subject: [PATCH 8/9] ARM: dts: kirkwood: Initial support for GoFlex Home
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
arch/arm/boot/dts/Makefile | 1 +
arch/arm/boot/dts/kirkwood-goflexhome.dts | 127 ++++++++++++++++++++++++++++++
2 files changed, 128 insertions(+)
create mode 100644 arch/arm/boot/dts/kirkwood-goflexhome.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index b5939b43ae3a..0eb79c76dedf 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -247,6 +247,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
kirkwood-ds411.dtb \
kirkwood-ds411j.dtb \
kirkwood-ds411slim.dtb \
+ kirkwood-goflexhome.dtb \
kirkwood-goflexnet.dtb \
kirkwood-guruplug-server-plus.dtb \
kirkwood-ib62x0.dtb \
diff --git a/arch/arm/boot/dts/kirkwood-goflexhome.dts b/arch/arm/boot/dts/kirkwood-goflexhome.dts
new file mode 100644
index 000000000000..554716fbf367
--- /dev/null
+++ b/arch/arm/boot/dts/kirkwood-goflexhome.dts
@@ -0,0 +1,127 @@
+/dts-v1/;
+
+#include "kirkwood.dtsi"
+#include "kirkwood-6281.dtsi"
+
+/ {
+ model = "Seagate GoFlex Home";
+ compatible = "seagate,goflexhome", "marvell,kirkwood-88f6281", "marvell,kirkwood";
+
+ memory {
+ device_type = "memory";
+ reg = <0x00000000 0x8000000>;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200n8 earlyprintk root=/dev/sda1 rootdelay=10";
+ stdout-path = &uart0;
+ };
+
+ ocp@f1000000 {
+ pinctrl: pin-controller@10000 {
+ pmx_usb_power_enable: pmx-usb-power-enable {
+ marvell,pins = "mpp29";
+ marvell,function = "gpio";
+ };
+ pmx_led_white: pmx-led_white {
+ marvell,pins = "mpp40";
+ marvell,function = "gpio";
+ };
+ pmx_led_green: pmx-led_green {
+ marvell,pins = "mpp46";
+ marvell,function = "gpio";
+ };
+ pmx_led_orange: pmx-led_orange {
+ marvell,pins = "mpp47";
+ marvell,function = "gpio";
+ };
+ };
+ serial@12000 {
+ status = "ok";
+ };
+
+ sata@80000 {
+ status = "okay";
+ nr-ports = <1>;
+ };
+
+ };
+ gpio-leds {
+ compatible = "gpio-leds";
+ pinctrl-0 = < &pmx_led_orange
+ &pmx_led_green
+ &pmx_led_white
+ >;
+ pinctrl-names = "default";
+
+ health {
+ label = "status:green:health";
+ gpios = <&gpio1 14 GPIO_ACTIVE_LOW>;
+ default-state = "keep";
+ };
+ fault {
+ label = "status:orange:fault";
+ gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
+ };
+ misc {
+ label = "status:white:misc";
+ gpios = <&gpio1 8 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "sata-disk1";
+ };
+ };
+ regulators {
+ compatible = "simple-bus";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ pinctrl-0 = <&pmx_usb_power_enable>;
+ pinctrl-names = "default";
+
+ usb_power: regulator@1 {
+ compatible = "regulator-fixed";
+ reg = <1>;
+ regulator-name = "USB Power";
+ regulator-min-microvolt = <5000000>;
+ regulator-max-microvolt = <5000000>;
+ enable-active-high;
+ regulator-always-on;
+ regulator-boot-on;
+ gpio = <&gpio0 29 GPIO_ACTIVE_HIGH>;
+ };
+ };
+};
+
+&nand {
+ chip-delay = <40>;
+ status = "okay";
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0000000 0x100000>;
+ read-only;
+ };
+
+ partition@100000 {
+ label = "uImage";
+ reg = <0x0100000 0x0600000>;
+ };
+
+ partition@0600000 {
+ label = "root";
+ reg = <0x0600000 0xd800000>;
+ };
+};
+
+&mdio {
+ status = "okay";
+
+ ethphy0: ethernet-phy@0 {
+ reg = <0>;
+ };
+};
+
+&eth0 {
+ status = "okay";
+ ethernet0-port@0 {
+ phy-handle = <&ethphy0>;
+ };
+};
--
2.16.1

View file

@ -0,0 +1,32 @@
From 3f36550294e58750ae9a312753abef976cb28a1e Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:45:51 -0700
Subject: [PATCH 9/9] Revert "vfs,mm: fix a dead loop in
truncate_inode_pages_range()"
This reverts commit c2a9737f45e27d8263ff9643f994bda9bac0b944.
This causes the kernel to not be able to read beyond 8TB on a single
device.
---
mm/filemap.c | 4 ----
1 file changed, 4 deletions(-)
diff --git a/mm/filemap.c b/mm/filemap.c
index 693f62212a59..39fa387ed6e2 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2064,10 +2064,6 @@ static ssize_t generic_file_buffered_read(struct kiocb *iocb,
unsigned int prev_offset;
int error = 0;
- if (unlikely(*ppos >= inode->i_sb->s_maxbytes))
- return 0;
- iov_iter_truncate(iter, inode->i_sb->s_maxbytes);
-
index = *ppos >> PAGE_SHIFT;
prev_index = ra->prev_pos >> PAGE_SHIFT;
prev_offset = ra->prev_pos & (PAGE_SIZE-1);
--
2.16.1

View file

@ -0,0 +1,11 @@
[Trigger]
Type = File
Operation = Install
Operation = Upgrade
Target = boot/zImage
Target = usr/lib/initcpio/*
[Action]
Description = Updating %PKGBASE% initcpios
When = PostTransaction
Exec = /usr/bin/mkinitcpio -p %PKGBASE%

View file

@ -4,7 +4,7 @@
buildarch=2
_rcver=4.16
_rcrel=2
_rcrel=3
pkgbase=linux-armv5-rc
_srcname=linux-${_rcver}-rc${_rcrel}
@ -21,12 +21,28 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'0002-at91-ariag25-updates.patch'
'0003-at91-arietta-g25-support.patch'
'config')
md5sums=('4c7b2e5181d388f9aed3f22435df2239'
'865895d3cb68d16d464b378d219e76bf'
'0a5301696cce975e32f8fec00bc96ba1'
'983e11cc37f22e816eebd47d7a5fb301'
'ea892bb6af6a395785f85ee46ea1ac4c')
'0004-leds-trigger-Introduce-a-SATA-trigger.patch'
'0005-ata-sata_mv-Add-SATA-activity-LED-trigger-support.patch'
'0006-ARM-dts-kirkwood-pogo_e02-Set-health-LED-to-default-.patch'
'0007-Fix-mvsdio-SD-card-detection.patch'
'0008-ARM-dts-kirkwood-Initial-support-for-GoFlex-Home.patch'
'0009-Revert-vfs-mm-fix-a-dead-loop-in-truncate_inode_page.patch'
'config'
'linux.preset'
'99-linux.hook')
md5sums=('32798ed3a73c651cd5e480b39305a750'
'79d6c8426b73e6fb85a26078232c757e'
'5c74b5ef2eae798e64a2b4bfeb4b00bd'
'daf9147c53a1389a85e673d02684922f'
'd16b66207022b40a6779c3c318a9a98b'
'19f6901829b222e2d9e8a041a83ddd9b'
'812a98acbdd6554285afc07a45859509'
'72ccc6d941bfab38b5c35717d20ce088'
'80de7816736a2d43b33c1f07babb1ec0'
'80b9c86e6aa74c09e1bdffe943ae07d6'
'3bf0efaafd28f5af7fdc648b5061582a'
'8cdd0d4cfd60b1af0adec5331de181c2'
'79fa396e3f9a09a85156d6d7c2d34b58')
prepare() {
cd "${srcdir}/${_srcname}"
@ -35,6 +51,12 @@ prepare() {
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
git apply ../0002-at91-ariag25-updates.patch
git apply ../0003-at91-arietta-g25-support.patch
git apply ../0004-leds-trigger-Introduce-a-SATA-trigger.patch
git apply ../0005-ata-sata_mv-Add-SATA-activity-LED-trigger-support.patch
git apply ../0006-ARM-dts-kirkwood-pogo_e02-Set-health-LED-to-default-.patch
git apply ../0007-Fix-mvsdio-SD-card-detection.patch
git apply ../0008-ARM-dts-kirkwood-Initial-support-for-GoFlex-Home.patch
git apply ../0009-Revert-vfs-mm-fix-a-dead-loop-in-truncate_inode_page.patch
cat "${srcdir}/config" > ./.config
@ -103,6 +125,17 @@ _package() {
-e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
-i "${startdir}/${pkgname}.install"
# install mkinitcpio preset file for kernel
install -D -m644 "${srcdir}/linux.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
sed \
-e "1s|'linux.*'|'${pkgbase}'|" \
-e "s|ALL_kver=.*|ALL_kver=\"${_kernver}\"|" \
-i "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
# install pacman hook for initramfs regeneration
sed "s|%PKGBASE%|${pkgbase}|g" "${srcdir}/99-linux.hook" |
install -D -m644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/99-${pkgbase}.hook"
# remove build and source links
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
# remove the firmware

File diff suppressed because it is too large Load diff

View file

@ -0,0 +1,10 @@
# mkinitcpio preset file for the linux-armv5-rc package
ALL_config="/etc/mkinitcpio.conf"
ALL_kver="4.10.0-1-ARCH"
PRESETS=('default')
#default_config="/etc/mkinitcpio.conf"
default_image="/boot/initramfs-linux.img"
#default_options=""