added extra/thunderbird

This commit is contained in:
Kevin Mihelich 2013-06-25 16:41:43 +00:00
parent d7e4bb1b23
commit c370d733bd
6 changed files with 202 additions and 0 deletions

View file

@ -0,0 +1,76 @@
# $Id$
# Maintainer : Ionut Biru <ibiru@archlinux.org>
# Contributor: Alexander Baldeck <alexander@archlinux.org>
# Contributor: Dale Blount <dale@archlinux.org>
# Contributor: Anders Bostrom <anders.bostrom@home.se>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - mozconfig changes for ARM
buildarch=20
highmem=1
pkgname=thunderbird
pkgver=17.0.6
pkgrel=1
pkgdesc="Standalone Mail/News reader"
arch=('i686' 'x86_64')
license=('MPL' 'GPL')
url="http://www.mozilla.org/thunderbird/"
depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libnotify' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'nss' 'sqlite' 'startup-notification')
makedepends=('unzip' 'zip' 'pkg-config' 'python2' 'wireless_tools' 'yasm' 'mesa' 'autoconf2.13')
optdepends=('libcanberra: for sound support')
install=thunderbird.install
source=(ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.bz2
mozconfig
thunderbird.desktop
thunderbird-install-dir.patch
vendor.js)
options=(!emptydirs)
sha256sums=('be4dc30abec38e323ba758584a381644c2ca2b4511b61f4c55edabba3b77ec01'
'02b3cf36887074ffcafc88ec80c787106bf8258ab1a661a09593bef7e9795d3f'
'd506b771e765e09e2e039b975e25befade8eec97e8950813a32463604955ab4e'
'929a7ceca0e90d0635a2099b7df24033e865fb5b5b8c5824468c4561c21c377d'
'e4ea8e6788163d9f8db8f1f40023db3ea0a1358f9a4510169f2d4c4fe6a887ed')
prepare() {
cd comm-esr17
patch -Np1 -i "$srcdir/thunderbird-install-dir.patch"
cp "$srcdir/mozconfig" .mozconfig
# configure script misdetects the preprocessor without an optimization level
# https://bugs.archlinux.org/task/34644
sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' configure
}
build() {
cd comm-esr17
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/thunderbird"
export PYTHON="/usr/bin/python2"
make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS"
}
package() {
cd comm-esr17
make -j1 -f client.mk DESTDIR="$pkgdir" install
install -Dm644 "$srcdir"/vendor.js "$pkgdir/usr/lib/thunderbird/defaults/preferences/vendor.js"
for i in 16x16 22x22 24x24 32x32 48x48 256x256; do
install -Dm644 other-licenses/branding/thunderbird/mailicon${i/x*/}.png \
"$pkgdir/usr/share/icons/hicolor/$i/apps/thunderbird.png"
done
install -Dm644 "$srcdir/thunderbird.desktop" \
"$pkgdir/usr/share/applications/thunderbird.desktop"
rm -rf "$pkgdir"/usr/lib/thunderbird/{dictionaries,hyphenation}
ln -sf /usr/share/hunspell "$pkgdir/usr/lib/thunderbird/dictionaries"
ln -sf /usr/share/hyphen "$pkgdir/usr/lib/thunderbird/hyphenation"
# We don't want the development stuff
rm -r "$pkgdir"/usr/{include,lib/thunderbird-devel,share/idl}
}

View file

@ -0,0 +1,45 @@
mk_add_options MOZ_CO_PROJECT=mail
ac_add_options --enable-application=mail
ac_add_options --prefix=/usr
ac_add_options --libdir=/usr/lib
# ALARM
ac_add_options --disable-elf-hack
ac_add_options --disable-neon
ac_add_options --disable-webrtc
# System libraries
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
ac_add_options --with-system-png
ac_add_options --with-system-libevent
ac_add_options --with-system-libvpx
ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
#ac_add_options --enable-system-cairo
ac_add_options --enable-system-pixman
ac_add_options --with-pthreads
# Features
ac_add_options --enable-official-branding
ac_add_options --enable-safe-browsing
ac_add_options --enable-startup-notification
ac_add_options --enable-gio
ac_add_options --disable-gnomevfs
ac_add_options --disable-crashreporter
ac_add_options --disable-updater
ac_add_options --disable-tests
ac_add_options --disable-mochitest
ac_add_options --disable-installer
# Optimization
ac_add_options --enable-optimize
export MOZILLA_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1

View file

@ -0,0 +1,47 @@
diff -upr comm-release.orig/config/baseconfig.mk comm-release/config/baseconfig.mk
--- comm-release.orig/config/baseconfig.mk 2012-11-21 03:19:15.000000000 +0200
+++ comm-release/config/baseconfig.mk 2012-11-21 03:20:35.000000000 +0200
@@ -1,9 +1,9 @@
INCLUDED_AUTOCONF_MK = 1
-includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
+includedir := $(includedir)/$(MOZ_APP_NAME)
+idldir = $(datadir)/idl/$(MOZ_APP_NAME)
+installdir = $(libdir)/$(MOZ_APP_NAME)
+sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel
MOZILLA_SRCDIR = $(topsrcdir)/mozilla
MOZDEPTH = $(DEPTH)/mozilla
DIST = $(MOZDEPTH)/dist
diff -upr comm-release.orig/mozilla/config/baseconfig.mk comm-release/mozilla/config/baseconfig.mk
--- comm-release.orig/mozilla/config/baseconfig.mk 2012-11-21 03:19:16.000000000 +0200
+++ comm-release/mozilla/config/baseconfig.mk 2012-11-21 03:19:20.000000000 +0200
@@ -1,9 +1,9 @@
INCLUDED_AUTOCONF_MK = 1
-includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
+includedir := $(includedir)/$(MOZ_APP_NAME)
+idldir = $(datadir)/idl/$(MOZ_APP_NAME)
+installdir = $(libdir)/$(MOZ_APP_NAME)
+sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel
DIST = $(DEPTH)/dist
# We do magic with OBJ_SUFFIX in config.mk, the following ensures we don't
diff -upr comm-release.orig/mozilla/js/src/config/baseconfig.mk comm-release/mozilla/js/src/config/baseconfig.mk
--- comm-release.orig/mozilla/js/src/config/baseconfig.mk 2012-11-21 03:19:15.000000000 +0200
+++ comm-release/mozilla/js/src/config/baseconfig.mk 2012-11-21 03:19:20.000000000 +0200
@@ -1,7 +1,7 @@
INCLUDED_AUTOCONF_MK = 1
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
+installdir = $(libdir)/$(MOZ_APP_NAME)
+sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel
ifneq (,$(filter /%,$(TOP_DIST)))
DIST = $(TOP_DIST)

View file

@ -0,0 +1,13 @@
[Desktop Entry]
Version=1.0
Name=Thunderbird
Comment=Mail & News Reader
GenericName=Mail Client & News Reader
Exec=thunderbird %u
TryExec=thunderbird
Icon=thunderbird
Terminal=false
Type=Application
Categories=Network;Email;
MimeType=message/rfc822;x-scheme-handler/mailto;
StartupNotify=true

View file

@ -0,0 +1,12 @@
post_install() {
update-desktop-database -q
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}

View file

@ -0,0 +1,9 @@
// Use LANG environment variable to choose locale
pref("intl.locale.matchOS", true);
// Disable default mailer checking.
pref("mail.shell.checkDefaultMail", false);
// Don't disable our bundled extensions in the application directory
pref("extensions.autoDisableScopes", 11);
pref("extensions.shownSelectionUI", true);