mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
removed extra/ilmbase
This commit is contained in:
parent
3b9ca9dcb3
commit
c390a05c9c
5 changed files with 0 additions and 108 deletions
|
@ -1,52 +0,0 @@
|
|||
# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
|
||||
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - ARM patch from https://github.com/openexr/openexr/issues/29
|
||||
|
||||
pkgname=ilmbase
|
||||
pkgver=2.1.0
|
||||
pkgrel=1
|
||||
depends=('gcc-libs')
|
||||
pkgdesc="Base libraries from ILM for OpenEXR"
|
||||
arch=(i686 x86_64)
|
||||
url="http://www.openexr.com"
|
||||
license=('custom')
|
||||
source=(http://download.savannah.nongnu.org/releases/openexr/$pkgname-$pkgver.tar.gz
|
||||
ilmbase-2.0.1-no_undefined.patch
|
||||
ilmbase-1.0.3-pkgconfig.patch
|
||||
arm.patch)
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/$pkgname-$pkgver"
|
||||
|
||||
patch -p1 -i ../arm.patch
|
||||
|
||||
# patches from fedora
|
||||
patch -p1 -i ../ilmbase-2.0.1-no_undefined.patch
|
||||
patch -p1 -i ../ilmbase-1.0.3-pkgconfig.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/$pkgname-$pkgver"
|
||||
./configure --prefix=/usr
|
||||
# manually set PTHREAD_LIBS to include -lpthread until libtool bogosity is fixed,
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=661333
|
||||
make PTHREAD_LIBS="-pthread -lpthread"
|
||||
}
|
||||
|
||||
check() {
|
||||
cd "${srcdir}/$pkgname-$pkgver"
|
||||
# one of the tests fails randomly for an unknown reason
|
||||
make check || true
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/$pkgname-$pkgver"
|
||||
make DESTDIR="${pkgdir}" install
|
||||
install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
|
||||
}
|
||||
md5sums=('8ba2f608191ad020e50277d8a3ba0850'
|
||||
'27ff3915e03964f85a9e9fb896a93479'
|
||||
'ed3eb3dfa2393adc6829cc9ca8caa0ff'
|
||||
'b652c8106907d867a2f52fe93ac6c5ec')
|
|
@ -1,12 +0,0 @@
|
|||
diff -urN a/IexMath/IexMathFpu.cpp b/IexMath/IexMathFpu.cpp
|
||||
--- a/IexMath/IexMathFpu.cpp 2013-03-06 16:18:50.000000000 -0700
|
||||
+++ b/IexMath/IexMathFpu.cpp 2013-04-20 19:45:33.400749953 -0600
|
||||
@@ -53,7 +53,7 @@
|
||||
#endif
|
||||
|
||||
|
||||
-#ifdef HAVE_UCONTEXT_H
|
||||
+#if defined(HAVE_UCONTEXT_H) && (defined(__x86_64__) || defined(__i386__))
|
||||
|
||||
|
||||
#include <ucontext.h>
|
|
@ -1,8 +0,0 @@
|
|||
diff -up ilmbase-1.0.3/IlmBase.pc.in.pkgconfig ilmbase-1.0.3/IlmBase.pc.in
|
||||
--- ilmbase-1.0.3/IlmBase.pc.in.pkgconfig 2012-07-17 18:27:25.000000000 -0500
|
||||
+++ ilmbase-1.0.3/IlmBase.pc.in 2012-09-08 11:11:15.913468312 -0500
|
||||
@@ -9,3 +9,4 @@ Description: Base math and exception lib
|
||||
Version: @ILMBASE_VERSION@
|
||||
Libs: -L${libdir} -lImath -lHalf -lIex -lIexMath -lIlmThread @PTHREAD_LIBS@
|
||||
Cflags: @PTHREAD_CFLAGS@ -I${OpenEXR_includedir}
|
||||
+Requires.private: gl glu
|
|
@ -1,24 +0,0 @@
|
|||
diff -up ilmbase-2.0.1/IlmThread/Makefile.am.no_undefined ilmbase-2.0.1/IlmThread/Makefile.am
|
||||
--- ilmbase-2.0.1/IlmThread/Makefile.am.no_undefined 2013-06-18 14:51:38.000000000 -0500
|
||||
+++ ilmbase-2.0.1/IlmThread/Makefile.am 2013-08-28 21:04:25.793391766 -0500
|
||||
@@ -14,7 +14,7 @@ libIlmThread_la_LDFLAGS = -version-info
|
||||
if LIB_SUFFIX_EXISTS
|
||||
libIlmThread_la_LDFLAGS += -release @LIB_SUFFIX@
|
||||
endif
|
||||
-libIlmThread_la_LIBADD = ../Iex/libIex.la
|
||||
+libIlmThread_la_LIBADD = ../Iex/libIex.la $(PTHREAD_LIBS)
|
||||
|
||||
libIlmThreadincludedir = $(includedir)/OpenEXR
|
||||
|
||||
diff -up ilmbase-2.0.1/IlmThread/Makefile.in.no_undefined ilmbase-2.0.1/IlmThread/Makefile.in
|
||||
--- ilmbase-2.0.1/IlmThread/Makefile.in.no_undefined 2013-06-18 14:55:24.000000000 -0500
|
||||
+++ ilmbase-2.0.1/IlmThread/Makefile.in 2013-08-28 21:04:55.395049371 -0500
|
||||
@@ -253,7 +253,7 @@ libIlmThread_la_SOURCES = IlmThreadPool.
|
||||
|
||||
libIlmThread_la_LDFLAGS = -version-info @LIBTOOL_VERSION@ \
|
||||
-no-undefined $(am__append_1)
|
||||
-libIlmThread_la_LIBADD = ../Iex/libIex.la
|
||||
+libIlmThread_la_LIBADD = ../Iex/libIex.la $(PTHREAD_LIBS)
|
||||
libIlmThreadincludedir = $(includedir)/OpenEXR
|
||||
libIlmThreadinclude_HEADERS = IlmThreadPool.h IlmThread.h \
|
||||
IlmThreadSemaphore.h IlmThreadMutex.h \
|
|
@ -1,12 +0,0 @@
|
|||
--- IexMath/IexMathFpu.cpp.orig 2012-07-26 20:51:55.000000000 +0200
|
||||
+++ IexMath/IexMathFpu.cpp 2012-10-04 15:30:47.000000000 +0200
|
||||
@@ -27,8 +27,7 @@
|
||||
#endif
|
||||
|
||||
|
||||
-#ifdef HAVE_UCONTEXT_H
|
||||
-
|
||||
+#if defined(HAVE_UCONTEXT_H) && (defined(x86_64) || defined(i386_))
|
||||
|
||||
#include <ucontext.h>
|
||||
#include <signal.h>
|
Loading…
Reference in a new issue