mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/pacman to 6.0.1-3
This commit is contained in:
parent
8b27bea6bd
commit
c3ae32319d
2 changed files with 28 additions and 1 deletions
core/pacman
|
@ -11,7 +11,7 @@
|
|||
|
||||
pkgname=pacman
|
||||
pkgver=6.0.1
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
pkgdesc="A library-based package manager with dependency support"
|
||||
arch=('x86_64')
|
||||
url="https://www.archlinux.org/pacman/"
|
||||
|
@ -29,6 +29,7 @@ options=('strip' 'debug')
|
|||
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
|
||||
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
|
||||
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.xz{,.sig}
|
||||
add-flto-to-LDFLAGS-for-clang.patch
|
||||
0001-Sychronize-filesystem.patch
|
||||
0002-Revert-close-stdin-before-running-install-scripts.patch
|
||||
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
|
||||
|
@ -36,6 +37,7 @@ source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.xz{,.sig
|
|||
makepkg.conf)
|
||||
sha256sums=('0db61456e56aa49e260e891c0b025be210319e62b15521f29d3e93b00d3bf731'
|
||||
'SKIP'
|
||||
'82ff91b85f4c6ceba19f9330437e2a22aabc966c2b9e2a20a53857f98a42c223'
|
||||
'f9a8ae2805cc995ef1b787e10f402d574aaee183cc3a23fe26805555b7d87fea'
|
||||
'7beb2faec0ec37dcb2050d9ed3c95353fb7f73da7e3bbe0e226e9e3f7858a01f'
|
||||
'0fdbdc3c86b826fe87d8051a5d34db23b366b0a7bdc22f3701b1bf2b01218d59'
|
||||
|
@ -44,6 +46,7 @@ sha256sums=('0db61456e56aa49e260e891c0b025be210319e62b15521f29d3e93b00d3bf731'
|
|||
|
||||
prepare() {
|
||||
cd "$pkgname-$pkgver"
|
||||
patch -Np1 -i ../add-flto-to-LDFLAGS-for-clang.patch
|
||||
|
||||
patch -p1 -i ../0001-Sychronize-filesystem.patch
|
||||
patch -p1 -i ../0002-Revert-close-stdin-before-running-install-scripts.patch
|
||||
|
|
24
core/pacman/add-flto-to-LDFLAGS-for-clang.patch
Normal file
24
core/pacman/add-flto-to-LDFLAGS-for-clang.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
From 26ee6ff6adbcd8560ec3a65cf219d2ab98edb804 Mon Sep 17 00:00:00 2001
|
||||
From: Allan McRae <allan@archlinux.org>
|
||||
Date: Fri, 24 Dec 2021 17:59:32 +1000
|
||||
Subject: [PATCH] LTO: Add -flto to LDFLAGS for clang
|
||||
|
||||
GCC automatically detects when it is linking LTO objects, but clang does
|
||||
not. Add -flto to LDFLAGS to make this work for clang too.
|
||||
|
||||
Signed-off-by: Allan McRae <allan@archlinux.org>
|
||||
---
|
||||
scripts/libmakepkg/buildenv/lto.sh.in | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/scripts/libmakepkg/buildenv/lto.sh.in b/scripts/libmakepkg/buildenv/lto.sh.in
|
||||
index 1f1ca53f..c3bd0fa4 100644
|
||||
--- a/scripts/libmakepkg/buildenv/lto.sh.in
|
||||
+++ b/scripts/libmakepkg/buildenv/lto.sh.in
|
||||
@@ -33,5 +33,6 @@ buildenv_lto() {
|
||||
if check_option "lto" "y"; then
|
||||
CFLAGS+=" -flto"
|
||||
CXXFLAGS+=" -flto"
|
||||
+ LDFLAGS+=" -flto"
|
||||
fi
|
||||
}
|
Loading…
Reference in a new issue