added extra/pyqt5

This commit is contained in:
Kevin Mihelich 2014-02-10 04:46:44 +00:00
parent 9da9a9013a
commit c3cfd0e7ca
2 changed files with 139 additions and 0 deletions

118
extra/pyqt5/PKGBUILD Normal file
View file

@ -0,0 +1,118 @@
# $Id$
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Yichao Yu <yyc1992@gmail.com>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix qreal on ARM
pkgbase=pyqt5
pkgname=pyqt5
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
pkgver=5.2
pkgrel=1
arch=('i686' 'x86_64')
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
license=('GPL')
makedepends=('python-sip' 'python2-sip' 'python-opengl' 'python2-opengl'
'python2-dbus' 'python-dbus' 'qt5-multimedia' 'qt5-tools'
'qt5-svg' 'qt5-serialport')
source=("http://downloads.sourceforge.net/project/pyqt/PyQt5/PyQt-${pkgver}/PyQt-gpl-${pkgver}.tar.gz"
'fix_qreal_check.diff')
md5sums=('567a0a72a4e186e9b373c26a9dcf380d'
'8bd96cc390766ad245295c67f9b3c7bf')
prepare() {
cd PyQt-gpl-${pkgver}
patch -p1 -i ../fix_qreal_check.diff
}
build() {
cp -r PyQt-gpl-${pkgver} Py2Qt-gpl-${pkgver}
cd PyQt-gpl-${pkgver}
python3 configure.py \
--confirm-license \
-v /usr/share/sip/PyQt5 \
--qsci-api \
-q /usr/bin/qmake-qt5
# Thanks Gerardo for the rpath fix
find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
make
### Python2 version ###
cd ../Py2Qt-gpl-${pkgver}
python2 configure.py \
--confirm-license \
-v /usr/share/sip/Py2-PyQt5 \
--qsci-api \
-q /usr/bin/qmake-qt5
# Thanks Gerardo for the rpath fix
find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
make
}
package_pyqt5-common(){
pkgdesc="Common PyQt files shared between python-pyqt5 and python2-pyqt5"
depends=('qt5-base')
cd PyQt-gpl-${pkgver}
make -C pyrcc DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
make -C pylupdate DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
install -Dm644 PyQt5.api "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt5.api
}
package_python-pyqt5(){
pkgdesc="A set of Python 3.x bindings for the Qt5 toolkit"
depends=('python-sip' 'pyqt5-common' 'python' 'python')
optdepends=('python-opengl: enable OpenGL 3D graphics in PyQt applications'
'python-dbus: for python-dbus mainloop support'
'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
'qt5-tools: QtHelp, QtDesigner'
'qt5-svg: QtSvg'
'qt5-webkit: QtWebKit, QtWebKitWidgets'
'qt5-xmlpatterns: QtXmlPatterns'
'qt5-declarative: QtQml, qmlplugin'
'qt5-serialport: QtSerialPort')
cd PyQt-gpl-${pkgver}
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
# Provided by pyqt-common
rm "${pkgdir}"/usr/bin/{pylupdate5,pyrcc5}
rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt5.api
}
package_python2-pyqt5(){
pkgdesc="A set of Python 2.x bindings for the Qt5 toolkit"
depends=('python2-sip' 'pyqt5-common' 'python2')
optdepends=('python2-opengl: enable OpenGL 3D graphics in PyQt applications'
'python-dbus: for python-dbus mainloop support'
'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
'qt5-tools: QtHelp, QtDesigner'
'qt5-svg: QtSvg'
'qt5-webkit: QtWebKit, QtWebKitWidgets'
'qt5-xmlpatterns: QtXmlPatterns'
'qt5-declarative: QtQml, qmlplugin'
'qt5-serialport: QtSerialPort')
cd Py2Qt-gpl-${pkgver}
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
# Fix conflicts with python-pyqt5
mv "${pkgdir}"/usr/bin/{,python2-}pyuic5
rm "${pkgdir}"/usr/bin/{pylupdate5,pyrcc5}
rm "${pkgdir}"/usr/lib/qt/plugins/designer/libpyqt5.so
rm "${pkgdir}"/usr/lib/qt/plugins/PyQt5/libpyqt5qmlplugin.so
rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt5.api
}

View file

@ -0,0 +1,21 @@
Description: check if qreal is double based on sizeof
Author: Dmitry Shachnev <mitya57@gmail.com>
Forwarded: no
Last-Update: 2014-01-29
--- a/configure.py
+++ b/configure.py
@@ -481,10 +481,8 @@
out << "PyQt_Desktop_OpenGL\\n";
#endif
-// This is the test used in qglobal.h.
-#if defined(QT_NO_FPU) || defined(Q_PROCESSOR_ARM) || defined(Q_OS_WINCE)
- out << "PyQt_qreal_double\\n";
-#endif
+ if (sizeof (qreal) != sizeof (double))
+ out << "PyQt_qreal_double\\n";
return 0;
}