mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/mkinitcpio to 33-2
This commit is contained in:
parent
0398e47d4a
commit
c3e72be709
2 changed files with 32 additions and 1 deletions
|
@ -0,0 +1,26 @@
|
|||
From eabdad3798b43fa5e9aacd0d0395a74154e56434 Mon Sep 17 00:00:00 2001
|
||||
From: nl6720 <nl6720@gmail.com>
|
||||
Date: Thu, 8 Dec 2022 10:51:49 +0200
|
||||
Subject: [mkinitcpio] [PATCH 1/1] functions: fix overwriting of symlinks with
|
||||
regular files
|
||||
|
||||
Use `cp --remove-destination` in `add_file` to remove the destination
|
||||
file. Without this, if the destination file is an existing symlink, it
|
||||
will be the link target that will get overwritten, not the symlink.
|
||||
---
|
||||
functions | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/functions b/functions
|
||||
index 9939e25..3b3de05 100644
|
||||
--- a/functions
|
||||
+++ b/functions
|
||||
@@ -650,7 +650,7 @@ add_file() {
|
||||
fi
|
||||
if [[ -z "$mode" ]]; then
|
||||
add_dir "${dest%/*}"
|
||||
- command cp -f --preserve=mode,ownership "$src" "${BUILDROOT}${dest}"
|
||||
+ command cp --remove-destination --preserve=mode,ownership "$src" "${BUILDROOT}${dest}"
|
||||
else
|
||||
command install -Dm"$mode" "$src" "${BUILDROOT}${dest}"
|
||||
fi
|
|
@ -10,7 +10,7 @@
|
|||
|
||||
pkgname=mkinitcpio
|
||||
pkgver=33
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="Modular initramfs image creation utility"
|
||||
arch=('any')
|
||||
url='https://github.com/archlinux/mkinitcpio'
|
||||
|
@ -26,21 +26,26 @@ optdepends=('xz: Use lzma or xz compression for the initramfs image'
|
|||
provides=('initramfs')
|
||||
backup=('etc/mkinitcpio.conf')
|
||||
source=("https://sources.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig}
|
||||
'0001-functions-fix-overwriting-of-symlinks-with-regular-f.patch'
|
||||
'0001-use-gzip-for-compression-by-default.patch'
|
||||
'0002-functions-handle-gzip-compressed-kernels-in-kver_gen.patch')
|
||||
install=mkinitcpio.install
|
||||
sha512sums=('13526e749d23f2933db4a9ed74f138b0fafaf9b93f455dcf686b29b950247f0b62f8f6a091d7006c41642b4106bf8bcd666af03ec44a9f0ee7cf2b57b5714cf0'
|
||||
'SKIP'
|
||||
'a43e66101edc301ae893a25eee6caa83c56a790cbac1685697fb999008c8210e46ca49e0700242f8321731264084462641285954db55d3daa2c7e8b62d1cc66c'
|
||||
'711fa620fcd5685e07f19772626eb838f710e8eea8a47c33c48689935e57bfa60f6b420b70fdb351b8222d2fd5310859864be26f640c6d72c486f871dd61d48d'
|
||||
'9f5d0129c93823175b04ec0a42c82fa4cc8adffb8a836773b9b08bb7d28767b1a1810f44b78501f1c501d19abd84a6d9a87d30e0d3e95c8d76f56ee5210fd5f3')
|
||||
b2sums=('1a85152e6ce465e419e87a1915860be83c198f4e7a6ecab44277a68f2f1ecb316c7fed6e8af93b0282b646c2de1a8057831668749788030eb3e5256eeb28979b'
|
||||
'SKIP'
|
||||
'a2ed9e8ff4b6fab1d6f6c1dae4dcf890b4434cb31ebdfe73ea54fd4af499849e2b98e565915cc331bd97f15f21d9147ee0499cf75b516562bfd7f1793e838e99'
|
||||
'5ce998c788e90abb22df2104f9cd58a5707fad2ebad21bf29b7e4e4d3f65cb99b74e3417b93c91c45c72569262403932c5f4af5ac5becf03a8ee2e4f38be2ebf'
|
||||
'8804b5b1594de02e54530f6f07fb8c41d89fef19f597dd34f5fb9bc04b601a466daeffe5474e22d7139b59f20a82ac255301b16bb623e4dc3db1406d3cda6301')
|
||||
validpgpkeys=('ECCAC84C1BA08A6CC8E63FBBF22FB1D78A77AEAB' # Giancarlo Razzolini
|
||||
'C100346676634E80C940FB9E9C02FF419FECBE16') # Morten Linderud
|
||||
|
||||
prepare() {
|
||||
patch -Np1 -d "$pkgname-$pkgver" < '0001-functions-fix-overwriting-of-symlinks-with-regular-f.patch'
|
||||
|
||||
cd $pkgname-$pkgver
|
||||
patch -p1 -i ../0001-use-gzip-for-compression-by-default.patch
|
||||
patch -p1 -i ../0002-functions-handle-gzip-compressed-kernels-in-kver_gen.patch
|
||||
|
|
Loading…
Reference in a new issue