added community/python2-pyqwt

This commit is contained in:
Kevin Mihelich 2015-03-15 16:36:54 +00:00
parent d69210382c
commit c3f10efd53
3 changed files with 481 additions and 0 deletions

View file

@ -0,0 +1,62 @@
# $Id$
# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
# Contributor: Eugen Zagorodniy <e dot zagorodniy at gmail dot com>
# Contributor: Olaf Leidinger <leidola@newcon.de>
# Contributer: Henning Garus <henning.garus@gmail.com>
# Contributor: Thomas Burdick <thomas.burdick@gmail.com>
# Contributor: Kyle Keen <keenerd@gmail.com>
# probably should be a split package to anticipate
# python{2,3}-qwt{5,6}-qt{4,5} permutations
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - replace march/mtune in configure script for ARM
pkgname=python2-pyqwt
pkgver=5.2.0
pkgrel=1
pkgdesc="Python bindings for Qt Widgets for Technical Applications"
arch=("i686" "x86_64")
url="http://pyqwt.sourceforge.net/"
depends=('python2-pyqt' 'python2-numpy' 'qwt5' 'sip')
options=('!makeflags')
license=("GPL")
provides=('pyqwt')
conflicts=('pyqwt')
source=("http://downloads.sourceforge.net/sourceforge/pyqwt/PyQwt-$pkgver.tar.gz"
"qplt.py-r1.21.patch"
"pyqtconfig.py"
)
md5sums=('fcd6c6029090d473dcc9df497516eae7'
'30011f9139ad12ddbeac79c6a45d4b43'
'954bc3020a8b5b164b0f49f2ef1e4a6c')
build() {
cd "$srcdir/PyQwt-$pkgver"
patch -p1 < ../qplt.py-r1.21.patch
cd configure
# pyqtconfig.py came from a modified python2-pyqt4
# version numbers will need tweaking with pyqt updates
cp "$srcdir/pyqtconfig.py" ./
[[ $CARCH == "arm" ]] && sed -i "s|-march=native -mtune=generic|-march=armv5te|g" -i pyqtconfig.py
[[ $CARCH == "armv6h" ]] && sed -i "s|-march=native -mtune=generic|-march=armv6 -mfpu=vfp -mfloat-abi=hard|g" -i pyqtconfig.py
[[ $CARCH == "armv7h" ]] && sed -i "s|-march=native -mtune=generic|-march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard|g" -i pyqtconfig.py
sed -i "s/'qmake'/'qmake-qt4'/" configure.py
sed -i "s/'qwt'/'qwt5'/" configure.py
sed -i "s/PyQt4.pyqtconfig/pyqtconfig/" configure.py
python2 configure.py -I/usr/include/qwt5 -lqwt5 -I/usr/include/qt4 \
--disable-numarray --disable-numeric
sed -i "s|/usr/include/Qt|/usr/include/qt4/Qt|g" iqt5qt4/Makefile
sed -i "s|/usr/include/Qt|/usr/include/qt4/Qt|g" qwt5qt4/Makefile
make
sed -i -e "s|env python$|env python2|" $(find "$srcdir" -name '*.py')
}
package() {
cd "$srcdir/PyQwt-$pkgver/configure"
make DESTDIR="$pkgdir" install
}

View file

@ -0,0 +1,407 @@
# Copyright (c) 2014 Riverbank Computing Limited <info@riverbankcomputing.com>
#
# This file is part of PyQt.
#
# This file may be used under the terms of the GNU General Public
# License versions 2.0 or 3.0 as published by the Free Software
# Foundation and appearing in the files LICENSE.GPL2 and LICENSE.GPL3
# included in the packaging of this file. Alternatively you may (at
# your option) use any later version of the GNU General Public
# License if such license has been publicly approved by Riverbank
# Computing Limited (or its successors, if any) and the KDE Free Qt
# Foundation. In addition, as a special exception, Riverbank gives you
# certain additional rights. These rights are described in the Riverbank
# GPL Exception version 1.1, which can be found in the file
# GPL_EXCEPTION.txt in this package.
#
# If you are unsure which license is appropriate for your use, please
# contact the sales department at sales@riverbankcomputing.com.
#
# This file is provided AS IS with NO WARRANTY OF ANY KIND, INCLUDING THE
# WARRANTY OF DESIGN, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
#
# This module is intended to be used by the configuration scripts of extension
# modules that %Import PyQt4 modules.
import sipconfig
# These are installation specific values created when PyQt4 was configured.
_pkg_config = {
'pyqt_bin_dir': '/usr/bin',
'pyqt_config_args': '--confirm-license --no-sip-files --qsci-api -q /usr/bin/qmake-qt4',
'pyqt_mod_dir': '/usr/lib/python2.7/site-packages/PyQt4',
'pyqt_modules': 'QtCore QtGui QtHelp QtMultimedia QtNetwork QtDBus QtDeclarative QtScript QtScriptTools QtXml QtOpenGL QtSql QtSvg QtTest QtWebKit QtXmlPatterns phonon QtAssistant QtDesigner',
'pyqt_sip_dir': '/usr/share/sip/PyQt4',
'pyqt_sip_flags': '-x VendorID -t WS_X11 -x PyQt_NoPrintRangeBug -t Qt_4_8_6 -x Py_v3 -g',
'pyqt_version': 0x040b03,
'pyqt_version_str': '4.11.3',
'qt_archdata_dir': '/usr/share/qt4',
'qt_data_dir': '/usr/share/qt4',
'qt_dir': '/usr',
'qt_edition': 'free',
'qt_framework': 0,
'qt_inc_dir': '/usr/include/qt4',
'qt_lib_dir': '/usr/lib',
'qt_threaded': 1,
'qt_version': 0x040806,
'qt_winconfig': 'shared'
}
_default_macros = {
'AIX_SHLIB': '',
'AR': 'ar cqs',
'CC': 'gcc',
'CFLAGS': '-pipe',
'CFLAGS_APP': '',
'CFLAGS_CONSOLE': '',
'CFLAGS_DEBUG': '-g',
'CFLAGS_EXCEPTIONS_OFF': '',
'CFLAGS_EXCEPTIONS_ON': '',
'CFLAGS_MT': '',
'CFLAGS_MT_DBG': '',
'CFLAGS_MT_DLL': '',
'CFLAGS_MT_DLLDBG': '',
'CFLAGS_RELEASE': '-march=native -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4',
'CFLAGS_RTTI_OFF': '',
'CFLAGS_RTTI_ON': '',
'CFLAGS_SHLIB': '-fPIC',
'CFLAGS_STL_OFF': '',
'CFLAGS_STL_ON': '',
'CFLAGS_THREAD': '-D_REENTRANT',
'CFLAGS_WARN_OFF': '-w',
'CFLAGS_WARN_ON': '-Wall -W',
'CHK_DIR_EXISTS': 'test -d',
'CONFIG': 'qt warn_on release incremental link_prl gdb_dwarf_index',
'COPY': 'cp -f',
'CXX': 'g++',
'CXXFLAGS': '-pipe',
'CXXFLAGS_APP': '',
'CXXFLAGS_CONSOLE': '',
'CXXFLAGS_DEBUG': '-g',
'CXXFLAGS_EXCEPTIONS_OFF': '',
'CXXFLAGS_EXCEPTIONS_ON': '',
'CXXFLAGS_MT': '',
'CXXFLAGS_MT_DBG': '',
'CXXFLAGS_MT_DLL': '',
'CXXFLAGS_MT_DLLDBG': '',
'CXXFLAGS_RELEASE': '-march=native -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4',
'CXXFLAGS_RTTI_OFF': '',
'CXXFLAGS_RTTI_ON': '',
'CXXFLAGS_SHLIB': '-fPIC',
'CXXFLAGS_STL_OFF': '',
'CXXFLAGS_STL_ON': '',
'CXXFLAGS_THREAD': '-D_REENTRANT',
'CXXFLAGS_WARN_OFF': '-w',
'CXXFLAGS_WARN_ON': '-Wall -W',
'DEFINES': '',
'DEL_FILE': 'rm -f',
'EXTENSION_PLUGIN': '',
'EXTENSION_SHLIB': '',
'INCDIR': '',
'INCDIR_OPENGL': '/usr/X11R6/include',
'INCDIR_QT': '/usr/include/qt4',
'INCDIR_X11': '/usr/X11R6/include',
'LFLAGS': '-Wl,-O1,--sort-common,--as-needed,-z,relro',
'LFLAGS_CONSOLE': '',
'LFLAGS_CONSOLE_DLL': '',
'LFLAGS_DEBUG': '',
'LFLAGS_DLL': '',
'LFLAGS_OPENGL': '',
'LFLAGS_PLUGIN': '-shared',
'LFLAGS_RELEASE': ' -Wl,-O1',
'LFLAGS_RPATH': '',
'LFLAGS_SHLIB': '-shared',
'LFLAGS_SONAME': '-Wl,-soname,',
'LFLAGS_THREAD': '',
'LFLAGS_WINDOWS': '',
'LFLAGS_WINDOWS_DLL': '',
'LIB': '',
'LIBDIR': '',
'LIBDIR_OPENGL': '/usr/X11R6/lib',
'LIBDIR_QT': '/usr/lib',
'LIBDIR_X11': '/usr/X11R6/lib',
'LIBS': '',
'LIBS_CONSOLE': '',
'LIBS_CORE': '',
'LIBS_GUI': '',
'LIBS_NETWORK': '',
'LIBS_OPENGL': '-lGL',
'LIBS_RT': '',
'LIBS_RTMT': '',
'LIBS_THREAD': '-lpthread',
'LIBS_WEBKIT': '',
'LIBS_WINDOWS': '',
'LIBS_X11': '-lXext -lX11 -lm',
'LINK': 'g++',
'LINK_SHLIB': 'g++',
'LINK_SHLIB_CMD': '',
'MAKEFILE_GENERATOR': 'UNIX',
'MKDIR': 'mkdir -p',
'MOC': '/usr/lib/qt4/bin/moc',
'RANLIB': '',
'RPATH': '',
'STRIP': 'strip'
}
class Configuration(sipconfig.Configuration):
"""The class that represents PyQt configuration values.
"""
def __init__(self, sub_cfg=None):
"""Initialise an instance of the class.
sub_cfg is the list of sub-class configurations. It should be None
when called normally.
"""
if sub_cfg:
cfg = sub_cfg
else:
cfg = []
cfg.append(_pkg_config)
sipconfig.Configuration.__init__(self, cfg)
class QtCoreModuleMakefile(sipconfig.SIPModuleMakefile):
"""The Makefile class for modules that %Import QtCore.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore"]
sipconfig.SIPModuleMakefile.__init__(self, *args, **kw)
class QtGuiModuleMakefile(QtCoreModuleMakefile):
"""The Makefile class for modules that %Import QtGui.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui"]
QtCoreModuleMakefile.__init__(self, *args, **kw)
class QtHelpModuleMakefile(QtGuiModuleMakefile):
"""The Makefile class for modules that %Import QtHelp.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "QtHelp"]
QtGuiModuleMakefile.__init__(self, *args, **kw)
class QtMultimediaModuleMakefile(QtGuiModuleMakefile):
"""The Makefile class for modules that %Import QtMultimedia.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "QtMultimedia"]
QtGuiModuleMakefile.__init__(self, *args, **kw)
class QtNetworkModuleMakefile(QtCoreModuleMakefile):
"""The Makefile class for modules that %Import QtNetwork.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtNetwork"]
QtCoreModuleMakefile.__init__(self, *args, **kw)
class QtDeclarativeModuleMakefile(QtNetworkModuleMakefile):
"""The Makefile class for modules that %Import QtDeclarative.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "QtNetwork", "QtDeclarative"]
QtNetworkModuleMakefile.__init__(self, *args, **kw)
class QtAssistantModuleMakefile(QtNetworkModuleMakefile):
"""The Makefile class for modules that %Import QtAssistant.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "QtNetwork", "QtAssistant"]
QtNetworkModuleMakefile.__init__(self, *args, **kw)
class QtOpenGLModuleMakefile(QtGuiModuleMakefile):
"""The Makefile class for modules that %Import QtOpenGL.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
kw["opengl"] = 1
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "QtOpenGL"]
QtGuiModuleMakefile.__init__(self, *args, **kw)
class QtScriptModuleMakefile(QtCoreModuleMakefile):
"""The Makefile class for modules that %Import QtScript.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtScript"]
QtCoreModuleMakefile.__init__(self, *args, **kw)
class QtScriptToolsModuleMakefile(QtScriptModuleMakefile):
"""The Makefile class for modules that %Import QtScriptTools.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "QtScript", "QtScriptTools"]
QtScriptModuleMakefile.__init__(self, *args, **kw)
class QtSqlModuleMakefile(QtGuiModuleMakefile):
"""The Makefile class for modules that %Import QtSql.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "QtSql"]
QtGuiModuleMakefile.__init__(self, *args, **kw)
class QtSvgModuleMakefile(QtGuiModuleMakefile):
"""The Makefile class for modules that %Import QtSvg.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "QtSvg"]
QtGuiModuleMakefile.__init__(self, *args, **kw)
class QtTestModuleMakefile(QtGuiModuleMakefile):
"""The Makefile class for modules that %Import QtTest.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "QtTest"]
QtGuiModuleMakefile.__init__(self, *args, **kw)
class QtWebKitModuleMakefile(QtNetworkModuleMakefile):
"""The Makefile class for modules that %Import QtWebKit.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "QtNetwork", "QtWebKit"]
QtNetworkModuleMakefile.__init__(self, *args, **kw)
class QtXmlModuleMakefile(QtCoreModuleMakefile):
"""The Makefile class for modules that %Import QtXml.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtXml"]
QtCoreModuleMakefile.__init__(self, *args, **kw)
class QtXmlPatternsModuleMakefile(QtCoreModuleMakefile):
"""The Makefile class for modules that %Import QtXmlPatterns.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtXmlPatterns"]
QtCoreModuleMakefile.__init__(self, *args, **kw)
class phononModuleMakefile(QtGuiModuleMakefile):
"""The Makefile class for modules that %Import phonon.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "phonon"]
QtGuiModuleMakefile.__init__(self, *args, **kw)
class QtDesignerModuleMakefile(QtGuiModuleMakefile):
"""The Makefile class for modules that %Import QtDesigner.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "QtDesigner"]
QtGuiModuleMakefile.__init__(self, *args, **kw)
class QAxContainerModuleMakefile(QtGuiModuleMakefile):
"""The Makefile class for modules that %Import QAxContainer.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtGui", "QAxContainer"]
QtGuiModuleMakefile.__init__(self, *args, **kw)
class QtDBusModuleMakefile(QtCoreModuleMakefile):
"""The Makefile class for modules that %Import QtDBus.
"""
def __init__(self, *args, **kw):
"""Initialise an instance of a module Makefile.
"""
if "qt" not in kw:
kw["qt"] = ["QtCore", "QtDBus"]
QtCoreModuleMakefile.__init__(self, *args, **kw)

View file

@ -0,0 +1,12 @@
diff -ur PyQwt-5.2.0.orig/qt4lib/PyQt4/Qwt5/qplt.py PyQwt-5.2.0/qt4lib/PyQt4/Qwt5/qplt.py
--- PyQwt-5.2.0.orig/qt4lib/PyQt4/Qwt5/qplt.py 2014-01-31 15:56:00.000000000 +0100
+++ PyQwt-5.2.0/qt4lib/PyQt4/Qwt5/qplt.py 2014-01-31 15:57:03.000000000 +0100
@@ -204,7 +204,7 @@
self.setTitle(text)
elif isinstance(item, int):
self.setZoomerMouseEventSet(item)
- elif (isinstance(item, tuple) and len(tuple) == 2
+ elif (isinstance(item, tuple) and len(item) == 2
and isinstance(item[0], int) and isinstance(item[1], int)):
self.size = item
elif isinstance(item, QWidget): # accept a parent silently