mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/libtg_owt to 0.git22.dcb5069-1
This commit is contained in:
parent
a4bdedc4de
commit
c406aac4d1
2 changed files with 32 additions and 4 deletions
|
@ -7,8 +7,8 @@
|
||||||
pkgname=libtg_owt
|
pkgname=libtg_owt
|
||||||
# It seems the currently desired version can be gotten from
|
# It seems the currently desired version can be gotten from
|
||||||
# https://github.com/telegramdesktop/tdesktop/blob/dev/Telegram/build/docker/centos_env/Dockerfile
|
# https://github.com/telegramdesktop/tdesktop/blob/dev/Telegram/build/docker/centos_env/Dockerfile
|
||||||
_commit=9d120195334db4f232c925529aa7601656dc59d7
|
_commit=dcb5069ff76bd293e86928804208737e6cee2ccc
|
||||||
pkgver=0.git21.${_commit:0:7}
|
pkgver=0.git22.${_commit:0:7}
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc='WebRTC library'
|
pkgdesc='WebRTC library'
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
|
@ -22,11 +22,13 @@ options=('staticlibs')
|
||||||
source=("tg_owt::git+${url}.git#commit=${_commit}"
|
source=("tg_owt::git+${url}.git#commit=${_commit}"
|
||||||
"libvpx::git+https://chromium.googlesource.com/webm/libvpx.git"
|
"libvpx::git+https://chromium.googlesource.com/webm/libvpx.git"
|
||||||
"libyuv::git+https://chromium.googlesource.com/libyuv/libyuv.git"
|
"libyuv::git+https://chromium.googlesource.com/libyuv/libyuv.git"
|
||||||
"pipewire::git+https://github.com/PipeWire/pipewire.git")
|
"pipewire::git+https://github.com/PipeWire/pipewire.git"
|
||||||
|
"libtg_owt-fix-gcc13.patch")
|
||||||
b2sums=('SKIP'
|
b2sums=('SKIP'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'SKIP')
|
'SKIP'
|
||||||
|
'18310fa97390e2cb6224060632ecac3b0a617aaedfef6291951d2a94c05c2602a7e2f36fc1632a1a6d9ba28ad705368d3229ab585a31e5dfff9733e5c17bd24f')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd tg_owt
|
cd tg_owt
|
||||||
|
@ -35,6 +37,8 @@ prepare() {
|
||||||
git config submodule.src/third_party/libyuv.url "$srcdir"/libyuv
|
git config submodule.src/third_party/libyuv.url "$srcdir"/libyuv
|
||||||
git config submodule.src/third_party/pipewire.url "$srcdir"/pipewire
|
git config submodule.src/third_party/pipewire.url "$srcdir"/pipewire
|
||||||
git -c protocol.file.allow=always submodule update
|
git -c protocol.file.allow=always submodule update
|
||||||
|
|
||||||
|
patch -Np1 -i "$srcdir"/libtg_owt-fix-gcc13.patch
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
24
extra/libtg_owt/libtg_owt-fix-gcc13.patch
Normal file
24
extra/libtg_owt/libtg_owt-fix-gcc13.patch
Normal file
|
@ -0,0 +1,24 @@
|
||||||
|
diff --git a/src/modules/audio_processing/transient/file_utils.h b/src/modules/audio_processing/transient/file_utils.h
|
||||||
|
index b7483377..687ebcef 100644
|
||||||
|
--- a/src/modules/audio_processing/transient/file_utils.h
|
||||||
|
+++ b/src/modules/audio_processing/transient/file_utils.h
|
||||||
|
@@ -12,6 +12,7 @@
|
||||||
|
#define MODULES_AUDIO_PROCESSING_TRANSIENT_FILE_UTILS_H_
|
||||||
|
|
||||||
|
#include <string.h>
|
||||||
|
+#include <cstdint>
|
||||||
|
|
||||||
|
#include "rtc_base/system/file_wrapper.h"
|
||||||
|
|
||||||
|
diff --git a/src/rtc_base/third_party/base64/base64.h b/src/rtc_base/third_party/base64/base64.h
|
||||||
|
index 4190a79d..e224ffd0 100644
|
||||||
|
--- a/src/rtc_base/third_party/base64/base64.h
|
||||||
|
+++ b/src/rtc_base/third_party/base64/base64.h
|
||||||
|
@@ -14,6 +14,7 @@
|
||||||
|
|
||||||
|
#include <string>
|
||||||
|
#include <vector>
|
||||||
|
+#include <cstdint>
|
||||||
|
|
||||||
|
#include "absl/strings/string_view.h"
|
||||||
|
#include "rtc_base/system/rtc_export.h"
|
Loading…
Reference in a new issue