diff --git a/aur/python2-configshell/PKGBUILD b/aur/python2-configshell/PKGBUILD
new file mode 100644
index 000000000..19f3b76ef
--- /dev/null
+++ b/aur/python2-configshell/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Johannes Dewender  arch at JonnyJD dot net 
+# Contributor: Kevin Mihelich <kevin@plugapps.com>
+
+plugrel=1
+
+pkgname=python2-configshell
+_pkgname=configshell
+pkgver=1.1
+pkgrel=3
+pkgdesc="python framework for building simple CLI-based applications"
+arch=('any')
+url="http://www.risingtidesystems.com/git/?p=configshell.git;a=summary"
+license=('AGPL3')
+depends=('python2-simpleparse' 'python-urwid' 'epydoc')
+makedepends=('python2-distribute')
+source=("$_pkgname-$pkgver.tgz::http://www.risingtidesystems.com/git/?p=$_pkgname.git;a=snapshot;h=3ba5560219d7ae8545ce825f4ba778b5c2c90893;sf=tgz")
+md5sums=('cbca82c16f5511d9307667fd611ba65a')
+
+build() {
+  cd "$srcdir/$_pkgname"
+  python2 setup.py build
+}
+
+package() {
+  cd "$srcdir/$_pkgname"
+  python2 setup.py install --skip-build --root="$pkgdir/" --optimize=1
+}