mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/mysql-workbench: fix
This commit is contained in:
parent
dded4f5645
commit
c4617e40db
3 changed files with 3 additions and 118 deletions
|
@ -1,88 +0,0 @@
|
|||
From ab7ee7f3786c1cf83e4835f50e509261573f39df Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 15 Nov 2019 18:43:53 -0700
|
||||
Subject: [PATCH] fix buiild for 32-bit
|
||||
|
||||
---
|
||||
backend/wbprivate/sqlide/wb_sql_editor_form.cpp | 2 +-
|
||||
library/ssh/SSHCommon.cpp | 12 ++++++------
|
||||
library/ssh/SSHSession.cpp | 6 +++---
|
||||
3 files changed, 10 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/backend/wbprivate/sqlide/wb_sql_editor_form.cpp b/backend/wbprivate/sqlide/wb_sql_editor_form.cpp
|
||||
index 6a2f65d..528fd96 100644
|
||||
--- a/backend/wbprivate/sqlide/wb_sql_editor_form.cpp
|
||||
+++ b/backend/wbprivate/sqlide/wb_sql_editor_form.cpp
|
||||
@@ -2016,7 +2016,7 @@ grt::StringRef SqlEditorForm::do_exec_sql(Ptr self_ptr, std::shared_ptr<std::str
|
||||
|
||||
bool results_left = false;
|
||||
for (auto &statement_range : statement_ranges) {
|
||||
- logDebug3("Executing statement range: %lu, %lu...\n", statement_range.first, statement_range.second);
|
||||
+ logDebug3("Executing statement range: %u, %u...\n", statement_range.first, statement_range.second);
|
||||
|
||||
statement = sql->substr(statement_range.first, statement_range.second);
|
||||
std::list<std::string> sub_statements;
|
||||
diff --git a/library/ssh/SSHCommon.cpp b/library/ssh/SSHCommon.cpp
|
||||
index e65ecb6..093ec3e 100644
|
||||
--- a/library/ssh/SSHCommon.cpp
|
||||
+++ b/library/ssh/SSHCommon.cpp
|
||||
@@ -168,11 +168,11 @@ namespace ssh {
|
||||
|
||||
void SSHConnectionConfig::dumpConfig() const {
|
||||
logDebug2("SSH Connection config info:\n");
|
||||
- logDebug2("SSH bufferSize: %lu\n", bufferSize);
|
||||
- logDebug2("SSH connectTimeout: %lu\n", connectTimeout);
|
||||
- logDebug2("SSH readWriteTimeout: %lu\n", readWriteTimeout);
|
||||
- logDebug2("SSH commandTimeout: %lu\n", commandTimeout);
|
||||
- logDebug2("SSH commandRetryCount: %lu\n", commandRetryCount);
|
||||
+ logDebug2("SSH bufferSize: %u\n", bufferSize);
|
||||
+ logDebug2("SSH connectTimeout: %u\n", connectTimeout);
|
||||
+ logDebug2("SSH readWriteTimeout: %u\n", readWriteTimeout);
|
||||
+ logDebug2("SSH commandTimeout: %u\n", commandTimeout);
|
||||
+ logDebug2("SSH commandRetryCount: %u\n", commandRetryCount);
|
||||
logDebug2("SSH optionsDir: %s\n", optionsDir.c_str());
|
||||
logDebug2("SSH known hosts file: %s\n", knownHostsFile.c_str());
|
||||
logDebug2("SSH local host: %s\n", localhost.c_str());
|
||||
@@ -180,7 +180,7 @@ namespace ssh {
|
||||
logDebug2("SSH remote host: %s\n", remotehost.c_str());
|
||||
logDebug2("SSH remote port: %d\n", remoteport);
|
||||
logDebug2("SSH remote ssh host: %s\n", remoteSSHhost.c_str());
|
||||
- logDebug2("SSH remote ssh port: %lu\n", remoteSSHport);
|
||||
+ logDebug2("SSH remote ssh port: %u\n", remoteSSHport);
|
||||
logDebug2("SSH strict host key check: %s\n", strictHostKeyCheck ? "yes" : "no");
|
||||
}
|
||||
|
||||
diff --git a/library/ssh/SSHSession.cpp b/library/ssh/SSHSession.cpp
|
||||
index a30ebbc..b223171 100644
|
||||
--- a/library/ssh/SSHSession.cpp
|
||||
+++ b/library/ssh/SSHSession.cpp
|
||||
@@ -147,7 +147,7 @@ namespace ssh {
|
||||
try {
|
||||
_session->connect();
|
||||
} catch (ssh::SshException &exc) {
|
||||
- logError("Unable to connect: %s:%lu\nError was: %s\n", config.remoteSSHhost.c_str(), config.remoteSSHport,
|
||||
+ logError("Unable to connect: %s:%u\nError was: %s\n", config.remoteSSHhost.c_str(), config.remoteSSHport,
|
||||
exc.getError().c_str());
|
||||
return std::make_tuple(SSHReturnType::CONNECTION_FAILURE, exc.getError());
|
||||
}
|
||||
@@ -360,7 +360,7 @@ namespace ssh {
|
||||
}
|
||||
} while (true);
|
||||
|
||||
- logDebug3("Bytes read: %lu\n", bytesRead);
|
||||
+ logDebug3("Bytes read: %u\n", bytesRead);
|
||||
return std::make_tuple(so.str(), retError, channel->getExitStatus());
|
||||
}
|
||||
|
||||
@@ -479,7 +479,7 @@ namespace ssh {
|
||||
}
|
||||
} while (true);
|
||||
|
||||
- logDebug3("Bytes read: %lu\n", bytesRead);
|
||||
+ logDebug3("Bytes read: %u\n", bytesRead);
|
||||
return std::make_tuple(so.str(), retError, channel->getExitStatus());
|
||||
}
|
||||
|
||||
--
|
||||
2.23.0
|
||||
|
|
@ -5,11 +5,10 @@
|
|||
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - use our cxxflags plus -fsigned-char
|
||||
# - patch to fix build on 32-bit
|
||||
# - remove -Wno-deprecated-copy flag from CMakeLists.txt
|
||||
# - add -fsigned-char to CXXFLAGS
|
||||
|
||||
highmem=1
|
||||
buildarch=8
|
||||
|
||||
pkgname=mysql-workbench
|
||||
pkgver=8.0.36
|
||||
|
@ -42,8 +41,6 @@ source=("https://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community
|
|||
'0004-libxml2.patch'
|
||||
'0005-python-3-12.patch'
|
||||
'0006-library-ssh-include.patch'
|
||||
'0001-fix-buiild-for-32-bit.patch'
|
||||
'atomic.patch'
|
||||
'arch_linux_profile.xml')
|
||||
sha256sums=('634d8a66b6c2777491058a60aba8187e947e4c49a0e7ae83df312fa70714637c'
|
||||
'SKIP'
|
||||
|
@ -59,8 +56,6 @@ sha256sums=('634d8a66b6c2777491058a60aba8187e947e4c49a0e7ae83df312fa70714637c'
|
|||
'a9f1d3262350b22850f9720647c806be8959f2ed387d0095e6134b7f3251363c'
|
||||
'e596ef8ed8479c5052c78fe17139309182d22bfd5765f32866367fd3e787277d'
|
||||
'208ecb77f2ea62340fc77456aab9cfbb89ff78d47d6aa5fde2003a894e4d872d'
|
||||
'719501bbd1de673767007c429feed2fc48d1176d456161c4ba69cf3165c0438a'
|
||||
'17294a67637ab7ffff5c39262208e63d21acac72cc2492f616ef1d8e0ae9ac02'
|
||||
'd816164098c90c432b4fe590708c14f95ab137abfe16ad1b7d498b2e83c0e265')
|
||||
|
||||
prepare() {
|
||||
|
@ -96,18 +91,6 @@ prepare() {
|
|||
|
||||
# be happy with more recent antlr
|
||||
sed -i "/set(ANTLR_JAR_FILENAME/s/4.11.1/${_antlr4_version}/" CMakeLists.txt
|
||||
|
||||
# remove -Wno-deprecated-copy
|
||||
sed -i 's|-Wno-deprecated-copy||' CMakeLists.txt
|
||||
|
||||
# fix build with 32-bit
|
||||
[[ $CARCH != "aarch64" ]] && patch -Np1 < "${srcdir}"/0001-fix-buiild-for-32-bit.patch
|
||||
|
||||
# link v6 against libatomic
|
||||
cd "${srcdir}/mysql-${_mysql_version}"
|
||||
if [[ $CARCH == "armv6h" ]]; then
|
||||
patch -Np0 < "${srcdir}"/atomic.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -175,7 +158,7 @@ build() {
|
|||
cmake "${srcdir}/mysql-workbench-community-${pkgver}-src" \
|
||||
-Wno-dev \
|
||||
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
|
||||
-DCMAKE_CXX_FLAGS="${CXXFLAGS} -std=c++17 -fsigned-char" \
|
||||
-DCMAKE_CXX_FLAGS="$CXXFLAGS -include cstdint -fsigned-char" \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DMySQL_CONFIG_PATH="${srcdir}/install-bundle/usr/bin/mysql_config" \
|
||||
-DMySQLCppConn_LIBRARY="${srcdir}/install-bundle/usr/lib/libmysqlcppconn.so" \
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- client/dump/CMakeLists.txt.orig 2018-07-30 12:36:51.808341641 -0600
|
||||
+++ client/dump/CMakeLists.txt 2018-07-30 12:37:08.520304037 -0600
|
||||
@@ -102,6 +102,6 @@
|
||||
|
||||
MYSQL_ADD_EXECUTABLE(mysqlpump program.cc)
|
||||
|
||||
-TARGET_LINK_LIBRARIES(mysqlpump mysqlpump_lib)
|
||||
+TARGET_LINK_LIBRARIES(mysqlpump mysqlpump_lib atomic)
|
||||
|
||||
SET_TARGET_PROPERTIES(mysqlpump PROPERTIES HAS_CXX TRUE)
|
Loading…
Reference in a new issue