mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/mplayer-vaapi to 34578-5
This commit is contained in:
parent
ec3a852bbf
commit
c4686898f9
5 changed files with 56 additions and 32 deletions
|
@ -1,4 +1,4 @@
|
||||||
# $Id: PKGBUILD 66299 2012-02-23 13:44:43Z allan $
|
# $Id: PKGBUILD 70637 2012-05-13 16:56:17Z foutrelis $
|
||||||
# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
|
# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
|
||||||
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
||||||
# Contributor: Hugo Doria <hugo@archlinux.org>
|
# Contributor: Hugo Doria <hugo@archlinux.org>
|
||||||
|
@ -10,7 +10,7 @@ plugrel=1
|
||||||
|
|
||||||
pkgname=mplayer-vaapi
|
pkgname=mplayer-vaapi
|
||||||
pkgver=34578
|
pkgver=34578
|
||||||
pkgrel=4
|
pkgrel=5
|
||||||
pkgdesc="A movie player, compiled with vaapi support"
|
pkgdesc="A movie player, compiled with vaapi support"
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url="http://gitorious.org/vaapi/mplayer"
|
url="http://gitorious.org/vaapi/mplayer"
|
||||||
|
@ -26,17 +26,22 @@ provides=("mplayer=$pkgver")
|
||||||
conflicts=('mplayer')
|
conflicts=('mplayer')
|
||||||
backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
|
backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
|
||||||
source=(http://pkgbuild.com/~foutrelis/mplayer-vaapi-$pkgver.tar.xz
|
source=(http://pkgbuild.com/~foutrelis/mplayer-vaapi-$pkgver.tar.xz
|
||||||
mplayer.desktop
|
tweak-desktop-file.patch
|
||||||
mplayer.png)
|
mplayer.png
|
||||||
|
live-media.patch)
|
||||||
options=('!buildflags' '!emptydirs')
|
options=('!buildflags' '!emptydirs')
|
||||||
install=mplayer-vaapi.install
|
install=mplayer-vaapi.install
|
||||||
sha256sums=('cc35a057c8a64d2cdec2dc0a037811ef0f91dd03cd3d07465c7272a08665a37d'
|
sha256sums=('cc35a057c8a64d2cdec2dc0a037811ef0f91dd03cd3d07465c7272a08665a37d'
|
||||||
'9aa54571b37d15aec2c8e3ddf086753217efc3084ebf466335b2f28d819c74da'
|
'5b39f0a61969bf330c4434cb17975101be93c27334f65e154e4a93033033e795'
|
||||||
'061739a8cc267748ad58f168034cc39785d949a5262772535e1b347c7842af48')
|
'061739a8cc267748ad58f168034cc39785d949a5262772535e1b347c7842af48'
|
||||||
|
'9c1400f27dd2ea54c125c66ed1af0eab19761b1b2ae808fa491cd3732fd8a685')
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$srcdir/mplayer-vaapi-$pkgver"
|
cd "$srcdir/mplayer-vaapi-$pkgver"
|
||||||
|
|
||||||
|
patch -d etc -Np0 -i "$srcdir/tweak-desktop-file.patch"
|
||||||
|
patch -Np0 -i "$srcdir/live-media.patch"
|
||||||
|
|
||||||
./configure --prefix=/usr \
|
./configure --prefix=/usr \
|
||||||
--disable-gui \
|
--disable-gui \
|
||||||
--disable-arts \
|
--disable-arts \
|
||||||
|
@ -65,11 +70,10 @@ package() {
|
||||||
|
|
||||||
make -j1 DESTDIR="$pkgdir" install-mplayer install-mplayer-man
|
make -j1 DESTDIR="$pkgdir" install-mplayer install-mplayer-man
|
||||||
install -Dm644 etc/{codecs.conf,input.conf,example.conf} "$pkgdir/etc/mplayer/"
|
install -Dm644 etc/{codecs.conf,input.conf,example.conf} "$pkgdir/etc/mplayer/"
|
||||||
install -dm755 "$pkgdir/usr/share/mplayer/"
|
install -Dm644 etc/mplayer.desktop "$pkgdir/usr/share/applications/mplayer.desktop"
|
||||||
|
install -d "$pkgdir/usr/share/mplayer/"
|
||||||
ln -s /usr/share/fonts/TTF/DejaVuSans.ttf "$pkgdir/usr/share/mplayer/subfont.ttf"
|
ln -s /usr/share/fonts/TTF/DejaVuSans.ttf "$pkgdir/usr/share/mplayer/subfont.ttf"
|
||||||
rm -rf "$pkgdir/usr/share/mplayer/font"
|
rm -rf "$pkgdir/usr/share/mplayer/font"
|
||||||
# Desktop file (FS#14770)
|
|
||||||
install -Dm644 "$srcdir/mplayer.desktop" "$pkgdir/usr/share/applications/mplayer.desktop"
|
|
||||||
install -Dm644 "$srcdir/mplayer.png" "$pkgdir/usr/share/pixmaps/mplayer.png"
|
install -Dm644 "$srcdir/mplayer.png" "$pkgdir/usr/share/pixmaps/mplayer.png"
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
13
community/mplayer-vaapi/live-media.patch
Normal file
13
community/mplayer-vaapi/live-media.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
Index: libmpdemux/demux_rtp.cpp
|
||||||
|
===================================================================
|
||||||
|
--- libmpdemux/demux_rtp.cpp (revision 34798)
|
||||||
|
+++ libmpdemux/demux_rtp.cpp (working copy)
|
||||||
|
@@ -19,6 +19,8 @@
|
||||||
|
* 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#define RTSPCLIENT_SYNCHRONOUS_INTERFACE 1
|
||||||
|
+
|
||||||
|
extern "C" {
|
||||||
|
// on MinGW, we must include windows.h before the things it conflicts
|
||||||
|
#ifdef __MINGW32__ // with. they are each protected from
|
|
@ -2,8 +2,8 @@ post_install() {
|
||||||
update-desktop-database -q
|
update-desktop-database -q
|
||||||
}
|
}
|
||||||
post_upgrade() {
|
post_upgrade() {
|
||||||
post_install $1
|
post_install
|
||||||
}
|
}
|
||||||
post_remove() {
|
post_remove() {
|
||||||
post_install $1
|
post_install
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,21 +0,0 @@
|
||||||
[Desktop Entry]
|
|
||||||
Type=Application
|
|
||||||
Name=MPlayer Media Player
|
|
||||||
Name[ca]=Reproductor multimèdia MPlayer
|
|
||||||
Name[pl]=MPlayer odtwarzacz multimedialny
|
|
||||||
GenericName=Multimedia player
|
|
||||||
Comment=Play movies and songs
|
|
||||||
Comment[ca]=Reproduïu vídeos i cançons
|
|
||||||
Comment[de]=Filme und Musik abspielen
|
|
||||||
Comment[es]=Reproduzca vídeos y canciones
|
|
||||||
Comment[fr]=Lecteur multimédia
|
|
||||||
Comment[it]=Lettore multimediale
|
|
||||||
Comment[zh]=多媒体播放器
|
|
||||||
Comment[pl]=Odtwarzaj filmy i muzykę
|
|
||||||
Icon=mplayer
|
|
||||||
TryExec=mplayer
|
|
||||||
Exec=mplayer -really-quiet %F
|
|
||||||
Terminal=false
|
|
||||||
NoDisplay=true
|
|
||||||
Categories=GTK;AudioVideo;Audio;Video;Player;TV;
|
|
||||||
MimeType=application/ogg;application/x-ogg;application/sdp;application/smil;application/x-smil;application/streamingmedia;application/x-streamingmedia;application/vnd.rn-realmedia;application/vnd.rn-realmedia-vbr;audio/aac;audio/x-aac;audio/m4a;audio/x-m4a;audio/mp1;audio/x-mp1;audio/mp2;audio/x-mp2;audio/mp3;audio/x-mp3;audio/mpeg;audio/x-mpeg;audio/mpegurl;audio/x-mpegurl;audio/mpg;audio/x-mpg;audio/rn-mpeg;audio/scpls;audio/x-scpls;audio/vnd.rn-realaudio;audio/wav;audio/x-pn-windows-pcm;audio/x-realaudio;audio/x-pn-realaudio;audio/x-ms-wma;audio/x-pls;audio/x-wav;video/mpeg;video/x-mpeg;video/x-mpeg2;video/mp4;video/msvideo;video/x-msvideo;video/quicktime;video/vnd.rn-realvideo;video/x-ms-afs;video/x-ms-asf;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvxvideo;video/x-avi;video/x-fli;video/x-flv;video/x-theora;video/x-matroska;
|
|
28
community/mplayer-vaapi/tweak-desktop-file.patch
Normal file
28
community/mplayer-vaapi/tweak-desktop-file.patch
Normal file
|
@ -0,0 +1,28 @@
|
||||||
|
--- mplayer.desktop.orig 2012-05-13 19:25:26.000000000 +0300
|
||||||
|
+++ mplayer.desktop 2012-05-13 19:32:19.000000000 +0300
|
||||||
|
@@ -7,12 +7,6 @@ GenericName[de]=Medienwiedergabe
|
||||||
|
GenericName[fr]=Lecteur multimédia
|
||||||
|
GenericName[it]=Lettore multimediale
|
||||||
|
GenericName[ja]=メディアプレーヤー
|
||||||
|
-X-GNOME-FullName=MPlayer Media Player
|
||||||
|
-X-GNOME-FullName[ca]=MPlayer Reproductor multimèdia
|
||||||
|
-X-GNOME-FullName[de]=MPlayer Medienwiedergabe
|
||||||
|
-X-GNOME-FullName[fr]=MPlayer Lecteur multimédia
|
||||||
|
-X-GNOME-FullName[it]=MPlayer Lettore multimediale
|
||||||
|
-X-GNOME-FullName[ja]=MPlayer メディアプレーヤー
|
||||||
|
Comment=Play movies and songs
|
||||||
|
Comment[ca]=Reproduïu vídeos i cançons
|
||||||
|
Comment[de]=Filme und Musik wiedergeben
|
||||||
|
@@ -20,8 +14,9 @@ Comment[fr]=Lit les films et musiques
|
||||||
|
Comment[it]=Riproduce filmati e musica
|
||||||
|
Comment[ja]=動画や音声のファイルを再生します
|
||||||
|
Icon=mplayer
|
||||||
|
-TryExec=gmplayer
|
||||||
|
-Exec=gmplayer %F
|
||||||
|
+TryExec=mplayer
|
||||||
|
+Exec=mplayer -really-quiet %F
|
||||||
|
Terminal=false
|
||||||
|
+NoDisplay=true
|
||||||
|
Categories=GTK;AudioVideo;Audio;Video;Player;TV;
|
||||||
|
-MimeType=application/ogg;application/x-ogg;application/sdp;application/smil;application/x-smil;application/streamingmedia;application/x-streamingmedia;application/vnd.rn-realmedia;application/vnd.rn-realmedia-vbr;audio/aac;audio/x-aac;audio/m4a;audio/x-m4a;audio/mp1;audio/x-mp1;audio/mp2;audio/x-mp2;audio/mp3;audio/x-mp3;audio/mpeg;audio/x-mpeg;audio/mpegurl;audio/x-mpegurl;audio/mpg;audio/x-mpg;audio/rn-mpeg;audio/scpls;audio/x-scpls;audio/vnd.rn-realaudio;audio/wav;audio/x-pn-windows-pcm;audio/x-realaudio;audio/x-pn-realaudio;audio/x-ms-wma;audio/x-pls;audio/x-wav;video/mpeg;video/x-mpeg;video/x-mpeg2;video/msvideo;video/x-msvideo;video/quicktime;video/vnd.rn-realvideo;video/x-ms-afs;video/x-ms-asf;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvxvideo;video/x-avi;video/x-fli;video/x-theora;video/x-matroska;video/3gpp;application/x-flash-video;
|
||||||
|
+MimeType=application/ogg;application/x-ogg;application/sdp;application/smil;application/x-smil;application/streamingmedia;application/x-streamingmedia;application/vnd.rn-realmedia;application/vnd.rn-realmedia-vbr;audio/aac;audio/x-aac;audio/m4a;audio/x-m4a;audio/mp1;audio/x-mp1;audio/mp2;audio/x-mp2;audio/mp3;audio/x-mp3;audio/mpeg;audio/x-mpeg;audio/mpegurl;audio/x-mpegurl;audio/mpg;audio/x-mpg;audio/rn-mpeg;audio/scpls;audio/x-scpls;audio/vnd.rn-realaudio;audio/wav;audio/x-pn-windows-pcm;audio/x-realaudio;audio/x-pn-realaudio;audio/x-ms-wma;audio/x-pls;audio/x-wav;video/mpeg;video/x-mpeg;video/x-mpeg2;video/mp4;video/msvideo;video/x-msvideo;video/quicktime;video/vnd.rn-realvideo;video/x-ms-afs;video/x-ms-asf;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvxvideo;video/x-avi;video/x-fli;video/x-flv;video/x-theora;video/x-matroska;video/3gpp;application/x-flash-video;
|
Loading…
Reference in a new issue