omxplayer-git fixes, relocate from aur to alarm

This commit is contained in:
Kevin Mihelich 2014-08-10 22:08:37 +00:00
parent 2ec341c54b
commit c4c919dfa8
4 changed files with 116 additions and 110 deletions

View file

@ -1,11 +1,8 @@
# Maintainer: Huulivoide <gmail.com: jesse.jaara>
# Contributor: Jonathan Hudson <daria.co.uk: jh+arch>
# If you are building this on the original 256MB Raspberry Pi
# you need to enable some swap (100MB ?) or the build will fail
# on OMXPlayerSubtitles.cpp
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
# Contributor: Huulivoide <gmail.com: jesse.jaara>
# Contributor: Jonathan Hudson <daria.co.uk: jh+arch>
buildarch=16
pkgname=omxplayer-git
pkgver=366.90b8951
@ -19,8 +16,10 @@ makedepends=('git' 'boost')
optdepends=('ttf-freefont')
provides=(omxplayer)
conflicts=('omxplayer' 'omxplayer-bin')
source=(git://github.com/popcornmix/omxplayer.git
Makefile.arch Makefile.include.arch)
source=('git://github.com/popcornmix/omxplayer.git'
'alarm.patch')
md5sums=('SKIP'
'4f21babb3985e7e029a799383938f8ce')
pkgver() {
cd omxplayer
@ -30,8 +29,7 @@ pkgver() {
prepare() {
cd "${srcdir}/omxplayer"
cp ../Makefile.arch Makefile
cp ../Makefile.include.arch Makefile.include
patch -p1 -i ../alarm.patch
sed 's|truetype/freefont|TTF|g' -i omxplayer.cpp
}
@ -47,7 +45,3 @@ package() {
make DESTDIR="${pkgdir}" install
}
md5sums=('SKIP'
'462e40e8da2e2b10cb32138e7885d285'
'a8635442d02665944c04c18606453a04')

View file

@ -0,0 +1,107 @@
diff -urN a/Makefile b/Makefile
--- a/Makefile 2014-08-10 15:20:40.333620698 -0600
+++ b/Makefile 2014-08-10 16:00:28.275387482 -0600
@@ -2,9 +2,9 @@
CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
-LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
+LDFLAGS+=-L./ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include
+INCLUDES+=-I./ -Ilinux
DIST ?= omxplayer-dist
@@ -39,7 +39,7 @@
OBJS+=$(filter %.o,$(SRC:.cpp=.o))
-all: dist
+all: omxplayer.bin
%.o: %.cpp
@rm -f $@
@@ -51,7 +51,7 @@
bash gen_version.sh > version.h
omxplayer.bin: version $(OBJS)
- $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
+ $(CXX) -o omxplayer.bin $(OBJS) $(LDFLAGS) -lvchiq_arm -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
$(STRIP) omxplayer.bin
help.h: README.md Makefile
@@ -74,19 +74,9 @@
@rm -rf $(DIST)
@rm -f omxplayer-dist.tar.gz
-ffmpeg:
- @rm -rf ffmpeg
- make -f Makefile.ffmpeg
- make -f Makefile.ffmpeg install
-
-dist: omxplayer.bin omxplayer.1
- mkdir -p $(DIST)/usr/lib/omxplayer
- mkdir -p $(DIST)/usr/bin
- mkdir -p $(DIST)/usr/share/doc/omxplayer
- mkdir -p $(DIST)/usr/share/man/man1
- cp omxplayer omxplayer.bin $(DIST)/usr/bin
- cp COPYING $(DIST)/usr/share/doc/omxplayer
- cp README.md $(DIST)/usr/share/doc/omxplayer/README
- cp omxplayer.1 $(DIST)/usr/share/man/man1
- cp -a ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/
- cd $(DIST); tar -czf ../$(DIST).tgz *
+install:
+ install -d $(DESTDIR)/usr/bin
+ install -d $(DESTDIR)/usr/share/doc/omxplayer
+ install omxplayer $(DESTDIR)/usr/bin/
+ install omxplayer.bin $(DESTDIR)/usr/bin/
+ install README.md COPYING $(DESTDIR)/usr/share/doc/omxplayer/
diff -urN a/Makefile.include b/Makefile.include
--- a/Makefile.include 2014-08-10 15:20:40.333620698 -0600
+++ b/Makefile.include 2014-08-10 16:03:26.779799178 -0600
@@ -1,40 +1,4 @@
-USE_BUILDROOT=0
-FLOAT=hard
-
-ifeq ($(USE_BUILDROOT), 1)
-BUILDROOT :=/opt/xbmc-bcm/buildroot
-SDKSTAGE :=$(BUILDROOT)/output/staging
-TARGETFS :=$(BUILDROOT)/output/target
-TOOLCHAIN :=$(BUILDROOT)/output/host/usr/
-HOST :=arm-unknown-linux-gnueabi
-SYSROOT :=$(BUILDROOT)/output/host/usr/arm-unknown-linux-gnueabi/sysroot
-else
-BUILDROOT :=/opt/bcm-rootfs
-SDKSTAGE :=/opt/bcm-rootfs
-TARGETFS :=/opt/bcm-rootfs
-TOOLCHAIN :=/home/dc4/tools/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian/
-HOST :=arm-linux-gnueabihf
-#SYSROOT :=$(TOOLCHAIN)/arm-bcm2708hardfp-linux-gnueabi/sysroot
-SYSROOT :=/opt/bcm-rootfs
-endif
-
-JOBS=7
-
-CFLAGS := -isystem$(PREFIX)/include
-CXXFLAGS := $(CFLAGS)
-CPPFLAGS := $(CFLAGS)
-LDFLAGS := -L$(BUILDROOT)/lib
-LD := $(TOOLCHAIN)/bin/$(HOST)-ld --sysroot=$(SYSROOT)
-CC := $(TOOLCHAIN)/bin/$(HOST)-gcc --sysroot=$(SYSROOT)
-CXX := $(TOOLCHAIN)/bin/$(HOST)-g++ --sysroot=$(SYSROOT)
-OBJDUMP := $(TOOLCHAIN)/bin/$(HOST)-objdump
-RANLIB := $(TOOLCHAIN)/bin/$(HOST)-ranlib
-STRIP := $(TOOLCHAIN)/bin/$(HOST)-strip
-AR := $(TOOLCHAIN)/bin/$(HOST)-ar
-CXXCP := $(CXX) -E
-PATH := $(PREFIX)/bin:$(BUILDROOT)/output/host/usr/bin:$(PATH)
-
-CFLAGS += -pipe -mfloat-abi=$(FLOAT) -mcpu=arm1176jzf-s -fomit-frame-pointer -mabi=aapcs-linux -mtune=arm1176jzf-s -mfpu=vfp -Wno-psabi -mno-apcs-stack-check -g -mstructure-size-boundary=32 -mno-sched-prolog
-LDFLAGS += -L$(SDKSTAGE)/lib -L$(SDKSTAGE)/usr/lib -L$(SDKSTAGE)/opt/vc/lib/ -Lpcre/build
-#INCLUDES += -isystem$(SDKSTAGE)/usr/include -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SYSROOT)/usr/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads -isystem$(SDKSTAGE)/usr/include/freetype2
-INCLUDES += -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SYSROOT)/usr/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads -Ipcre/build -Iboost-trunk -Ifreetype2/include
+STRIP := strip
+CFLAGS += -fomit-frame-pointer -mabi=aapcs-linux -mtune=arm1176jzf-s -Wno-psabi -mno-apcs-stack-check -g -mstructure-size-boundary=32 -mno-sched-prolog
+LDFLAGS += -L/opt/vc/lib/
+INCLUDES += -I/opt/vc/include -I/opt/vc/include/interface/vmcs_host/linux -I/opt/vc/include/interface/vcos/pthreads -I/usr/include/freetype2 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include

View file

@ -1,67 +0,0 @@
include Makefile.include
CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
LDFLAGS+=-L./ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -ldbus-1
INCLUDES+=-I./ -Ilinux
DIST ?= omxplayer-dist
SRC=linux/XMemUtils.cpp \
utils/log.cpp \
DynamicDll.cpp \
utils/PCMRemap.cpp \
utils/RegExp.cpp \
OMXSubtitleTagSami.cpp \
OMXOverlayCodecText.cpp \
BitstreamConverter.cpp \
linux/RBP.cpp \
OMXThread.cpp \
OMXReader.cpp \
OMXStreamInfo.cpp \
OMXAudioCodecOMX.cpp \
OMXCore.cpp \
OMXControl.cpp \
Keyboard.cpp \
OMXVideo.cpp \
OMXAudio.cpp \
OMXClock.cpp \
File.cpp \
OMXPlayerVideo.cpp \
OMXPlayerAudio.cpp \
OMXPlayerSubtitles.cpp \
SubtitleRenderer.cpp \
Unicode.cpp \
Srt.cpp \
KeyConfig.cpp \
omxplayer.cpp
OBJS+=$(filter %.o,$(SRC:.cpp=.o))
all: omxplayer.bin
%.o: %.cpp
@rm -f $@
$(CXX) $(CFLAGS) $(INCLUDES) -c $< -o $@ -Wno-deprecated-declarations
version:
sh gen_version.sh > version.h
omxplayer.bin: version $(OBJS)
$(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
#arm-unknown-linux-gnueabi-strip omxplayer.bin
clean:
for i in $(OBJS); do (if test -e "$$i"; then ( rm $$i ); fi ); done
@rm -f omxplayer.old.log omxplayer.log
@rm -f omxplayer.bin
@rm -rf $(DIST)
@rm -f omxplayer-dist.tar.gz
install:
install -d $(DESTDIR)/usr/bin
install -d $(DESTDIR)/usr/share/doc/omxplayer
install omxplayer $(DESTDIR)/usr/bin/
install omxplayer.bin $(DESTDIR)/usr/bin/
install README.md COPYING $(DESTDIR)/usr/share/doc/omxplayer/

View file

@ -1,28 +0,0 @@
USE_BUILDROOT=0
JOBS=1
CFLAGS :=
CXXFLAGS := $(CFLAGS)
CPPFLAGS := $(CFLAGS)
LDFLAGS :=
LD := ld
CC := gcc
CXX := g++
OBJDUMP := objdump
RANLIB := ranlib
STRIP := strip
AR := ar
CXXCP := $(CXX) -E
CFLAGS += -pipe -mcpu=arm1176jzf-s -fomit-frame-pointer -mabi=aapcs-linux \
-mtune=arm1176jzf-s -mfpu=vfp -Wno-psabi -mno-apcs-stack-check \
-O3 -mstructure-size-boundary=32 -mno-sched-prolog
LDFLAGS += -L/opt/vc/lib/ -Wl,-rpath /opt/vc/lib/
INCLUDES += -I/opt/vc/include -I/opt/vc/include/interface/vcos/ \
-I/opt/vc/include/interface/vcos/pthreads -I/usr/include/freetype2 \
-I/opt/vc/include/interface/vmcs_host/linux -I/usr/include/dbus-1.0 \
-I/usr/lib/dbus-1.0/include/