mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/kdelibs to 4.14.26-1
This commit is contained in:
parent
ece8198aca
commit
c4e1e1f8c0
2 changed files with 4 additions and 30 deletions
|
@ -7,8 +7,8 @@
|
|||
# - patch to fix unclickable plasmoid buttons on ARM
|
||||
|
||||
pkgname=kdelibs
|
||||
pkgver=4.14.25
|
||||
_kdeappver=16.08.2
|
||||
pkgver=4.14.26
|
||||
_kdeappver=16.08.3
|
||||
pkgrel=1
|
||||
pkgdesc="KDE Core Libraries"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -20,13 +20,12 @@ depends=('attica-qt4' 'libxss' 'qca-qt4' 'libdbusmenu-qt4' 'polkit-qt4'
|
|||
'media-player-info' 'libutempter' 'qtwebkit' 'icu')
|
||||
makedepends=('cmake' 'automoc4' 'avahi' 'libgl' 'mesa')
|
||||
source=("http://download.kde.org/stable/applications/${_kdeappver}/src/$pkgname-$pkgver.tar.xz"
|
||||
'kde-applications-menu.patch' 'archlinux-menu.patch' 'qt4.patch' kdelibs-gcc6.patch
|
||||
'kde-applications-menu.patch' 'archlinux-menu.patch' 'qt4.patch'
|
||||
'arm-coronaoffscreen-input-fixes.diff')
|
||||
sha1sums=('70758ee9bc864e3eabe9cb3a26be815d3504a784'
|
||||
sha1sums=('78428269657bc080f8dbcd7fefb11970d7ed870a'
|
||||
'86ee8c8660f19de8141ac99cd6943964d97a1ed7'
|
||||
'63a850ab4196b9d06934f2b4a13acd9f7739bc67'
|
||||
'ed1f57ee661e5c7440efcaba7e51d2554709701c'
|
||||
'575e52f537e37eeaaaeb639268f9bfa394e7c58d'
|
||||
'855150096763600c970aa307c8241b96da33b9ed')
|
||||
|
||||
|
||||
|
@ -39,8 +38,6 @@ prepare() {
|
|||
patch -p1 -i ../archlinux-menu.patch
|
||||
# qmake refers to Qt5
|
||||
patch -p1 -i ../qt4.patch
|
||||
# fix build with GCC 6 (Fedora)
|
||||
patch -p1 -i ../kdelibs-gcc6.patch
|
||||
# fix unclickable plasmoid buttons on ARM
|
||||
patch -p1 -i ../arm-coronaoffscreen-input-fixes.diff
|
||||
}
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
diff -up kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp.gcc6 kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp
|
||||
--- kdelibs-4.14.17/khtml/dom/dom2_traversal.h.gcc6 2016-02-12 19:27:45.874888043 -0600
|
||||
+++ kdelibs-4.14.17/khtml/dom/dom2_traversal.h 2016-02-12 19:26:11.777418711 -0600
|
||||
@@ -214,7 +214,7 @@ public:
|
||||
*
|
||||
*/
|
||||
enum ShowCode {
|
||||
- SHOW_ALL = 0xFFFFFFFF,
|
||||
+ SHOW_ALL = (int)0xFFFFFFFF,
|
||||
SHOW_ELEMENT = 0x00000001,
|
||||
SHOW_ATTRIBUTE = 0x00000002,
|
||||
SHOW_TEXT = 0x00000004,
|
||||
--- kdelibs-4.14.17/ConfigureChecks.cmake.gcc6 2016-02-11 23:06:08.000000000 -0600
|
||||
+++ kdelibs-4.14.17/ConfigureChecks.cmake 2016-02-12 19:14:07.707788177 -0600
|
||||
@@ -244,7 +244,7 @@ check_prototype_exists(unsetenv stdlib.h
|
||||
check_prototype_exists(usleep unistd.h HAVE_USLEEP_PROTO)
|
||||
check_prototype_exists(initgroups "unistd.h;sys/types.h;unistd.h;grp.h" HAVE_INITGROUPS_PROTO)
|
||||
check_prototype_exists(setreuid unistd.h HAVE_SETREUID_PROTO)
|
||||
-check_prototype_exists(trunc math.h HAVE_TRUNC)
|
||||
+check_prototype_exists(truncf math.h HAVE_TRUNC)
|
||||
|
||||
# check for existing datatypes
|
||||
|
Loading…
Reference in a new issue