mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/python to 3.8.3-1
This commit is contained in:
parent
1c4bc87a0c
commit
c4fc04c993
2 changed files with 5 additions and 67 deletions
|
@ -1,57 +0,0 @@
|
|||
From 84fdbc156ed424d030686de350fbfc6c3593263f Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <84fdbc156ed424d030686de350fbfc6c3593263f.1537028533.git.jan.steffens@gmail.com>
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Sat, 15 Sep 2018 18:22:06 +0200
|
||||
Subject: [PATCH] compileall: Fix ddir when recursing
|
||||
|
||||
---
|
||||
Lib/compileall.py | 14 +++++++++-----
|
||||
1 file changed, 9 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/Lib/compileall.py b/Lib/compileall.py
|
||||
index 72592126d7..70e246fd96 100644
|
||||
--- a/Lib/compileall.py
|
||||
+++ b/Lib/compileall.py
|
||||
@@ -45,12 +45,16 @@ def _walk_dir(dir, ddir=None, maxlevels=10, quiet=0):
|
||||
else:
|
||||
dfile = None
|
||||
if not os.path.isdir(fullname):
|
||||
- yield fullname
|
||||
+ yield fullname, ddir
|
||||
elif (maxlevels > 0 and name != os.curdir and name != os.pardir and
|
||||
os.path.isdir(fullname) and not os.path.islink(fullname)):
|
||||
yield from _walk_dir(fullname, ddir=dfile,
|
||||
maxlevels=maxlevels - 1, quiet=quiet)
|
||||
|
||||
+def _compile_one(file_ddir, *args, **kwargs):
|
||||
+ file, ddir = file_ddir
|
||||
+ return compile_file(file, ddir, *args, **kwargs)
|
||||
+
|
||||
def compile_dir(dir, maxlevels=10, ddir=None, force=False, rx=None,
|
||||
quiet=0, legacy=False, optimize=-1, workers=1,
|
||||
invalidation_mode=py_compile.PycInvalidationMode.TIMESTAMP):
|
||||
@@ -79,17 +83,17 @@ def compile_dir(dir, maxlevels=10, ddir=None, force=False, rx=None,
|
||||
if workers is not None and workers != 1 and ProcessPoolExecutor is not None:
|
||||
workers = workers or None
|
||||
with ProcessPoolExecutor(max_workers=workers) as executor:
|
||||
- results = executor.map(partial(compile_file,
|
||||
- ddir=ddir, force=force,
|
||||
+ results = executor.map(partial(_compile_one,
|
||||
+ force=force,
|
||||
rx=rx, quiet=quiet,
|
||||
legacy=legacy,
|
||||
optimize=optimize,
|
||||
invalidation_mode=invalidation_mode),
|
||||
files)
|
||||
success = min(results, default=True)
|
||||
else:
|
||||
- for file in files:
|
||||
- if not compile_file(file, ddir, force, rx, quiet,
|
||||
+ for file_ddir in files:
|
||||
+ if not _compile_one(file_ddir, force, rx, quiet,
|
||||
legacy, optimize, invalidation_mode):
|
||||
success = False
|
||||
return success
|
||||
--
|
||||
2.18.0
|
||||
|
|
@ -13,8 +13,8 @@ shopt -s extglob
|
|||
|
||||
pkgbase=python
|
||||
pkgname=(python python-tests)
|
||||
pkgver=3.8.2
|
||||
pkgrel=2
|
||||
pkgver=3.8.3
|
||||
pkgrel=1
|
||||
_pybasever=${pkgver%.*}
|
||||
pkgdesc="Next generation of the python high-level scripting language"
|
||||
arch=('x86_64')
|
||||
|
@ -22,20 +22,15 @@ license=('custom')
|
|||
url="https://www.python.org/"
|
||||
depends=('expat' 'bzip2' 'gdbm' 'openssl' 'libffi' 'zlib' 'libnsl')
|
||||
makedepends=('tk' 'sqlite' 'bluez-libs' 'mpdecimal' 'llvm' 'gdb' 'xorg-server-xvfb')
|
||||
source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"{,.asc}
|
||||
0001-compileall-Fix-ddir-when-recursing.patch)
|
||||
sha512sums=('ca37ad0e7c5845f5f228566aa8ff654a8f428c7d4a5aaabff29baebb0ca3219b31ba8bb2607f89e37cf3fc564f023b8407e53a4f2c47bd99122c1cc222613e37'
|
||||
'SKIP'
|
||||
'ebd04c3b6d41321b1f0d439d356e0ce463760db55dc64109854c70d017cf56608aa19de9fc4a21bf840795ff202b4703444f9af8074b661780798c17e03089ff')
|
||||
source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"{,.asc})
|
||||
sha512sums=('3103bd8d944f3905eee3a2b52fd1f5c7dee380f9c5a99ad35a401fcba5a9117c3860ecec5cb47a92712c6549442fd2fa553a15c5657241dd09f5d00b9ed4f0f4'
|
||||
'SKIP')
|
||||
validpgpkeys=('0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D' # Ned Deily (Python release signing key) <nad@python.org>
|
||||
'E3FF2839C048B25C084DEBE9B26995E310250568') # Łukasz Langa (GPG langa.pl) <lukasz@langa.pl>
|
||||
|
||||
prepare() {
|
||||
cd Python-${pkgver}
|
||||
|
||||
# FS#59997
|
||||
patch -p1 -i ../0001-compileall-Fix-ddir-when-recursing.patch
|
||||
|
||||
# https://bugs.python.org/issue34587
|
||||
sed -i -e "s|testCongestion|disabled_&|" Lib/test/test_socket.py
|
||||
|
||||
|
|
Loading…
Reference in a new issue