mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
removed community/openssh-askpass
This commit is contained in:
parent
8d970d7b41
commit
c522332f1d
3 changed files with 0 additions and 68 deletions
|
@ -1,39 +0,0 @@
|
|||
# Maintainer: schuay <jakob.gruber@gmail.com>
|
||||
# Previous Maintainer: TDY <tdy@gmx.com>
|
||||
# Contributor: Massimiliano Torromeo <Massimiliano.Torromeo AT gmail DOT com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix qreal usage on ARM
|
||||
|
||||
pkgname=openssh-askpass
|
||||
pkgver=2.0.3
|
||||
pkgrel=3
|
||||
pkgdesc='A plasma-like passphrase dialog for ssh'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://hugo.pereira.free.fr/software/index.php?page=package&package_list=software_list_qt4&package=openssh-askpass&full=0'
|
||||
license=('GPL')
|
||||
depends=('openssh' 'qt4' 'xcb-util-keysyms')
|
||||
makedepends=('cmake')
|
||||
provides=('x11-ssh-askpass')
|
||||
source=("http://hugo.pereira.free.fr/software/tgz/$pkgname-$pkgver.tar.gz"
|
||||
'arm.patch')
|
||||
install=$pkgname.install
|
||||
md5sums=('b5abdeef5f09256545f8643aca111426'
|
||||
'834cd4ee728226b219d6c747a1b6a9b2')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
patch -p1 -i "${srcdir}"/arm.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
|
||||
cmake -DCMAKE_INSTALL_PREFIX="/usr" ..
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver/build"
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
|
@ -1,24 +0,0 @@
|
|||
diff -urN a/base-qt/CustomPixmap.cpp b/base-qt/CustomPixmap.cpp
|
||||
--- a/base-qt/CustomPixmap.cpp 2014-09-26 02:05:51.000000000 -0600
|
||||
+++ b/base-qt/CustomPixmap.cpp 2015-06-21 11:36:25.050199863 -0600
|
||||
@@ -208,7 +208,7 @@
|
||||
|
||||
Debug::Throw( "CustomPixmap::highlighted.\n" );
|
||||
if( opacity <= 0 ) return *this;
|
||||
- opacity = qMin( opacity, 1.0 );
|
||||
+ opacity = qMin( (double)opacity, 1.0 );
|
||||
|
||||
// compute mask
|
||||
QPixmap mask( *this );
|
||||
diff -urN a/base-qt/PathEditor_p.h b/base-qt/PathEditor_p.h
|
||||
--- a/base-qt/PathEditor_p.h 2014-09-12 02:43:11.000000000 -0600
|
||||
+++ b/base-qt/PathEditor_p.h 2015-06-21 11:36:41.300204916 -0600
|
||||
@@ -68,7 +68,7 @@
|
||||
{ mouseOver_ = value; }
|
||||
|
||||
//! border width
|
||||
- static const qreal BorderWidth;
|
||||
+ static const double BorderWidth;
|
||||
|
||||
protected:
|
||||
|
|
@ -1,5 +0,0 @@
|
|||
post_upgrade() {
|
||||
if [[ $(vercmp 2.0.3-3 "$2") -eq 1 ]]; then
|
||||
echo "The SSH_ASKPASS environment variable is not exported by default anymore. Set it in /etc/profile to revert to the previous behavior"
|
||||
fi
|
||||
}
|
Loading…
Reference in a new issue