mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/uboot-sunxi to 2017.01-1
This commit is contained in:
parent
9d00857653
commit
c52b2b3dbb
2 changed files with 6 additions and 47 deletions
|
@ -1,38 +0,0 @@
|
||||||
From a4777cc3ee0d37d336e2769b00ca57ef67be78de Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
Date: Fri, 2 Jan 2015 20:16:57 -0700
|
|
||||||
Subject: [PATCH] arch linux arm modifications
|
|
||||||
|
|
||||||
---
|
|
||||||
include/config_distro_defaults.h | 3 +++
|
|
||||||
include/configs/sunxi-common.h | 2 +-
|
|
||||||
2 files changed, 4 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/include/config_distro_defaults.h b/include/config_distro_defaults.h
|
|
||||||
index 766a212..0df77cd 100644
|
|
||||||
--- a/include/config_distro_defaults.h
|
|
||||||
+++ b/include/config_distro_defaults.h
|
|
||||||
@@ -57,4 +57,7 @@
|
|
||||||
#define CONFIG_SUPPORT_RAW_INITRD
|
|
||||||
#define CONFIG_ENV_VARS_UBOOT_CONFIG
|
|
||||||
|
|
||||||
+#define CONFIG_CMD_PART
|
|
||||||
+#define CONFIG_PARTITION_UUIDS
|
|
||||||
+
|
|
||||||
#endif /* _CONFIG_CMD_DISTRO_DEFAULTS_H */
|
|
||||||
diff --git a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
|
|
||||||
index 2406115..8c64bbd 100644
|
|
||||||
--- a/include/configs/sunxi-common.h
|
|
||||||
+++ b/include/configs/sunxi-common.h
|
|
||||||
@@ -173,7 +173,7 @@
|
|
||||||
#define CONFIG_SYS_NO_FLASH
|
|
||||||
|
|
||||||
#define CONFIG_SYS_MONITOR_LEN (768 << 10) /* 768 KiB */
|
|
||||||
-#define CONFIG_IDENT_STRING " Allwinner Technology"
|
|
||||||
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
|
|
||||||
#define CONFIG_DISPLAY_BOARDINFO
|
|
||||||
|
|
||||||
#define CONFIG_ENV_OFFSET (544 << 10) /* (8 + 24 + 512) KiB */
|
|
||||||
--
|
|
||||||
2.8.3
|
|
||||||
|
|
|
@ -17,19 +17,17 @@ pkgname=('uboot-a10-olinuxino-lime'
|
||||||
'uboot-pcduino'
|
'uboot-pcduino'
|
||||||
'uboot-pcduino3'
|
'uboot-pcduino3'
|
||||||
'uboot-pcduino3-nano')
|
'uboot-pcduino3-nano')
|
||||||
pkgver=2016.07
|
pkgver=2017.01
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="http://git.denx.de/u-boot.git/"
|
url="http://git.denx.de/u-boot.git/"
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
makedepends=('git' 'bc' 'dtc')
|
makedepends=('git' 'bc' 'dtc' 'python2')
|
||||||
backup=(boot/boot.txt boot/boot.scr)
|
backup=(boot/boot.txt boot/boot.scr)
|
||||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
||||||
'0001-arch-linux-arm-modifications.patch'
|
|
||||||
'boot.txt'
|
'boot.txt'
|
||||||
'mkscr')
|
'mkscr')
|
||||||
md5sums=('425a3fa610a7d972e5092a0e92276c70'
|
md5sums=('ad2d82d5b4fa548b2b95bbc26c9bad79'
|
||||||
'a9303cc01e222117a870e1166266e02c'
|
|
||||||
'b05eae006e4e35176ee3032eba1c4663'
|
'b05eae006e4e35176ee3032eba1c4663'
|
||||||
'021623a04afd29ac3f368977140cfbfd')
|
'021623a04afd29ac3f368977140cfbfd')
|
||||||
|
|
||||||
|
@ -50,20 +48,19 @@ boards=('A10-OLinuXino-Lime'
|
||||||
prepare() {
|
prepare() {
|
||||||
cd u-boot-${pkgver}
|
cd u-boot-${pkgver}
|
||||||
|
|
||||||
git apply ../0001-arch-linux-arm-modifications.patch
|
sed -i 's/env python$/&2/' tools/binman/binman{,.py}
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd u-boot-${pkgver}
|
cd u-boot-${pkgver}
|
||||||
|
|
||||||
unset CFLAGS
|
unset CFLAGS CXXFLAGS LDFLAGS
|
||||||
unset CXXFLAGS
|
|
||||||
unset LDFLAGS
|
|
||||||
|
|
||||||
for i in ${boards[@]}; do
|
for i in ${boards[@]}; do
|
||||||
mkdir ../bin_${i}
|
mkdir ../bin_${i}
|
||||||
make distclean
|
make distclean
|
||||||
make ${i}_config
|
make ${i}_config
|
||||||
|
echo 'CONFIG_IDENT_STRING=" Arch Linux ARM"' >> .config
|
||||||
make EXTRAVERSION=-${pkgrel}
|
make EXTRAVERSION=-${pkgrel}
|
||||||
mv u-boot-sunxi-with-spl.bin ../bin_${i}
|
mv u-boot-sunxi-with-spl.bin ../bin_${i}
|
||||||
done
|
done
|
||||||
|
|
Loading…
Reference in a new issue