mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-usbarmory to 3.19.3-2
This commit is contained in:
parent
c039a97012
commit
c6032a6d68
3 changed files with 104 additions and 38 deletions
|
@ -1,32 +1,37 @@
|
|||
From 345e2b50bcf13c5dac5c19e71abf0fd37a9d7b68 Mon Sep 17 00:00:00 2001
|
||||
From b5497a9288986f0bc5fb005e38500cc413b8aa21 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 7 Mar 2015 16:51:15 -0700
|
||||
Subject: [PATCH] USB armory support
|
||||
|
||||
---
|
||||
arch/arm/boot/dts/Makefile | 1 +
|
||||
arch/arm/boot/dts/imx53-usbarmory.dts | 197 ++++++++++++++++++++++++++++++++++
|
||||
2 files changed, 198 insertions(+)
|
||||
arch/arm/boot/dts/Makefile | 2 +
|
||||
arch/arm/boot/dts/imx53-usbarmory-host_mode.dts | 17 ++
|
||||
arch/arm/boot/dts/imx53-usbarmory.dts | 13 ++
|
||||
arch/arm/boot/dts/imx53-usbarmory.dtsi | 211 ++++++++++++++++++++++++
|
||||
4 files changed, 243 insertions(+)
|
||||
create mode 100644 arch/arm/boot/dts/imx53-usbarmory-host_mode.dts
|
||||
create mode 100644 arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
create mode 100644 arch/arm/boot/dts/imx53-usbarmory.dtsi
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 91bd5bd..d10ac9f 100644
|
||||
index 91bd5bd..3626ddd 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -213,6 +213,7 @@ dtb-$(CONFIG_ARCH_MXC) += \
|
||||
@@ -213,6 +213,8 @@ dtb-$(CONFIG_ARCH_MXC) += \
|
||||
imx53-smd.dtb \
|
||||
imx53-tx53-x03x.dtb \
|
||||
imx53-tx53-x13x.dtb \
|
||||
+ imx53-usbarmory.dtb \
|
||||
+ imx53-usbarmory-host_mode.dtb \
|
||||
imx53-voipac-bsb.dtb \
|
||||
imx6dl-aristainetos_4.dtb \
|
||||
imx6dl-aristainetos_7.dtb \
|
||||
diff --git a/arch/arm/boot/dts/imx53-usbarmory.dts b/arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
diff --git a/arch/arm/boot/dts/imx53-usbarmory-host_mode.dts b/arch/arm/boot/dts/imx53-usbarmory-host_mode.dts
|
||||
new file mode 100644
|
||||
index 0000000..ff411be
|
||||
index 0000000..a94cb1d
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
@@ -0,0 +1,197 @@
|
||||
+++ b/arch/arm/boot/dts/imx53-usbarmory-host_mode.dts
|
||||
@@ -0,0 +1,17 @@
|
||||
+/*
|
||||
+ * Copyright 2015 Inverse Path, S.r.l.
|
||||
+ *
|
||||
|
@ -39,6 +44,47 @@ index 0000000..ff411be
|
|||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+#include "imx53-usbarmory.dtsi"
|
||||
+
|
||||
+&usbotg {
|
||||
+ dr_mode = "host";
|
||||
+};
|
||||
diff --git a/arch/arm/boot/dts/imx53-usbarmory.dts b/arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
new file mode 100644
|
||||
index 0000000..c86a4d8
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
@@ -0,0 +1,13 @@
|
||||
+/*
|
||||
+ * Copyright 2015 Inverse Path, S.r.l.
|
||||
+ *
|
||||
+ * The code contained herein is licensed under the GNU General Public
|
||||
+ * License. You may obtain a copy of the GNU General Public License
|
||||
+ * Version 2 or later at the following locations:
|
||||
+ *
|
||||
+ * http://www.opensource.org/licenses/gpl-license.html
|
||||
+ * http://www.gnu.org/copyleft/gpl.html
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+#include "imx53-usbarmory.dtsi"
|
||||
diff --git a/arch/arm/boot/dts/imx53-usbarmory.dtsi b/arch/arm/boot/dts/imx53-usbarmory.dtsi
|
||||
new file mode 100644
|
||||
index 0000000..ec32fac
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx53-usbarmory.dtsi
|
||||
@@ -0,0 +1,211 @@
|
||||
+/*
|
||||
+ * Copyright 2015 Inverse Path, S.r.l.
|
||||
+ *
|
||||
+ * The code contained herein is licensed under the GNU General Public
|
||||
+ * License. You may obtain a copy of the GNU General Public License
|
||||
+ * Version 2 or later at the following locations:
|
||||
+ *
|
||||
+ * http://www.opensource.org/licenses/gpl-license.html
|
||||
+ * http://www.gnu.org/copyleft/gpl.html
|
||||
+ */
|
||||
+
|
||||
+#include "imx53.dtsi"
|
||||
+
|
||||
+/ {
|
||||
|
@ -81,6 +127,21 @@ index 0000000..ff411be
|
|||
+ };
|
||||
+};
|
||||
+
|
||||
+&cpu0 {
|
||||
+ device_type = "cpu";
|
||||
+ compatible = "arm,cortex-a8";
|
||||
+ reg = <0x0>;
|
||||
+ clocks = <&clks IMX5_CLK_ARM>;
|
||||
+ clock-latency = <61036>;
|
||||
+ voltage-tolerance = <5>;
|
||||
+ operating-points = <
|
||||
+ /* kHz */
|
||||
+ 166666 850000
|
||||
+ 400000 900000
|
||||
+ 800000 1050000
|
||||
+ >;
|
||||
+};
|
||||
+
|
||||
+&esdhc1 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_esdhc1>;
|
||||
|
@ -225,5 +286,5 @@ index 0000000..ff411be
|
|||
+ };
|
||||
+};
|
||||
--
|
||||
2.3.4
|
||||
2.3.5
|
||||
|
||||
|
|
|
@ -9,8 +9,8 @@ _srcname=linux-3.19
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="USB armory"
|
||||
pkgver=3.19.3
|
||||
pkgrel=1
|
||||
rcnrel=armv7-x3
|
||||
pkgrel=2
|
||||
rcnrel=armv7-x4
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
|
@ -25,10 +25,10 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
|
|||
'config')
|
||||
md5sums=('d3fc8316d4d4d04b65cbc2d70799e763'
|
||||
'1fec75551b2f55fced43df8394b1fd9a'
|
||||
'ed423c27f65c9b070deab31e761c0eeb'
|
||||
'3b7b7348d4769c9d3f234c5d16e9ce9a'
|
||||
'SKIP'
|
||||
'54a04c50b97515c057c8889a83a30974'
|
||||
'47604e349d7809f0c71f54de1ecb66df')
|
||||
'8c459fc0fd6cf84e68e32a99ddc8e6ae'
|
||||
'd24bccca87d04a4c5aafe96e6f058d00')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
@ -112,7 +112,7 @@ _package() {
|
|||
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot/dtbs}
|
||||
make INSTALL_MOD_PATH="${pkgdir}" modules_install
|
||||
cp arch/$KARCH/boot/zImage "${pkgdir}/boot/zImage"
|
||||
cp arch/$KARCH/boot/dts/imx53-usbarmory.dtb "${pkgdir}/boot/dtbs"
|
||||
cp arch/$KARCH/boot/dts/imx53-usbarmory{,-host_mode}.dtb "${pkgdir}/boot/dtbs"
|
||||
|
||||
# set correct depmod command for install
|
||||
sed \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 3.19.0-1 Kernel Configuration
|
||||
# Linux/arm 3.19.3-2 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARM_HAS_SG_CHAIN=y
|
||||
|
@ -550,7 +550,7 @@ CONFIG_CPU_FREQ_GOV_CONSERVATIVE=m
|
|||
#
|
||||
# CPU frequency scaling drivers
|
||||
#
|
||||
CONFIG_CPUFREQ_DT=m
|
||||
CONFIG_CPUFREQ_DT=y
|
||||
# CONFIG_ARM_KIRKWOOD_CPUFREQ is not set
|
||||
|
||||
#
|
||||
|
@ -1674,22 +1674,10 @@ CONFIG_POWER_SUPPLY=y
|
|||
# CONFIG_POWER_RESET is not set
|
||||
CONFIG_POWER_AVS=y
|
||||
# CONFIG_HWMON is not set
|
||||
CONFIG_THERMAL=m
|
||||
CONFIG_THERMAL_OF=y
|
||||
CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE=y
|
||||
# CONFIG_THERMAL is not set
|
||||
# CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE is not set
|
||||
# CONFIG_THERMAL_DEFAULT_GOV_FAIR_SHARE is not set
|
||||
# CONFIG_THERMAL_DEFAULT_GOV_USER_SPACE is not set
|
||||
CONFIG_THERMAL_GOV_FAIR_SHARE=y
|
||||
CONFIG_THERMAL_GOV_STEP_WISE=y
|
||||
# CONFIG_THERMAL_GOV_BANG_BANG is not set
|
||||
CONFIG_THERMAL_GOV_USER_SPACE=y
|
||||
CONFIG_CPU_THERMAL=y
|
||||
# CONFIG_CLOCK_THERMAL is not set
|
||||
# CONFIG_THERMAL_EMULATION is not set
|
||||
|
||||
#
|
||||
# Texas Instruments thermal drivers
|
||||
#
|
||||
CONFIG_WATCHDOG=y
|
||||
CONFIG_WATCHDOG_CORE=y
|
||||
# CONFIG_WATCHDOG_NOWAYOUT is not set
|
||||
|
@ -2555,7 +2543,24 @@ CONFIG_F2FS_FS_XATTR=y
|
|||
CONFIG_F2FS_FS_POSIX_ACL=y
|
||||
CONFIG_F2FS_FS_SECURITY=y
|
||||
# CONFIG_F2FS_CHECK_FS is not set
|
||||
# CONFIG_AUFS_FS is not set
|
||||
CONFIG_AUFS_FS=y
|
||||
CONFIG_AUFS_BRANCH_MAX_127=y
|
||||
# CONFIG_AUFS_BRANCH_MAX_511 is not set
|
||||
# CONFIG_AUFS_BRANCH_MAX_1023 is not set
|
||||
# CONFIG_AUFS_BRANCH_MAX_32767 is not set
|
||||
CONFIG_AUFS_SBILIST=y
|
||||
CONFIG_AUFS_HNOTIFY=y
|
||||
CONFIG_AUFS_HFSNOTIFY=y
|
||||
CONFIG_AUFS_EXPORT=y
|
||||
CONFIG_AUFS_XATTR=y
|
||||
CONFIG_AUFS_FHSM=y
|
||||
CONFIG_AUFS_RDU=y
|
||||
CONFIG_AUFS_SHWH=y
|
||||
CONFIG_AUFS_BR_RAMFS=y
|
||||
CONFIG_AUFS_BR_FUSE=y
|
||||
CONFIG_AUFS_POLL=y
|
||||
CONFIG_AUFS_BDEV_LOOP=y
|
||||
# CONFIG_AUFS_DEBUG is not set
|
||||
CONFIG_NETWORK_FILESYSTEMS=y
|
||||
CONFIG_NFS_FS=y
|
||||
CONFIG_NFS_V2=y
|
||||
|
@ -2854,7 +2859,7 @@ CONFIG_CRYPTO_MANAGER=y
|
|||
CONFIG_CRYPTO_MANAGER2=y
|
||||
CONFIG_CRYPTO_USER=m
|
||||
CONFIG_CRYPTO_MANAGER_DISABLE_TESTS=y
|
||||
# CONFIG_CRYPTO_GF128MUL is not set
|
||||
CONFIG_CRYPTO_GF128MUL=m
|
||||
# CONFIG_CRYPTO_NULL is not set
|
||||
CONFIG_CRYPTO_WORKQUEUE=y
|
||||
CONFIG_CRYPTO_CRYPTD=y
|
||||
|
@ -2879,7 +2884,7 @@ CONFIG_CRYPTO_CTR=m
|
|||
CONFIG_CRYPTO_ECB=y
|
||||
# CONFIG_CRYPTO_LRW is not set
|
||||
# CONFIG_CRYPTO_PCBC is not set
|
||||
# CONFIG_CRYPTO_XTS is not set
|
||||
CONFIG_CRYPTO_XTS=m
|
||||
|
||||
#
|
||||
# Hash modes
|
||||
|
@ -2907,8 +2912,8 @@ CONFIG_CRYPTO_SHA1=y
|
|||
CONFIG_CRYPTO_SHA1_ARM=y
|
||||
CONFIG_CRYPTO_SHA1_ARM_NEON=y
|
||||
CONFIG_CRYPTO_SHA256=y
|
||||
# CONFIG_CRYPTO_SHA512 is not set
|
||||
# CONFIG_CRYPTO_SHA512_ARM_NEON is not set
|
||||
CONFIG_CRYPTO_SHA512=y
|
||||
CONFIG_CRYPTO_SHA512_ARM_NEON=y
|
||||
# CONFIG_CRYPTO_TGR192 is not set
|
||||
# CONFIG_CRYPTO_WP512 is not set
|
||||
|
||||
|
|
Loading…
Reference in a new issue