mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added core/linux-firmware
This commit is contained in:
parent
512f287353
commit
c62aeca80b
2 changed files with 296 additions and 0 deletions
|
@ -0,0 +1,123 @@
|
|||
From 7eec2b56f54c778d5bd6e7aea49ee03e3b76e769 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Fri, 22 Jan 2021 20:36:23 +0000
|
||||
Subject: [PATCH v2] Add support for compressing firmware in copy-firmware.sh
|
||||
|
||||
As of kernel 5.3 there's initial support for loading compressed firmware.
|
||||
At this stage the only supported compression methis is "xz -C crc32" but
|
||||
this option brings significant benefits.
|
||||
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
|
||||
v2: quote filename for xz command
|
||||
|
||||
Makefile | 4 ++++
|
||||
copy-firmware.sh | 47 +++++++++++++++++++++++++++++++----------------
|
||||
2 files changed, 35 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index e1c362f..9a48471 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -11,3 +11,7 @@ check:
|
||||
install:
|
||||
mkdir -p $(DESTDIR)$(FIRMWAREDIR)
|
||||
./copy-firmware.sh $(DESTDIR)$(FIRMWAREDIR)
|
||||
+
|
||||
+installcompress:
|
||||
+ mkdir -p $(DESTDIR)$(FIRMWAREDIR)
|
||||
+ ./copy-firmware.sh -C $(DESTDIR)$(FIRMWAREDIR)
|
||||
diff --git a/copy-firmware.sh b/copy-firmware.sh
|
||||
index 9b46b63..0dd2e5c 100755
|
||||
--- a/copy-firmware.sh
|
||||
+++ b/copy-firmware.sh
|
||||
@@ -6,6 +6,7 @@
|
||||
|
||||
verbose=:
|
||||
prune=no
|
||||
+compress=no
|
||||
|
||||
while test $# -gt 0; do
|
||||
case $1 in
|
||||
@@ -19,6 +20,11 @@ while test $# -gt 0; do
|
||||
shift
|
||||
;;
|
||||
|
||||
+ -C | --compress)
|
||||
+ compress=yes
|
||||
+ shift
|
||||
+ ;;
|
||||
+
|
||||
*)
|
||||
if test "x$destdir" != "x"; then
|
||||
echo "ERROR: unknown command-line options: $@"
|
||||
@@ -31,40 +37,49 @@ while test $# -gt 0; do
|
||||
esac
|
||||
done
|
||||
|
||||
+if test "x$compress" = "xyes"; then
|
||||
+ cmpxtn=.xz
|
||||
+ grep '^File:' WHENCE | sed -e's/^File: *//g' -e's/"//g' | while read f; do
|
||||
+ test -f "$f" || continue
|
||||
+ $verbose "compressing $f"
|
||||
+ xz -C crc32 "$f"
|
||||
+ done
|
||||
+fi
|
||||
+
|
||||
grep '^File:' WHENCE | sed -e's/^File: *//g' -e's/"//g' | while read f; do
|
||||
- test -f "$f" || continue
|
||||
- $verbose "copying file $f"
|
||||
- mkdir -p $destdir/$(dirname "$f")
|
||||
- cp -d "$f" $destdir/"$f"
|
||||
+ test -f "$f$cmpxtn" || continue
|
||||
+ $verbose "copying file $f$cmpxtn"
|
||||
+ mkdir -p $destdir/$(dirname "$f$cmpxtn")
|
||||
+ cp -d "$f$cmpxtn" $destdir/"$f$cmpxtn"
|
||||
done
|
||||
|
||||
grep -E '^Link:' WHENCE | sed -e's/^Link: *//g' -e's/-> //g' | while read f d; do
|
||||
- if test -L "$f"; then
|
||||
- test -f "$destdir/$f" && continue
|
||||
- $verbose "copying link $f"
|
||||
- mkdir -p $destdir/$(dirname "$f")
|
||||
+ if test -L "$f$cmpxtn"; then
|
||||
+ test -f "$destdir/$f$cmpxtn" && continue
|
||||
+ $verbose "copying link $f$cmpxtn"
|
||||
+ mkdir -p $destdir/$(dirname "$f$cmpxtn")
|
||||
cp -d "$f" $destdir/"$f"
|
||||
|
||||
if test "x$d" != "x"; then
|
||||
- target=`readlink "$f"`
|
||||
+ target=`readlink "$f$cmpxtn"`
|
||||
|
||||
if test "x$target" != "x$d"; then
|
||||
$verbose "WARNING: inconsistent symlink target: $target != $d"
|
||||
else
|
||||
if test "x$prune" != "xyes"; then
|
||||
- $verbose "WARNING: unneeded symlink detected: $f"
|
||||
+ $verbose "WARNING: unneeded symlink detected: $f$cmpxtn"
|
||||
else
|
||||
- $verbose "WARNING: pruning unneeded symlink $f"
|
||||
- rm -f "$f"
|
||||
+ $verbose "WARNING: pruning unneeded symlink $f$cmpxtn"
|
||||
+ rm -f "$f$cmpxtn"
|
||||
fi
|
||||
fi
|
||||
else
|
||||
- $verbose "WARNING: missing target for symlink $f"
|
||||
+ $verbose "WARNING: missing target for symlink $f$cmpxtn"
|
||||
fi
|
||||
else
|
||||
- $verbose "creating link $f -> $d"
|
||||
- mkdir -p $destdir/$(dirname "$f")
|
||||
- ln -sf "$d" "$destdir/$f"
|
||||
+ $verbose "creating link $f$cmpxtn -> $d$cmpxtn"
|
||||
+ mkdir -p $destdir/$(dirname "$f$cmpxtn")
|
||||
+ ln -sf "$d$cmpxtn" "$destdir/$f$cmpxtn"
|
||||
fi
|
||||
done
|
||||
|
||||
--
|
||||
2.29.2
|
||||
|
173
core/linux-firmware/PKGBUILD
Normal file
173
core/linux-firmware/PKGBUILD
Normal file
|
@ -0,0 +1,173 @@
|
|||
# Maintainer: Thomas Bächler <thomas@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - don't compress firmware for kernels older than 5.3
|
||||
|
||||
pkgbase=linux-firmware
|
||||
pkgname=(linux-firmware-whence linux-firmware amd-ucode
|
||||
linux-firmware-{nfp,mellanox,marvell,qcom,liquidio,qlogic,bnx2x}
|
||||
)
|
||||
#_tag=20211216
|
||||
_commit=0c6a7b3bf728b95c8b7b95328f94335e2bb2c967
|
||||
pkgver=20220119.0c6a7b3
|
||||
pkgrel=2.1
|
||||
pkgdesc="Firmware files for Linux"
|
||||
url="https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git;a=summary"
|
||||
license=('GPL2' 'GPL3' 'custom')
|
||||
arch=('any')
|
||||
makedepends=('git')
|
||||
options=(!strip)
|
||||
source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git#commit=${_commit}?signed"
|
||||
0001-Add-support-for-compressing-firmware-in-copy-firmware.patch)
|
||||
sha256sums=('SKIP'
|
||||
'41c73f88ac68a3aef01fd406ce6cdb87555c65e4816dab12df10740875551aa7')
|
||||
validpgpkeys=('4CDE8575E547BF835FE15807A31B6BD72486CFD6') # Josh Boyer <jwboyer@fedoraproject.org>
|
||||
|
||||
_backports=(
|
||||
)
|
||||
|
||||
|
||||
_pick() {
|
||||
local p="$1" f d; shift
|
||||
for f; do
|
||||
d="$srcdir/$p/${f#$pkgdir/}"
|
||||
mkdir -p "$(dirname "$d")"
|
||||
mv "$f" "$d"
|
||||
rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
|
||||
done
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd ${pkgbase}
|
||||
|
||||
local _c
|
||||
for _c in "${_backports[@]}"; do
|
||||
git log --oneline -1 "${_c}"
|
||||
git cherry-pick -n "${_c}"
|
||||
done
|
||||
|
||||
# add firmware compression support - patch taken from Fedora
|
||||
patch -Np1 -i ../0001-Add-support-for-compressing-firmware-in-copy-firmware.patch
|
||||
}
|
||||
|
||||
pkgver() {
|
||||
cd ${pkgbase}
|
||||
|
||||
# Commit date + short rev
|
||||
echo $(TZ=UTC git show -s --pretty=%cd --date=format-local:%Y%m%d HEAD).$(git rev-parse --short HEAD)
|
||||
}
|
||||
|
||||
build() {
|
||||
mkdir -p kernel/x86/microcode
|
||||
cat ${pkgbase}/amd-ucode/microcode_amd*.bin > kernel/x86/microcode/AuthenticAMD.bin
|
||||
|
||||
# Reproducibility: set the timestamp on the bin file
|
||||
if [[ -n ${SOURCE_DATE_EPOCH} ]]; then
|
||||
touch -d @${SOURCE_DATE_EPOCH} kernel/x86/microcode/AuthenticAMD.bin
|
||||
fi
|
||||
|
||||
# Reproducibility: strip the inode and device numbers from the cpio archive
|
||||
echo kernel/x86/microcode/AuthenticAMD.bin |
|
||||
bsdtar --uid 0 --gid 0 -cnf - -T - |
|
||||
bsdtar --null -cf - --format=newc @- > amd-ucode.img
|
||||
}
|
||||
|
||||
package_linux-firmware-whence() {
|
||||
cd "$pkgbase"
|
||||
install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 WHENCE
|
||||
}
|
||||
|
||||
package_linux-firmware() {
|
||||
depends=('linux-firmware-whence')
|
||||
|
||||
cd ${pkgname}
|
||||
|
||||
make DESTDIR="${pkgdir}" FIRMWAREDIR=/usr/lib/firmware install
|
||||
|
||||
# Trigger a microcode reload for configurations not using early updates
|
||||
echo 'w /sys/devices/system/cpu/microcode/reload - - - - 1' |
|
||||
install -Dm644 /dev/stdin "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
|
||||
|
||||
install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 LICEN*
|
||||
|
||||
# split
|
||||
cd "$pkgdir"
|
||||
_pick linux-firmware-nfp usr/lib/firmware/netronome
|
||||
_pick linux-firmware-nfp usr/share/licenses/${pkgname}/LICENCE.Netronome
|
||||
|
||||
_pick linux-firmware-mellanox usr/lib/firmware/mellanox
|
||||
|
||||
_pick linux-firmware-marvell usr/lib/firmware/{libertas,mwl8k,mwlwifi,mrvl}
|
||||
_pick linux-firmware-marvell usr/share/licenses/${pkgname}/LICENCE.{Marvell,NXP}
|
||||
|
||||
_pick linux-firmware-qcom usr/lib/firmware/{qcom,a300_*}
|
||||
_pick linux-firmware-qcom usr/share/licenses/${pkgname}/LICENSE.qcom
|
||||
|
||||
_pick linux-firmware-liquidio usr/lib/firmware/liquidio
|
||||
_pick linux-firmware-liquidio usr/share/licenses/${pkgname}/LICENCE.cavium_liquidio
|
||||
|
||||
_pick linux-firmware-qlogic usr/lib/firmware/{qlogic,qed,ql2???_*,c{b,t,t2}fw-*}
|
||||
_pick linux-firmware-qlogic usr/share/licenses/${pkgname}/LICENCE.{qla1280,qla2xxx}
|
||||
|
||||
_pick linux-firmware-bnx2x usr/lib/firmware/bnx2x*
|
||||
}
|
||||
|
||||
package_amd-ucode() {
|
||||
pkgdesc="Microcode update image for AMD CPUs"
|
||||
license=(custom)
|
||||
|
||||
install -Dt "${pkgdir}/boot" -m644 amd-ucode.img
|
||||
|
||||
install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 ${pkgbase}/LICENSE.amd-ucode
|
||||
}
|
||||
|
||||
package_linux-firmware-nfp() {
|
||||
pkgdesc+=" - nfp / Firmware for Netronome Flow Processors"
|
||||
depends=('linux-firmware-whence')
|
||||
|
||||
mv -v linux-firmware-nfp/* "${pkgdir}"
|
||||
}
|
||||
|
||||
package_linux-firmware-mellanox() {
|
||||
pkgdesc+=" - mellanox / Firmware for Mellanox Spectrum switches"
|
||||
depends=('linux-firmware-whence')
|
||||
|
||||
mv -v linux-firmware-mellanox/* "${pkgdir}"
|
||||
}
|
||||
|
||||
package_linux-firmware-marvell() {
|
||||
pkgdesc+=" - marvell / Firmware for Marvell devices"
|
||||
depends=('linux-firmware-whence')
|
||||
|
||||
mv -v linux-firmware-marvell/* "${pkgdir}"
|
||||
}
|
||||
|
||||
package_linux-firmware-qcom() {
|
||||
pkgdesc+=" - qcom / Firmware for Qualcomm SoCs"
|
||||
depends=('linux-firmware-whence')
|
||||
|
||||
mv -v linux-firmware-qcom/* "${pkgdir}"
|
||||
}
|
||||
|
||||
package_linux-firmware-liquidio() {
|
||||
pkgdesc+=" - liquidio / Firmware for Cavium LiquidIO server adapters"
|
||||
depends=('linux-firmware-whence')
|
||||
|
||||
mv -v linux-firmware-liquidio/* "${pkgdir}"
|
||||
}
|
||||
|
||||
package_linux-firmware-qlogic() {
|
||||
pkgdesc+=" - qlogic / Firmware for QLogic devices"
|
||||
depends=('linux-firmware-whence')
|
||||
|
||||
mv -v linux-firmware-qlogic/* "${pkgdir}"
|
||||
}
|
||||
|
||||
package_linux-firmware-bnx2x() {
|
||||
pkgdesc+=" - bnx2x / Firmware for Broadcom NetXtreme II 10Gb ethernet adapters"
|
||||
depends=('linux-firmware-whence')
|
||||
|
||||
mv -v linux-firmware-bnx2x/* "${pkgdir}"
|
||||
}
|
||||
|
||||
# vim:set sw=2 et:
|
Loading…
Reference in a new issue