core/mkinitcpio to 30-1

This commit is contained in:
Kevin Mihelich 2021-02-20 17:19:54 +00:00
parent e59fcb8723
commit c638c50b54
2 changed files with 69 additions and 11 deletions

View file

@ -0,0 +1,53 @@
From 3e3db8f6f8efb5ed10181f2270479b3a10593eb4 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 20 Feb 2021 10:02:34 -0700
Subject: [PATCH] use gzip for compression by default
---
man/mkinitcpio.conf.5.txt | 2 +-
mkinitcpio | 2 +-
mkinitcpio.conf | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/man/mkinitcpio.conf.5.txt b/man/mkinitcpio.conf.5.txt
index 0383360..46538d2 100644
--- a/man/mkinitcpio.conf.5.txt
+++ b/man/mkinitcpio.conf.5.txt
@@ -55,7 +55,7 @@ Variables
Defines a program to filter the generated image through. The kernel
understands the compression formats yielded by the *zstd*, *gzip*, *bzip2*,
*lz4*, *lzop*, *lzma*, and *xz* compressors. If unspecified, this setting
- defaults to *zstd* compression. In order to create an uncompressed image,
+ defaults to *gzip* compression. In order to create an uncompressed image,
define this variable as *cat*.
+
It's not hard to realize that a filter such as a *tac* or *rev* will cause
diff --git a/mkinitcpio b/mkinitcpio
index 1f6a499..2067572 100755
--- a/mkinitcpio
+++ b/mkinitcpio
@@ -508,7 +508,7 @@ if [[ $_optgenimg ]]; then
die 'Unable to write to %s' "$_optgenimg"
fi
- _optcompress=${_optcompress:-${COMPRESSION:-zstd}}
+ _optcompress=${_optcompress:-${COMPRESSION:-gzip}}
if ! type -P "$_optcompress" >/dev/null; then
warning "Unable to locate compression method: %s" "$_optcompress"
_optcompress=cat
diff --git a/mkinitcpio.conf b/mkinitcpio.conf
index 3494fab..3c902f6 100644
--- a/mkinitcpio.conf
+++ b/mkinitcpio.conf
@@ -52,7 +52,7 @@ FILES=()
HOOKS=(base udev autodetect modconf block filesystems keyboard fsck)
# COMPRESSION
-# Use this to compress the initramfs image. By default, zstd compression
+# Use this to compress the initramfs image. By default, gazip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="zstd"
#COMPRESSION="gzip"
--
2.30.1

View file

@ -3,11 +3,11 @@
# Maintainer: Thomas Bächler <thomas@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - hold for breaking change to older kernels in version 30
# initramfs is changing to zstd, which is incompatible with < 5.10, revert this change
# - swap zstd for gzip in depends, remove gzip optdepend
# - patch to revert back to gzip for default compression
pkgname=mkinitcpio
pkgver=29
pkgver=30
pkgrel=1
pkgdesc="Modular initramfs image creation utility"
arch=('any')
@ -15,6 +15,7 @@ url="https://projects.archlinux.org/mkinitcpio.git/"
license=('GPL')
depends=('awk' 'mkinitcpio-busybox>=1.19.4-2' 'kmod' 'util-linux>=2.23' 'libarchive' 'coreutils'
'bash' 'diffutils' 'findutils' 'grep' 'filesystem>=2011.10-1' 'gzip' 'systemd')
makedepends=('asciidoc')
optdepends=('xz: Use lzma or xz compression for the initramfs image'
'bzip2: Use bzip2 compression for the initramfs image'
'lzop: Use lzo compression for the initramfs image'
@ -22,18 +23,22 @@ optdepends=('xz: Use lzma or xz compression for the initramfs image'
'mkinitcpio-nfs-utils: Support for root filesystem on NFS')
provides=('initramfs')
backup=('etc/mkinitcpio.conf')
source=("https://sources.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig})
source=("https://sources.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig}
'0001-use-gzip-for-compression-by-default.patch')
install=mkinitcpio.install
sha512sums=('cc03159f16ae12a0d1ebf6a1827f8cdaf73ad0910bf2b1b0f30b737b1cff472130eb41c3669c180291a9861c3c3167498d1f9d60cb9782aeb1ef1d0cd2156068'
'SKIP')
b2sums=('4303216cc3c020bf58491a18b13785660e08f418a333f5b975b29b1da4f6b4427f5bbda358018a34e6894217c6368fdf3fe73d361e770a4b6e40abb12ba2fd02'
'SKIP')
sha512sums=('ef43a8ddc01697fa43bede4eebad3271bbc89efa57ba7e4e9f321e8174ff2af74d857b308c5c0f37b42a91906c91c1b022f9a651c70d5d3e9dfc8dc441a60ee4'
'SKIP'
'a214bae7dc174500a6db1dd4ebc1ca5f98cb16c00b6736e9a7fc314ed861143146b503af509aa025be5694a972e40e38e569a16ed72be9875b2d3979a8a0d763')
b2sums=('2001f9ac12bfa7369ad32842956cd21b2a786cd28133b6d3256e4aa77210c78ec6cac8a710ff8c2feb5a4797c1a33ce8c8c7dfabd84d7927c08bf8377e330300'
'SKIP'
'67efdc949e2234bc0ee1e428588a4617892664ca7481b2c239e9ecdd2c20e059bff1123c52310db3f5a8d0afbe62f4689903c86cf8b373f406c2f7fc60e52f10')
validpgpkeys=('ECCAC84C1BA08A6CC8E63FBBF22FB1D78A77AEAB' # Giancarlo Razzolini
'86CFFCA918CF3AF47147588051E8B148A9999C34') # Evangelos Foutras
# prepare() {
# cd $pkgname-$pkgver
# }
prepare() {
cd $pkgname-$pkgver
patch -p1 -i ../0001-use-gzip-for-compression-by-default.patch
}
check() {
make -C "$pkgname-$pkgver" check